The default bug view has changed. See this FAQ.

Make unicode-bidi:isolate the default for block elements instead of unicode-bidi:embed

RESOLVED FIXED in mozilla11

Status

()

Core
Layout: Text
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: Aharon (Vladimir) Lanin, Assigned: smontagu)

Tracking

(Blocks: 1 bug)

Trunk
mozilla11
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments, 4 obsolete attachments)

(Reporter)

Description

6 years ago
Created attachment 550374 [details]
block-as-inline.html

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/534.30 (KHTML, like Gecko) Chrome/12.0.742.122 Safari/534.30




Expected results:

When a block element is set to display:inline, it is desirable for it to behave bidi-wise as it would if it were display:inline-block. Under CSS2.1, there was no way to accomplish this, and unicode-bidi:embed was used for lack of a better choice. Now that we have unicode-bidi:isolate, it should be the default instead, as the HTML5 spec (http://dev.w3.org/html5/spec/Overview.html#non-replaced-elements) says it should be.
(Reporter)

Updated

6 years ago
Blocks: 613154
Depends on: 613149
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 7 → All
Hardware: x86_64 → All
(Assignee)

Comment 1

6 years ago
This is included in the patch for bug 613149 at https://bugzilla.mozilla.org/attachment.cgi?id=525116&action=diff#a/layout/style/html.css_sec2
(Assignee)

Updated

6 years ago
Attachment #550374 - Attachment mime type: text/plain → text/html
(Assignee)

Comment 2

6 years ago
The testcase is NOT fixed by bug 613149 -- I'll look into it.
Assignee: nobody → smontagu
(Reporter)

Comment 3

5 years ago
The change needs to be effective for "block" elements whether or not they have a dir attribute. The change already made in the stylesheet is not sufficient because the generic [dir] {unicode-bidi:embed;} is considered more specific and overrides it for "block" elements with a dir attribute. See http://www.w3.org/Bugs/Public/show_bug.cgi?id=14850.
(Assignee)

Comment 4

5 years ago
Created attachment 575189 [details] [diff] [review]
Patch

(In reply to Aharon (Vladimir) Lanin from comment #3)
> The change needs to be effective for "block" elements whether or not they
> have a dir attribute. The change already made in the stylesheet is not
> sufficient because the generic [dir] {unicode-bidi:embed;} is considered
> more specific and overrides it for "block" elements with a dir attribute.
> See http://www.w3.org/Bugs/Public/show_bug.cgi?id=14850.

Great catch! In spite of discussing this exact issue with Aharon a few days ago, the penny didn't drop for me that it was the cause of this bug.

The patch also adds unicode-bidi: -moz-isolate for a few elements from http://dev.w3.org/html5/spec/Overview.html#flow-content-1,
http://dev.w3.org/html5/spec/Overview.html#sections-and-headings,
http://dev.w3.org/html5/spec/Overview.html#lists, and
http://dev.w3.org/html5/spec/Overview.html#tables which didn't have it before: <figcaption>, <figure>, <legend>, and <summary>,
Attachment #575189 - Flags: review?(dbaron)
(Assignee)

Comment 5

5 years ago
Created attachment 575190 [details] [diff] [review]
Attachment 550374 [details] as reftest
Attachment #575190 - Flags: review?(dbaron)
(Assignee)

Comment 6

5 years ago
Created attachment 575192 [details] [diff] [review]
Attachment 550374 [details] as reftest, updated
Attachment #575190 - Attachment is obsolete: true
Attachment #575190 - Flags: review?(dbaron)
Attachment #575192 - Flags: review?(dbaron)
(Assignee)

Comment 7

5 years ago
Created attachment 577909 [details] [diff] [review]
Patch v.2

I found a bug in the patch through rniwa's tests in bug 706194: the rule for pre[dir] was overriding the rule for pre[dir="auto"] earlier in the file.
Attachment #575189 - Attachment is obsolete: true
Attachment #575189 - Flags: review?(dbaron)
Attachment #577909 - Flags: review?(dbaron)
(Assignee)

Comment 8

5 years ago
Created attachment 577910 [details] [diff] [review]
Patch v.2a
Attachment #577909 - Attachment is obsolete: true
Attachment #577909 - Flags: review?(dbaron)
Attachment #577910 - Flags: review?(dbaron)
(Assignee)

Comment 9

5 years ago
Created attachment 577911 [details] [diff] [review]
Patch v.2b

*sigh*
Attachment #577910 - Attachment is obsolete: true
Attachment #577910 - Flags: review?(dbaron)
Attachment #577911 - Flags: review?(dbaron)
Comment on attachment 577911 [details] [diff] [review]
Patch v.2b

r=dbaron, but perhaps update the spec quote to cite HTML5?
Attachment #577911 - Flags: review?(dbaron) → review+
Comment on attachment 575192 [details] [diff] [review]
Attachment 550374 [details] as reftest, updated

r=dbaron
Attachment #575192 - Flags: review?(dbaron) → review+
(Assignee)

Comment 12

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/e45974ac5499
https://hg.mozilla.org/integration/mozilla-inbound/rev/59844258e406
Assignee: smontagu → nobody
Flags: in-testsuite+
Target Milestone: --- → mozilla11
(Assignee)

Updated

5 years ago
Assignee: nobody → smontagu
https://hg.mozilla.org/mozilla-central/rev/e45974ac5499
https://hg.mozilla.org/mozilla-central/rev/59844258e406
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.