deleted drafts are shown as unread

RESOLVED DUPLICATE of bug 562748

Status

Thunderbird
Message Compose Window
--
minor
RESOLVED DUPLICATE of bug 562748
7 years ago
6 years ago

People

(Reporter: MikkCZ, Unassigned)

Tracking

(Depends on: 3 bugs, {regression})

x86_64
All
regression
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:5.0.1) Gecko/20100101 Firefox/5.0.1
Build ID: 20110707182747

Steps to reproduce:

I am using IMAP.
In preferences I have active automatic concept saving.


Actual results:

After I send a message, all automatically saved concepts are moved into trash, but they are also marked as unread.
(in TB3.x they haven't been marked as unread)


Expected results:

These concepts should be deleted completely (no trash), or at least they shouldn't be marked as unread.
It's confusing when you see unread messages in trash, but you don't know how they've got there.
OS: Windows 7 → All
Summary: deleted concepts are shown as unread → deleted drafts are shown as unread
Whiteboard: dupme
Depends on: 676249, 673400
Keywords: regression

Updated

7 years ago
Whiteboard: dupme
(In reply to Michal Stanke from comment #0)
> I am using IMAP.
> After I send a message, all automatically saved concepts are moved into trash, (snip)

Tb never copies/moves previous version of draft upon save, or final version of draft after send. Tb simply requests "uid xxx store Flags \Deleted" to IMAP server if IMAP.

Gmail IMAP? If yes, you are merely looking phenomenon reported to Bug 562748, aren't you?
(In reply to Michal Stanke from comment #0)
> Actual results:
(snip)
> but they are also marked as unread.
> (in TB3.x they haven't been marked as unread)

This part will disappear by bug 673400, because draft can be saved with Read status.
(In reply to WADA from comment #1)
> (In reply to Michal Stanke from comment #0)
> > I am using IMAP.
> > After I send a message, all automatically saved concepts are moved into trash, (snip)
> 
> Tb never copies/moves previous version of draft upon save, or final version
> of draft after send. Tb simply requests "uid xxx store Flags \Deleted" to
> IMAP server if IMAP.
> 
> Gmail IMAP? If yes, you are merely looking phenomenon reported to Bug
> 562748, aren't you?

Yes, that's true.
I don't care about moving into the Trash folder - the most annoying thing for me is that they are marked as unread.
Blocks: 562748
No longer blocks: 562748
Depends on: 562748

Comment 4

6 years ago
thanks for the update.
so, should this remain open?  Or, if we are certain it will be fixed by 
bug 562748 then why not close it as duplicate?

don't significantly affect workflow, so => minor
Severity: normal → minor
The other bug subsumes the symptoms described here. Thanks to everyone for the bug report and the help in finding the duplicate :).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 562748
You need to log in before you can comment on or make changes to this bug.