If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

select option list appears offset from its parent

RESOLVED DUPLICATE of bug 643758

Status

()

Core
General
RESOLVED DUPLICATE of bug 643758
6 years ago
6 years ago

People

(Reporter: jonathan.riley, Unassigned)

Tracking

5 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 6.1; Trident/5.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C)

Steps to reproduce:

Visit web pages that are commonly visited by other people in the building, attempt to use a select element to choose an option.


Actual results:

Option box occasionally appears 'offset' from its parent <select> element by about 2 rows. Options can be selected, but the display shows the cursor not being matched with the select box. 

This is occasional, and a page refresh resolves the problem.


Expected results:

option menu appears directly below the select element as usual

Comment 1

6 years ago
What are the URLs to those pages?
(Reporter)

Comment 2

6 years ago
The pages used are for an internal company system, but use nothing but basic HTML - the system hasn't changed since the days of IE6.

The issue is intermittently found on all web pages accessed through FF5, and appears to be just a display issue - the hover selection over each option is in the right place, but the menu itself is offset from the cursor.

We've repeated the problem at various different times on several completely different system setups. As an example, my office machine is running Windows 7, and another 3 machines are running XP. We do have regular access to a Ubuntu machine, but I haven't yet seen the bug on anything but a Windows machine.

Comment 3

6 years ago
Have you checked the pages using a validator without errors or warnings?

http://validator.w3.org/
http://htmlhelp.com/tools/validator/
http://www.validome.org/

If the pages don't use standard compliant code they may break. Firefox is all the time trying to get more and more standard compliant.
> If the pages don't use standard compliant code they may break. Firefox is
> all the time trying to get more and more standard compliant.

I don't see how that is relevant.  The dropdown menu of a <select> should
be displayed next to the button regardless of mode, or how non-complaint
the markup is in general.
Component: General → General
Product: Firefox → Core
QA Contact: general → general
Jonathan, please attach a screenshot showing the problem if you can.
(Reporter)

Comment 6

6 years ago
Because the problem is intermittent, it might be some time before I can. If someone in the office comes across the problem again, I'll grab it for you.
When it occurs, try to get the following information:
1. is Firefox in fullscreen mode?
2. was the current tab detached from another window at some point earlier?
3. is it reproducible?  ie, if you select an option and click on the button
   again is the menu still offset?
4. does the problem go away if you reload the page?
Please write the steps to reproduce this issue.Be specific!
Post urls where this issues occur.
Thanks!
Do you still encounter the issue?
(Reporter)

Comment 10

6 years ago
Yes, since upgrading to version 6, the issue has reoccured twice. A quick fix for this its to right click on the title bar of firefox, and remove one of the toolbars, then repeat to show the toolbar again; this solves the problem until the next time it happens.

We do use a custom toolbar for firefox in the office - would there be any chance that it would affect the way the browser draws lookup menus within a page?
It might.
Could you post a screenshot of the issue?
Thanks.
(Reporter)

Comment 12

6 years ago
Created attachment 554847 [details]
Example of lookup positioning error

as attached
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 643758
You need to log in before you can comment on or make changes to this bug.