Open Bug 643758 Opened 9 years ago Updated 11 days ago

[e10s] HTML5 validation popup doesn't close when the form element scrolls

Categories

(Firefox :: Tabbed Browser, defect, P3)

defect

Tracking

()

Tracking Status
e10s + ---
firefox-esr52 --- wontfix
firefox-esr60 --- wontfix
firefox61 --- wontfix
firefox62 --- wontfix
firefox63 --- wontfix
firefox64 --- fix-optional

People

(Reporter: accounts, Unassigned)

References

(Blocks 1 open bug, )

Details

(Keywords: polish, regression, testcase)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0) Gecko/20100101 Firefox/4.0

On submitting a blank form with, the form elements with the HTML5 attribute/value required="required" are highlighted in red and the first of such elements is given a tooltip saying "Please fill out this field."

When scrolling the page up or down with the middle mouse wheel, the tooltip remains in the same position relative to the window instead of the document. It should scroll with the document, following the element it points to, or be destroyed before the scroll. (Switching tabs or clicking anything else will cause it to be destroyed.)

Reproducible: Always

Steps to Reproduce:
1. Go to http://www.thetruth.com/riderapp/questionnaire.cfm
2. At the bottom of the page, hit Submit
3. The window should automatically scroll to the top, first tooltip highlgihted. Scroll the middle mouse wheel up or down.
Actual Results:  
Tooltip stays in fixed position on screen.

Expected Results:  
Tooltip should be destroyed.

Standard USB mouse, wheel set to scroll three lines per notch.
Confirmed on: Build identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0) Gecko/20100101 Firefox/4.0
Status: UNCONFIRMED → NEW
Ever confirmed: true
Yesterday the site displayed a tooltip but today does not, I think the source code for the website changed. Please provide another public working test case. Thanks.
OS: Windows XP → All
Status: NEW → UNCONFIRMED
Ever confirmed: false
Mozilla/5.0 (X11; Linux i686; rv:2.2a1pre) Gecko/20110407 Firefox/4.2a1pre

Reporter, the indicated tooltip is no longer present. Setting resolution to Resolved Invalid.

Feel free to reopen if you run into the problem again.

Thanks!
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → INVALID
reopened, here's a simple test page:
http://dl.dropbox.com/u/3358149/mozilla-test.html
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Version: unspecified → Trunk
Regression window:
Works:
http://hg.mozilla.org/mozilla-central/rev/136b3db3e75d
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b10pre) Gecko/20110119
Firefox/4.0b10pre ID:20110119185324
Broken:
http://hg.mozilla.org/mozilla-central/rev/9b6a73bdb237
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b10pre) Gecko/20110119
Firefox/4.0b10pre ID:20110119205425
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=136b3db3e75d&tochange=9b6a73bdb237
Suspected:
9c96acb338ca    Felipe Gomes — Bug 597723. Mouse scrolling shouldn't dismiss
panel notifications. r=enndeakin a=blocking-final
Blocks: 597723
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
Duplicate of this bug: 667506
Mozilla/5.0 (Windows NT 5.1; rv:7.0a1) Gecko/20110627 Firefox/7.0a1

On any page, the context menu invoked with right click remain active when scrolling the middle mouse wheel up and down. 
Changing the severity of this issue from trivial to normal.
Severity: trivial → normal
Duplicate of this bug: 675632
Duplicate of this bug: 676484
User Agent 	Mozilla/5.0 (Windows NT 5.1; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID 	20160711143737

I could not reproduce the issue on latest Nightly (50.0a1) so I will close the bug. If anyone can still reproduce the issue feel free to reopen the bug. 
Note: The testcases provided are no longer available so I used a new one: http://jsbin.com/vogeducijo/edit?html,output.
Status: NEW → RESOLVED
Closed: 9 years ago4 years ago
Resolution: --- → WORKSFORME
I cannot reproduce the problem with the testcase of comment #12 if e10s was disabled.
However, I can still reproduce the problem if e10s was enabled.
Status: RESOLVED → REOPENED
tracking-e10s: --- → ?
Resolution: WORKSFORME → ---
You're right. I tested on Windows XP which has the e10s disabled by default. 
On Windows 10 with e10s enabled I can reproduce the issue.
Summary: HTML5 input required tooltip doesn't destroy on middle-wheel scroll → [e10s] HTML5 input required tooltip doesn't destroy on middle-wheel scroll
Component: General → Layout: Form Controls
Product: Firefox → Core
Keywords: polish
Priority: -- → P3
So this isn't a regression in 50 (or even in 48) per se but is an e10s regression.

When should we focus on getting it fixed (ie. what release should we block)?
Flags: needinfo?(jmathies)
(In reply to Andrew Overholt [:overholt] from comment #15)
> So this isn't a regression in 50 (or even in 48) per se but is an e10s
> regression.
> 
> When should we focus on getting it fixed (ie. what release should we block)?

This was triaged as a P3 so lower priority. Basically it's up; to the module owner to prioritize.

This popup is handled by the firefox front end currently, so moving the bug over there. The popup isn't 'attached' to the form control, which we could consider the bug here.
Component: Layout: Form Controls → Tabbed Browser
Flags: needinfo?(jmathies)
Product: Core → Firefox
Jared, what do you think about this e10s-related bug.
Flags: needinfo?(jaws)
Felipe, do you know why the "scroll" event listener isn't being triggered at http://searchfox.org/mozilla-central/source/browser/modules/FormValidationHandler.jsm#138 ?

I tried adding a "scroll" event listener in FormSubmitObserver.jsm but that didn't trigger either. I attached it to this._content and element.ownerDocument.

We could probably change this to MozScrolledAreaChanged so it would have less of a perf hit while we're here.
Flags: needinfo?(jaws) → needinfo?(felipc)
Hm I don't know. I just did a test here attaching a scroll listener to gBrowser.selectedBrowser and it worked properly.
Flags: needinfo?(felipc)
Consensus is we can ship without a fix here but would still love one :)
Blocks: fxe10s
Status: REOPENED → NEW
Depends on: 1413092
Hardware: x86 → All
Summary: [e10s] HTML5 input required tooltip doesn't destroy on middle-wheel scroll → [e10s] HTML5 validation popup doesn't close when the form element scrolls
Marking fix-optional for 64. We could still take a patch for 65, and if it's verified and doesn't seem risky, could still take fixes for 64 as well.
Duplicate of this bug: 1504161
Duplicate of this bug: 1041529
Duplicate of this bug: 1426737
Duplicate of this bug: 1544704
Duplicate of this bug: 1546618
You need to log in before you can comment on or make changes to this bug.