Last Comment Bug 677044 - GIF animation drops all frames after a certain point
: GIF animation drops all frames after a certain point
Status: RESOLVED FIXED
[fixed by backout of bug 609499][qa+]
: regression, testcase
Product: Core
Classification: Components
Component: ImageLib (show other bugs)
: Trunk
: All All
: -- normal with 5 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
: 678746 679587 680437 680775 682223 (view as bug list)
Depends on:
Blocks: 609499 679587
  Show dependency treegraph
 
Reported: 2011-08-06 14:15 PDT by Matthew Turnbull [Bluefang]
Modified: 2011-12-14 21:02 PST (History)
27 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
unaffected
unaffected


Attachments
example GIF affected by this issue (3.44 MB, image/gif)
2011-08-06 14:15 PDT, Matthew Turnbull [Bluefang]
no flags Details
testcase 2 (should show 2 people colliding) (1.35 MB, image/gif)
2011-08-15 23:04 PDT, Daniel Holbert [:dholbert]
no flags Details
testcase, shall rotate around z axis, does not rotate (804.57 KB, image/gif)
2011-08-17 04:02 PDT, Stefan
no flags Details

Description Matthew Turnbull [Bluefang] 2011-08-06 14:15:02 PDT
Created attachment 551279 [details]
example GIF affected by this issue

Some GIF images drop all frames after a certain point, causing them to restart prematurely.

The regression range looks to be:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=be4b064f1159&tochange=5684f06138f3

From that list, the likely culprit is Bug 609499
Comment 1 Daniel Holbert [:dholbert] 2011-08-06 15:14:52 PDT
Confirming.
EXPECTED RESULTS: Chair spins, camera pans up/left to a woman's face.
ACTUAL RESULTS:  Chair only spins partway, & animation abruptly restarts.

Firefox 5 shows EXPECTED RESULTS. Nightly shows ACTUAL RESULTS. (Nightly never gets to the part of the animation with the woman's face)

Mozilla/5.0 (X11; Linux i686; rv:8.0a1) Gecko/20110806 Firefox/8.0a1
Comment 2 Fanolian 2011-08-07 05:38:51 PDT
It's happening on Windows platform (win7 at least) also.

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0a1) Gecko/20110806 Firefox/8.0a1
Comment 3 Alice0775 White 2011-08-13 13:19:51 PDT
*** Bug 678746 has been marked as a duplicate of this bug. ***
Comment 4 Thomas Ahlblom 2011-08-13 14:08:04 PDT
Local track down using Linux x86_64:

The first bad revision is:
changeset:   73789:67044ea27b53
user:        Joe Drew <joe@drew.ca>
date:        Wed Aug 03 15:19:19 2011 -0400
summary:     Bug 609499 - Some invalid GIF files don't terminate their LZW data with a 0-length block. Handle them better by handling them less specially. r=jrmuizel

http://hg.mozilla.org/mozilla-central/rev/67044ea27b53
Comment 5 Daniel Holbert [:dholbert] 2011-08-15 23:04:42 PDT
Created attachment 553375 [details]
testcase 2 (should show 2 people colliding)

Here's another affected gif.  Should show 2 people colliding, but Nightly just shows just a few frames of one person running at the beginning.
(source: http://www.reddit.com/r/funny/comments/jjr70/smoosh/ )
Comment 6 Stefan 2011-08-17 04:02:22 PDT
Created attachment 553725 [details]
testcase, shall rotate around z axis, does not rotate
Comment 7 Alice0775 White 2011-08-19 08:20:40 PDT
*** Bug 680437 has been marked as a duplicate of this bug. ***
Comment 8 Thomas Ahlblom 2011-08-21 11:05:14 PDT
*** Bug 680775 has been marked as a duplicate of this bug. ***
Comment 9 NightsoN Blaze 2011-08-21 18:06:45 PDT
Another affected gif:http://i.imgur.com/Yg5za.gif
Comment 10 Alice0775 White 2011-08-26 00:45:20 PDT
*** Bug 682223 has been marked as a duplicate of this bug. ***
Comment 11 Boris Zbarsky [:bz] 2011-08-26 08:49:47 PDT
joe, jeff, could you please take a look at this?  We need to figure out whether we fix this or back out bug 609499 on Aurora, imo.
Comment 12 Jeff Muizelaar [:jrmuizel] 2011-08-26 10:39:48 PDT
I've backed out 67044ea27b53 from FF8 (Aurora) and FF9 (Central):
http://hg.mozilla.org/mozilla-central/rev/d2cd9f583b0a
http://hg.mozilla.org/releases/mozilla-aurora/rev/b747b6535a03
Comment 13 jaitsu@ymail.com 2011-08-27 09:16:09 PDT
(In reply to Jeff Muizelaar [:jrmuizel] from comment #12)
> I've backed out 67044ea27b53 from FF8 (Aurora) and FF9 (Central):
> http://hg.mozilla.org/mozilla-central/rev/d2cd9f583b0a
> http://hg.mozilla.org/releases/mozilla-aurora/rev/b747b6535a03

That's fixed it, it seems
Comment 14 Hideo Oshima 2011-09-18 07:44:40 PDT
Why is this bug still open?
I think it can be marked as FIXED or WORKSFORME.
Comment 15 Scott Johnson (:jwir3) 2011-10-11 08:46:23 PDT
Since bug 609499 was backed out, this is no longer an issue.
Comment 16 Scott Johnson (:jwir3) 2011-10-11 08:46:55 PDT
*** Bug 679587 has been marked as a duplicate of this bug. ***
Comment 17 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2011-10-13 10:46:25 PDT
qa+ for verification using the attached testcase in comment 0.

Note You need to log in before you can comment on or make changes to this bug.