Context menus in sidebar

VERIFIED DUPLICATE of bug 41445

Status

P4
normal
VERIFIED DUPLICATE of bug 41445
18 years ago
14 years ago

People

(Reporter: matt, Assigned: matt)

Tracking

Trunk
mozilla1.0

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

18 years ago
need to add
delete tab
move up/down
print tab
stop

Comment 1

18 years ago
You see, Kevin? I told you this would happen. What's next after `Print Tab ...' 
and `Stop', I wonder? `Save As ...', perhaps? `Reload'? `Send Panel ...'? `Select 
All'? `Text Encoding'? `Use Style'?
Depends on: 66933
Hardware: PC → All
Summary: context menu's in sidebar → Context menus in sidebar

Comment 2

18 years ago
Actually, I'm the one asking for these as well. I understand your point, it's
very well taken. What I want to ensure is that we look at these for their
greatest utility for the average user. I would easily forgo the less common
functions in favor of the convenience items we're discussing. FYI - we've got a
couple of those you mention in there already. ;-)

Comment 3

18 years ago
Bah. Just fix bug 42758, and make menu items apply to the sidebar panel when it 
has focus. Then users will have *all* the utility and none of the clutter, and we 
won't have to take these silly items out again later.

Comment 4

18 years ago
Fair enough.

Comment 5

18 years ago
Some of these items (remove panel/move up/move down) would have to show up when 
you right-click the top of the tab, because some types of sidebar content don't 
have context menus at all.  Some of these items (stop, print) make more sense 
for when you right-click on the panel's content and the content happens to be 
HTML or something else that acts in a similar way.

Comment 6

18 years ago
Good point. Are these different behaviors possible?
(Assignee)

Updated

18 years ago
Keywords: nsbeta1

Comment 7

18 years ago
Marking p3, nsbeta1+, mozilla0.9.1
Keywords: nsbeta1 → nsbeta1+
Priority: -- → P3
Target Milestone: --- → mozilla0.9.1
(Assignee)

Comment 8

18 years ago
We have most of the context showing up now.
Need to add the ones that kevin wants.
as discussed in team meeting, moving all Nav+ team members nsbeta1+ P3 bugs from 
mozilla0.9.1 to mozilla0.9.2. 
Target Milestone: mozilla0.9.1 → mozilla0.9.2
sidebar triage: moving to mozilla1.0. 
Priority: P3 → P4
Target Milestone: mozilla0.9.2 → mozilla1.0

Comment 11

17 years ago
Revision of sidebar context menu items will be tracked by bug 41445.

*** This bug has been marked as a duplicate of 41445 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 12

17 years ago
verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.