Last Comment Bug 677256 - Migrate to Google Location Service v2
: Migrate to Google Location Service v2
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Geolocation (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla9
Assigned To: Doug Turner (:dougt)
:
Mentors:
Depends on: 668194 683157 716453 883071
Blocks: 702107
  Show dependency treegraph
 
Reported: 2011-08-08 08:31 PDT by Doug Turner (:dougt)
Modified: 2013-12-27 14:35 PST (History)
9 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
New network geolocation provider (8.52 KB, text/plain)
2011-08-08 08:55 PDT, Doug Turner (:dougt)
ben: review+
Details
diff w/ tests fix ups (31.01 KB, patch)
2011-08-11 10:41 PDT, Doug Turner (:dougt)
ben: review+
Details | Diff | Splinter Review

Description Doug Turner (:dougt) 2011-08-08 08:31:41 PDT
Google is implementing a simpler GLS service and deprecating the old one.  We will migrate.
Comment 1 Doug Turner (:dougt) 2011-08-08 08:55:15 PDT
Created attachment 551470 [details]
New network geolocation provider

This file replaces the existing NetworkGelocationProvider.js.  It is probably best to just review this file as the diff is going to be huge.

I removed HELD support.  I contacted the contributor and he is fine with it and will probably make an Add-on.

Because of the large code change, I reintented everything to 2 space.  The last file was a mess.
Comment 2 Curtis Koenig [:curtisk-use curtis.koenig+bzATgmail.com]] 2011-08-09 11:25:41 PDT
This may need to be looked at by the security/privacy teams adding kw: sec-review-needed so we can triage the bug and decide yes/no.
Comment 3 Asa Dotzler [:asa] 2011-08-09 11:26:57 PDT
Some web developers may have been using undocumented geo features that are going away with this update. We should probably add that to the "what's important for web developers" document for the release that carries this change.
Comment 4 Doug Turner (:dougt) 2011-08-11 10:41:05 PDT
Created attachment 552430 [details] [diff] [review]
diff w/ tests fix ups

ben, this is mostly the same as the file, but now in diff form.  I updated the tests to be compatible with the new format, and included a tri-lic header.
Comment 5 Ian Melven :imelven 2011-08-11 16:51:39 PDT
spoke to dougt earlier and confirmed the new version of the api does not introduce any new security or privacy risks compared to the existing one in use, and in fact sends back less data. removing sec-review-needed.
Comment 7 Marco Bonardo [::mak] 2011-08-19 03:11:31 PDT
http://hg.mozilla.org/mozilla-central/rev/861e1307c43c
Comment 8 Robert Kaiser 2011-08-19 08:07:48 PDT
(In reply to Doug Turner (:dougt) from comment #0)
> Google is implementing a simpler GLS service and deprecating the old one. 
> We will migrate.

Is that one still only for use of Firefox or can this one be used more publicly?
Just wondering if this could give bug 494421 some traction...
Comment 9 Doug Turner (:dougt) 2011-08-19 08:39:21 PDT
Mozilla Firefox only.
Comment 10 Robert Kaiser 2011-08-19 11:06:38 PDT
(In reply to Doug Turner (:dougt) from comment #9)
> Mozilla Firefox only.

OK, thanks, just wanted to clarify that.
Comment 11 Eric Shepherd [:sheppy] 2011-11-08 08:09:43 PST
Anyone aware of anything in particular that I should be documenting here? Is just saying that the back-end service has been updated enough, or are there specific details that need mentioning?
Comment 12 Doug Turner (:dougt) 2011-11-08 20:28:26 PST
nope.  killing the flags.
Comment 13 Ka-Hing Cheung 2011-11-17 22:02:13 PST
The new scheme unconditionally appends "?browser=firefox&sensor=true" to the end of geo.wifi.uri, which breaks manually setting that pref to a data uri to force a particular location. In my case I don't have wifi on this computer so I want to override the IP based detection with something more accurate. Is there a workaround?

Note You need to log in before you can comment on or make changes to this bug.