Last Comment Bug 677581 - Update in-tree libogg to 1.3.0
: Update in-tree libogg to 1.3.0
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Audio/Video (show other bugs)
: Trunk
: x86 Windows Vista
: -- normal (vote)
: mozilla10
Assigned To: Ralph Giles (:rillian) needinfo me
:
:
Mentors:
Depends on: 695240
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-09 09:56 PDT by Ian Melven :imelven
Modified: 2011-10-17 17:28 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
proposed patch (55.31 KB, patch)
2011-09-26 16:10 PDT, Ralph Giles (:rillian) needinfo me
kinetik: review+
Details | Diff | Splinter Review

Description Ian Melven :imelven 2011-08-09 09:56:24 PDT
latest libogg is : Version 1.3.0 (2011 August 4)

the release notes at http://svn.xiph.org/trunk/ogg/CHANGES say :

Version 1.2.1 (2010 November 01)

* Various build updates (see SVN)
* Add ogg_stream_pageout_fill() to API to allow applications
  greater explicit flexibility in page sizing.
* Documentation updates including multiplexing description,
  terminology and API (incl. ogg_packet_clear(),
  ogg_stream_pageout_fill())
=> * Correct possible buffer overwrite in stream encoding on 32 bit
  when a single packet exceed 250MB.
=> * Correct read-buffer overrun [without side effects] under
  similar circumstances.
* Update unit testing to work properly with new page spill
  heuristic.

and http://mxr.mozilla.org/mozilla-central/source/media/libogg/src/ says :

ogg_bitwise.c 22k Jun 15 2010
ogg_framing.c 66k Jun 15 2010

so it appears we should at least investigate to see if we have this issue.
Comment 1 Matthew Gregan [:kinetik] 2011-08-09 14:09:45 PDT
We picked those fixes up in bug 559344 when the in-tree libogg was updated to SVN r17287.

We should still update to 1.3.0, since it makes working out the answer to questions like this much easier.  I'll take the security flag off of this bug.
Comment 2 Ralph Giles (:rillian) needinfo me 2011-09-26 16:10:46 PDT
Created attachment 562573 [details] [diff] [review]
proposed patch

Brian, please check this patch on Solaris. I've changed the way the fixed width types are obtained there.
Comment 3 Ralph Giles (:rillian) needinfo me 2011-10-04 11:02:50 PDT
Review ping. I'll request checkin at the end of the week if we can't get verification on Solaris.
Comment 4 Ralph Giles (:rillian) needinfo me 2011-10-07 09:21:09 PDT
Comment on attachment 562573 [details] [diff] [review]
proposed patch

Timing out on Solaris review. Matthew, please review for check-in.
Comment 5 Matthew Gregan [:kinetik] 2011-10-10 17:53:31 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/df9d305be412
Comment 6 Marco Bonardo [::mak] 2011-10-11 02:39:53 PDT
https://hg.mozilla.org/mozilla-central/rev/df9d305be412
Comment 7 Ralph Giles (:rillian) needinfo me 2011-10-11 10:01:59 PDT
Thanks, Matthew.

Note You need to log in before you can comment on or make changes to this bug.