javascript strict warnings in navigatorDD.js

RESOLVED WORKSFORME

Status

()

Core
Drag and Drop
P4
normal
RESOLVED WORKSFORME
17 years ago
9 years ago

People

(Reporter: Henrik Gemal, Assigned: Joe Hewitt (gone))

Tracking

(Blocks: 1 bug)

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
JavaScript strict warning:
chrome://navigator/content/navigatorDD.js line 108: reference to undefined 
property aDragSession.sourceElement

JavaScript error:
chrome://navigator/content/navigatorDD.js line 249: aElement has no properties

Comment 1

17 years ago
over to ben, adding alecf.
Assignee: vishy → ben

Comment 2

17 years ago
-> xpapps dnd
Assignee: ben → blakeross
Component: XP Apps → XP Apps: Drag and Drop
QA Contact: sairuh → tpreston

Comment 3

17 years ago
Henrik, can you still reproduce this?
(Reporter)

Comment 4

17 years ago
yeps...
if you have folders in your personal toolbar. Then try to drag a subfolder of a 
folder in the personal toolbar to the content area you get:

JavaScript strict warning:
chrome://navigator/content/navigatorDD.js line 108: reference to undefined 
property aDragSession.sourceElement

JavaScript error:
chrome://navigator/content/navigatorDD.js line 249: aElement has no properties

build 20010426

Comment 5

17 years ago
those errors are due to bug 46456

Comment 6

17 years ago
then --> hewitt (owner of that bug)
Assignee: blakeross → hewitt
(Assignee)

Comment 7

17 years ago
these are fixed now
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
(Reporter)

Comment 8

17 years ago
I cant see the warnings with todays build 20010619.
Will reopen if I see them again.

Please add the following line to your prefs.js file, so we could avoid all 
these strict warning fixup...:
user_pref("javascript.options.strict", true);
Status: RESOLVED → VERIFIED
(Reporter)

Comment 9

17 years ago
Warning: anonymous function does not always return a value
Source File: chrome://navigator/content/navigatorDD.js
Line: 255, Column: 18

Please add the following line to your prefs.js file, so we could avoid all 
these strict warning fixup...:
user_pref("javascript.options.strict", true);
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
(Assignee)

Updated

16 years ago
Status: REOPENED → ASSIGNED
Priority: -- → P4
Target Milestone: --- → mozilla1.0
(Assignee)

Updated

16 years ago
Target Milestone: mozilla1.0 → Future
Reporter:  Can you reproduce this in a recent build?  I don't see a way to
easily reproduce this strict JS warning.  Also, looking at the function line 255
of
http://lxr.mozilla.org/seamonkey/source/xpfe/browser/resources/content/navigatorDD.js
is in, and the two adjoining functions, I do not see anything which would cause
this particular strict warning.

This bug hasn't been commented on in about 5 months.  It could be the above
strict warning is no longer valid.
(Reporter)

Comment 11

16 years ago
drag a link from a webpage to the Search button and you'll get:

Warning: reference to undefined property xferData[1]
Source File: chrome://navigator/content/navigatorDD.js
Line: 422

Warning: assignment to undeclared variable kNC_Name
Source File: chrome://navigator/content/navigator.js
Line: 665

Warning: assignment to undeclared variable defaultEngine
Source File: chrome://navigator/content/navigator.js
Line: 667

20020117

Comment 12

15 years ago
qa contact -> pmac
QA Contact: tpreston → pmac

Updated

10 years ago
Blocks: 296661

Comment 13

9 years ago
WFM:
Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.9.1b4pre) Gecko/20090305 SeaMonkey/2.0b1pre
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.