Closed Bug 678158 Opened 9 years ago Closed 9 years ago

File download gets cancelled before download even starts

Categories

(Toolkit :: Downloads API, defect)

8 Branch
x86_64
Windows 7
defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 416683

People

(Reporter: Hughman, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0a2) Gecko/20110804 Firefox/7.0a2
Build ID: 20110804042002

Steps to reproduce:

I was attempting to download
http://cdn01.foxitsoftware.com/pub/foxit/reader/desktop/win/5.x/5.0/enu/FoxitReader502.0718_enu_Setup.exe
from http://www.foxitsoftware.com/downloads/


Actual results:

The save or cancel dialogue appeared. While dialogue was open I am fairly certain the file was downloading in the background (from resource monitor and such).
However as soon as the "Save File" button is pressed the Downloads dialogue appears with the download cancelled.
Pressing the retry button on the download causes the download to but is deleted as soon as its finished (this bit may be related to bug 503649 but is not the reason I filed this since it was a finding while I was writing this).


Expected results:

The download should not get cancelled but download successfully.

I have seen this before a month back but thought nothing of it.
Also if I direct the download to Down Them All it works perfectly from the start (which is what I usually use).
I also tried a brand new profile in Aurora with same results.
Just ran into this again while downloading Google Chrome.

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0a2) Gecko/20110822 Firefox/8.0a2
Component: General → Download Manager
Product: Firefox → Toolkit
Version: 7 Branch → 8 Branch
After coming across it again while trying to download "Catalyst Software Suite", I tried using IE9 where I got the error "your current security setting do not allow this file to be downloaded".

After a while playing with the security settings in Internet Options (the windows/IE one) I found that changing "Launching applications and unsafe files" to "Prompt" instead of "Disabled" fixed the problem in both IE and Firefox. Its strange that this setting actually caused this in Firefox.


I am leaving this as UNCONFIRMED in case a developer wants to follow up on why this IE/Windows setting affected the ability to download files in Firefox. I also made this bug depend on bug 503649 as at this point I think it was about exactly the same problem.
Depends on: 503649
That may be a Vista/7 feature.

There already are several reports of this. See if bug 416683, bug 445158, bug 455928, bug 504804 cover your problem. If yes, duplicate this bug to the one that seems best.
Ill mark this a duplicate of the one with the same name. Bug 503649 should also be placed under it.

Someone really needs to add an alert/message that tells the user about why the download is not working. It was SERIOUSLY annoying for MONTHS there where I could not download ANY unsafe file using firefox's normal download system. I only realised how bad it was in the last 2 weeks because Down Them All stopped working in aurora.

Let me say that again for any who see this and do not understand:
IF I WAS A NORMAL USER AND NOT A PROGRAMMER MY SELF THIS WOULD HAVE MADE ME STOP USING THIS BROWSER!
After all, it was not doing what I wanted and was not giving any hints about why.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 416683
No longer depends on: 503649
I understand this. However, who did set that setting in Internet Options? Is it the Windows default?
I don't thin kits a windows default since its not the recommended setting. However I also do not think I would have changed that setting myself.

Given it started a few months ago it might have been related to IE8 to IE9 upgrade which also caused me to not be able to open any files over my network due to similar setting problem. So in the end I still have no idea how that setting got disabled.
So Firefox is obeying some system setting the same way as IE. I think that is correct. The only problem is that it does not provide indication why the download is blocked, which IE does. Also I think there are requests to make firefox ignore the setting if the user wishes so. Those are in the bugs I referenced.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.