Last Comment Bug 678184 - blank tooltips/popups/dialogs/selects blank on 10.6 (maybe after running a while?)
: blank tooltips/popups/dialogs/selects blank on 10.6 (maybe after running a wh...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Widget: Cocoa (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: mozilla8
Assigned To: Markus Stange [:mstange]
:
Mentors:
: 678680 678737 (view as bug list)
Depends on: 678002
Blocks: 668195
  Show dependency treegraph
 
Reported: 2011-08-11 06:57 PDT by Mike Shaver (:shaver -- probably not reading bugmail closely)
Modified: 2011-08-14 05:10 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Mike Shaver (:shaver -- probably not reading bugmail closely) 2011-08-11 06:57:25 PDT
I'm getting blank sheet-dialogs (f.e. an https auth dialog), blank @title tooltips, blank <select> dropdowns, some blank windows (like the install-an-addon one) and no window decoration around windows like prefs and about->nightly.

(With a persona applied the titlebar is black with black text and grey shadow, but that may be another bug.)

Running Aug 10 nightly.

Console shows a poopton (> 20/sec; they're interleaving which is a bit surprising) of 

Aug 11 09:19:09 waferthin [0x0-0x250250].org.mozilla.nightly[66303]: Thu Aug 11 09:19:09 waferthin.local firefox[66303] <Error>: kCGErrorCannotComplete: CGSDeviceGetGeometry: Invalid device window

Looks to have started just after I unsuspended, dunno if suspending causes it, or just having been running a while, or both.  I'll see if I can find out more.
Comment 1 Mike Shaver (:shaver -- probably not reading bugmail closely) 2011-08-11 07:46:48 PDT
Happened again after just 30 mins or so post-restart, so suspending isn't necessary.
Comment 2 Steven Michaud [:smichaud] (Retired) 2011-08-11 07:55:31 PDT
> (With a persona applied the titlebar is black with black text and
> grey shadow, but that may be another bug.)

Bug 678002.

This bug might have started with the patch for bug 668195, which first
appeared in the 2011-08-10 mozilla-central nightly.
Comment 3 Mike Shaver (:shaver -- probably not reading bugmail closely) 2011-08-11 08:08:38 PDT
Oh, forgot to add: I no longer get pointer changes when hovering over links or the resize widget.
Comment 4 Markus Stange [:mstange] 2011-08-11 08:54:37 PDT
STR:
1. Start browser
2. Apply persona
3. Open a new browser window (Cmd+N), close it (Cmd+W), open another one (Cmd+N)

Boom.

Thankfully this happens in debug builds, too.
Comment 5 Markus Stange [:mstange] 2011-08-11 10:34:53 PDT
The new patch in bug 678002 fixes this bug, too.
Comment 6 Markus Stange [:mstange] 2011-08-13 06:38:58 PDT
*** Bug 678680 has been marked as a duplicate of this bug. ***
Comment 7 Markus Stange [:mstange] 2011-08-13 13:10:12 PDT
*** Bug 678737 has been marked as a duplicate of this bug. ***
Comment 8 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2011-08-14 05:10:36 PDT
http://hg.mozilla.org/mozilla-central/rev/bcab3415d9ee

Note You need to log in before you can comment on or make changes to this bug.