With GL layers enabled, Fennec crashes on startup

RESOLVED FIXED in mozilla8

Status

()

Core
Graphics
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: ajuma, Assigned: ajuma)

Tracking

({regression})

Trunk
mozilla8
ARM
Android
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

6 years ago
On the current (August 11) Nightly, if GL Layers are enabled, Fennec always crashes on startup.

Regression range:
The crash occurs with http://hg.mozilla.org/mozilla-central/rev/93328efd3d77
but not with http://hg.mozilla.org/mozilla-central/rev/aee7dcfde223
We need to find the specific changeset.

A wild guess might be the changes for Bug 648484.
Keywords: regressionwindow-wanted
(Assignee)

Comment 2

6 years ago
(In reply to Benoit Girard (:BenWa) from comment #1)
> We need to find the specific changeset.
> 
> A wild guess might be the changes for Bug 648484.

Yes, this is indeed caused by one of the changes for Bug 648484. I'm working on finding which one.
Keywords: regressionwindow-wanted

Updated

6 years ago
Depends on: 648484
This is bad.  What's the crash?
(Assignee)

Comment 4

6 years ago
It turns out that as result of the changes to the interface of GetLayerManager in part 3 of bug 648484, calls in nsWindow.cpp to GetLayerManager(nsnull) were going to nsBaseWidget::GetLayerManager instead of nsWindow::GetLayerManager as defined in nsWindow.cpp. As a result, sGLContext in nsWindow.cpp was never initialized, and we crashed when attempting to dereference it in nsWindow::OnDraw.

Patch on its way.
(Assignee)

Comment 5

6 years ago
Created attachment 552502 [details] [diff] [review]
Fix interface of nsWindow::GetLayerManager on Android

This makes the interface of GetLayerManager on Android consistent with the changes introduced in Bug 648484.
Attachment #552502 - Flags: review?(jones.chris.g)
Comment on attachment 552502 [details] [diff] [review]
Fix interface of nsWindow::GetLayerManager on Android

Nice.
Attachment #552502 - Flags: review?(jones.chris.g) → review+
Blocks: 648484
No longer depends on: 648484
http://hg.mozilla.org/integration/mozilla-inbound/rev/5a85aeba5c59
Whiteboard: [inbound]
http://hg.mozilla.org/mozilla-central/rev/5a85aeba5c59
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Whiteboard: [inbound]
Target Milestone: --- → mozilla8
You need to log in before you can comment on or make changes to this bug.