Make mozconfig-find always return an absolute path

RESOLVED FIXED

Status

()

Core
Build Config
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: sid0, Assigned: sid0)

Tracking

unspecified
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox7 fixed, firefox8 unaffected)

Details

(Whiteboard: fixed-in-bs [qa-])

Attachments

(1 attachment)

Created attachment 552636 [details] [diff] [review]
patch v1

Relative mozconfigs are currently broken on comm-central because we don't fix the relative-ness for mozilla-central's mozconfig. I think the best approach to fix this is to make mozconfig-find return absolute paths.

The code's adapted from one of the patches in bug 341223, but conflicts with it. It applies on top of the patch in bug 675691.
Attachment #552636 - Flags: review?(ted.mielczarek)
(Assignee)

Comment 1

6 years ago
oh yeah, I tested this with
- gmake relative mozconfig
- pymake relative mozconfig
- gmake absolute mozconfig
- pymake absolute mozconfig

and everything worked as expected.
Attachment #552636 - Flags: review?(ted.mielczarek) → review+
(Assignee)

Comment 2

6 years ago
Well, turns out using hg diff -U 1 works wonders.

https://hg.mozilla.org/projects/build-system/rev/2fed775753c7
Whiteboard: fixed-in-bs
http://hg.mozilla.org/mozilla-central/rev/2fed775753c7
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Comment on attachment 552636 [details] [diff] [review]
patch v1

This is a build-config only regression that we found when generating the first Thunderbird beta for the 7.0 cycle and hit our l10n repacks.

Whilst we could probably somehow upgrade buildbot to sync something, we're not ready to do that yet (blocked by other thing), and this is a clear regression from previous cycles, so I'd really like to get this on mozilla-beta so our builds can progress nicely and we don't have to relbranch for each and every beta of the 7.0 cycle.
Attachment #552636 - Flags: approval-mozilla-beta?

Updated

6 years ago
Attachment #552636 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Comment 5

6 years ago
http://hg.mozilla.org/releases/mozilla-beta/rev/12587ddb5436
status-firefox7: --- → fixed
status-firefox8: --- → unaffected
Blocks: 682897
qa- as no QA fix verification needed
Whiteboard: fixed-in-bs → fixed-in-bs [qa-]
You need to log in before you can comment on or make changes to this bug.