Closed Bug 678649 Opened 8 years ago Closed 8 years ago

Today pane in Lion won't expand

Categories

(Calendar :: Calendar Views, defect)

Lightning 1.0b4
x86
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: jamesrome, Assigned: bv1578)

Details

(Whiteboard: [needed beta][no l10n impact])

Attachments

(3 files, 1 obsolete file)

Lion now allows all edges of a frame to resize it. If you resize the Today Pane by dragging the left bar rightwards, the pane disappears into a vertical bar a few pixels wide. If you click the today pane icon in the botton bar, the thin right edge appears and disappears, but there is no way to resize it because Lion thinks you are trying to resize the window.
This is Lightning 1.0.b5
Confirmed...why did I have to do this in my production profile :-}
Is there some manual workaround to get the pane back?
You could remove "localstore.rdf" from your profile folder to reset all UI elements.
We should fix this for the release so users don't lose their today pane. I think the best way to fix this is to automatically toggle the state of the status bar icon when the splitter is collapsed and restore it to minimum width if the icon is clicked again. I think we had a bug about something similar.

Decathlon, you probably know better than me whats best here. Maybe you can patch this?
Component: OS Integration → Calendar Views
Flags: blocking-calendar1.0+
QA Contact: os-integration → views
Whiteboard: [needed beta][no l10n impact]
Thinking to a different behavior for the Mac platform wouldn't be a right choice, would it? Like you described in comment #5 for the Mac and as usual for Win/Linux.

About the actual behavior, I think there was requests for hiding the splitter when it is collapsed (and toggle the today-pane button), but at the end the decision was taken by Christian Jansen here: bug 390982 comment #10 (in response to the previous comment).

I already have a simple fix (three code lines), but if we want make the comment #5 as the final behavior and not a temporary workaround (i.e. don't thinking to a future splitter for the MAC platform that is catchable when is near the window border), it would need to delete some other code.
Status: NEW → ASSIGNED
Assignee: nobody → bv1578
I've just realized that the same problem should exist for the folder pane in Thunderbird (panel to the left) unless that splitter is different from the todaypane splitter.
I can't test on MAC, and I can't find a specific bug for Lion OS, only bug 509359 seems related.
If Thunderbird has the same issue, it needs a different solution, maybe based on a splitter that is wider when in collapsed state than in open state in order to allow to grab and drag it.

Philipp, if you think the solution in comment 5 is right, I have a patch that works in that way, otherwise if it needs to modify the splitter, the patch must be assigned to someone that can test on a MAC.
Yes. I have now lost the folder bar too! This needs to be fixed!
I can't get it back either by deleting localstore.rdf. What do I do?
I filed this for TB also:
https://bugzilla.mozilla.org/show_bug.cgi?id=686040
(In reply to James Rome from comment #9)
> I can't get it back either by deleting localstore.rdf. What do I do?

You could try to add the following code in the userChrome.css file:


@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul")

#folderpane_splitter[state="collapsed"]{
   border-right: 30px solid red !important;
}


(it enlarges and "highlights" the split border in order to grab it)
It works on Win7, don't know on MAC.

For the userChrome.css file see:
http://kb.mozillazine.org/UserChrome.css
or
https://developer.mozilla.org/en/Thunderbird/Thunderbird_Configuration_Files
Deleting localstore.rdf should work, no idea whats going wrong there. 

I concur to Christian's comment and think we should solve it as I proposed in comment 5, or do it like Firefox does with the bookmarks sidebar and give it a min-width and not allow it to collapse. If the user wants to close it, they can do so by clicking the button or the X button on the today pane. I don't really mind which way, its up to you what you think is better.

Also, we could consider waiting for what the Thunderbird folks say in bug 686040. IIRC then we overlay into a sidebar container, so if they fix it for the folder pane, they could possibly fix it the same way for the sidebar container.
I've read about bug 609245 (the equivalent to this one for Thunderbird), and they found the problem with the splitter on Lion only lately. Until then, the bug was oriented to the definition of the panel's behavior when splitters collapse or menu-items/buttons/keys give an open/close command.

The behavior they want to implement is the same as described in comment #5 as they reported in bug 609245 comment #9 :

> > That said, I think being able to collapse the panes by dragging them is nice,
> > and a better way to bring them back would be like so: when the pane is
> > collapsed by dragging, uncheck the menu item in the View menu (e.g. View ->
> > Folder pane, or wherever it is), and then to bring it back, you can either
> > drag it back, or go into the view menu.
> 
> That sounds _way_ better to me, and I would love to review a patch that
> added that to all the platforms.  ;)

(that is the behavior of the message pane when in mail mode by pressing F8 key or by collapsing the splitter).

This patch implements the same behavior. The splitter now is open or collapsed, but never hidden. The todaypane button, the F11 key and the menu item toggle the panel status from collapsed to open or vice versa (so it doesn't need to move the splitter to open the panel).
It results a loss of functionality compared with the previous behavior, but now it doesn't need to store the splitter' status with the mode.

The patch doesn't solve the functionality problem of the splitters on Lion. IMHO it needs a different look for the splitter when collapsed on the Mac. For that we could wait what they will do on Thunderbird.
Attachment #561205 - Flags: review?(philipp)
This patch implements the behavior that the pane cannot be closed by dragging and can always be reopened using the button.

Given that on mac you can accidentally close the panel and won't be able to reopen it, I'd rather have users complaining that they cannot collapse the panel by dragging than them complaining they cannot get the panel back.

I'm going to check this in so we can do release builds, but I'd appreciate a review nevertheless.
Attachment #561205 - Attachment is obsolete: true
Attachment #561205 - Flags: review?(philipp)
Attachment #562003 - Flags: review?(bv1578)
Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/14a99024becb>
-> FIXED
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Trunk
Backported to comm-aurora <http://hg.mozilla.org/releases/comm-aurora/rev/9ee5e3330894>
Target Milestone: Trunk → 1.0b8
Backported to comm-beta <http://hg.mozilla.org/releases/comm-beta/rev/85518455c8e5>
Target Milestone: 1.0b8 → 1.0b7
(In reply to Philipp Kewisch [:Fallen] from comment #14)

> Given that on mac you can accidentally close the panel and won't be able to
> reopen it, I'd rather have users complaining that they cannot collapse the
> panel by dragging than them complaining they cannot get the panel back.

I'm not sure whether I've understood. Are you saying that on Mac, with the patch version 1, when you drag the splitter until collapsing the panel, then you can't get back the panel by clicking on the today button (or F11 key)? If so, it would work differently from the Win platform.
Yeah, just noticed :-( I forgot to do the theme changes for Linux/Windows...
Oh hey cool its not that bad. The today pane is a bit wider as a min-width, but thats something we can live with I feel. No extra action needed.

(In reply to Decathlon from comment #18)
> I'm not sure whether I've understood. Are you saying that on Mac, with the
> patch version 1, when you drag the splitter until collapsing the panel, then
> you can't get back the panel by clicking on the today button (or F11 key)?
> If so, it would work differently from the Win platform.
Yes, I believe I wasn't able to get it back. I can test again if you want?
(In reply to Philipp Kewisch [:Fallen] from comment #20)

> > I'm not sure whether I've understood. Are you saying that on Mac, with the
> > patch version 1, when you drag the splitter until collapsing the panel, then
> > you can't get back the panel by clicking on the today button (or F11 key)?
> > If so, it would work differently from the Win platform.
> Yes, I believe I wasn't able to get it back. I can test again if you want?

But when you collapse the splitter, does the todaypane button get unchecked? This is fundamental.

Could you try on Mac the patch v1 with the only addition of the min-width in the pinstripe theme?
Maybe on the Mac, the splitter state "collapsed" need to be removed instead of set to "open".
It's hard guessing without test or debug possibility ;-)

With the patch v2 the behavior is completely different from Thunderbird's one, e.g. the message pane (F8 key) or the implementation they are doing with bug 609245.
The patch works, but IMHO the behavior it's a lot reductive and maybe it should be applied only on the platform where there are problems (until a solution is being found).
(In reply to Decathlon from comment #21)
> (In reply to Philipp Kewisch [:Fallen] from comment #20)
> 
> > > I'm not sure whether I've understood. Are you saying that on Mac, with the
> > > patch version 1, when you drag the splitter until collapsing the panel, then
> > > you can't get back the panel by clicking on the today button (or F11 key)?
> > > If so, it would work differently from the Win platform.
> > Yes, I believe I wasn't able to get it back. I can test again if you want?
> 
> But when you collapse the splitter, does the todaypane button get unchecked?
> This is fundamental.
With my patch its impossible to collapse the todaypane unless you use the button.

> The patch works, but IMHO the behavior it's a lot reductive and maybe it
> should be applied only on the platform where there are problems (until a
> solution is being found).
I'm happy to back it out for the next release so we can fix it properly, I just needed something that works so Mark could spin the release builds.
Where do we obtain a patched version of Lightning?
Comment on attachment 562003 [details] [diff] [review]
patch - todaypane button expands the panel - v2

(In reply to Philipp Kewisch [:Fallen] from comment #22)

> > But when you collapse the splitter, does the todaypane button get unchecked?
> > This is fundamental.
> With my patch its impossible to collapse the todaypane unless you use the
> button.

Yes, I saw in the patch v2 you added the collapse="none", and the splitter "hidden" when you use the button. I meant with the patch v1. I think the splitter on Mac platform behaviors differently than on Win.

> I'm happy to back it out for the next release so we can fix it properly, I
> just needed something that works so Mark could spin the release builds.

OK. Let's do in this way then :-).

r+
Attachment #562003 - Flags: review?(bv1578) → review+
(In reply to James Rome from comment #23)
> Where do we obtain a patched version of Lightning?

http://ftp.mozilla.org/pub/mozilla.org/calendar/lightning/nightly/1.0b7-candidates/build1/
Says it is not compatible with TB 6.0.2
James, that is correct. It is a test build for Thunderbird 7 Beta.
Ok, I tested v1 again. Indeed, if you collapse the bar then it can be re-opened with the button. The only issue I have with v1 is that the splitter is always visible. While this is ok for platforms other than mac, on mac its kind of confusing. If you don't watch the today pane button, you constantly try to re-open the pane by trying to find the pixel where dragging the splitter is possible.

Do you think it would be a bad idea to hide the splitter when the pane is collapsed? This way you could close it with by collapsing, but are forced to look for alternatives (like the status bar button) when re-opening it.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: 1.0b7 → ---
(In reply to Philipp Kewisch [:Fallen] from comment #28)

> The only issue I have with v1 is that the splitter is always visible. 
> 
> Do you think it would be a bad idea to hide the splitter when the pane is
> collapsed?

I would prefer this solution rather than prevent the splitter to move until collapsing.
This patch forces the splitter to work in that way.

Otherwise we can wait what the Thunderbird's guys will do with splitters on Mac platform in bug 609245.
Attachment #563535 - Flags: review?(philipp)
Comment on attachment 563535 [details] [diff] [review]
hide the splitter when collapsed

Review of attachment 563535 [details] [diff] [review]:
-----------------------------------------------------------------

I like, r=philipp
Attachment #563535 - Flags: review?(philipp) → review+
Pushed to comm-central changeset ea1af2ee2c0f
Status: REOPENED → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Trunk
Backported to releases/comm-aurora changeset 42b1224f5087
Target Milestone: Trunk → 1.0b9
Backported to releases/comm-beta changeset b3fbc820d41d
Target Milestone: 1.0b9 → 1.0b8
Why can't we get this for the current build of Thunderbird -- 7.0.1?
James, I'm sorry but we don't do backports to previous releases due to lack of manpower. Thunderbird 8 / Lightning 1.0 is scheduled for November 8th and will contain this fix.

Also, note that the first fix is contained in Lightning 1.0b7 and should have stopped this bug from occurring. Can you confirm that?
in 1.0b7, now I can't close the pane all the way by dragging it to the right. I guess that is a fix.
(In reply to James Rome from comment #36)
> in 1.0b7, now I can't close the pane all the way by dragging it to the
> right. I guess that is a fix.

Yes, that was a quick-fix so its not gone. The next version will allow collapsing via drag. In the meanwhile, use the status icon to collapse the bar.
You need to log in before you can comment on or make changes to this bug.