Closed Bug 678707 Opened 11 years ago Closed 8 years ago

"Additional plugins are required to display all media on this page" doesn't allow user to know which plugins it is talking about

Categories

(Toolkit Graveyard :: Plugin Finder Service, defect)

All
Linux
defect
Not set
minor

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: jidanni, Unassigned)

References

()

Details

(Whiteboard: [dupeme])

Attachments

(1 file)

Regarding the
"Additional plugins are required to display all media on this page" message.

1. I had to type those words into this report because I cannot copy that
line with the mouse --- for -- no -- good -- reason.

2. Why don't you ADD A BUTTON to allow the user to examine what plug ins
you are talking about? All you offer is "INSTALL MISSING PLUGINS"...

When one goes to the doctors office he at least can look at the label of
the medicine before he eats it.

3. OK, we take the gamble to find out just what plugins you are talking
about, and if it can't find any ... WE STILL DON'T KNOW which ones you
were talking about.
That's right... I went through the whole trip with your window entitled "plugin finder service"... not only did I never learn what plugins I was supposedly looking for, I also was not allowed to copy one sliver of text with the mouse... apparently a scheme to lessen your bug reports...
Component: General → Plugin Finder Service
Product: Firefox → Toolkit
QA Contact: general → plugin.finder
Mozilla/5.0 (X11; Linux i686; rv:9.0a1) Gecko/20110818 Firefox/9.0a1

Hello.

This issue seems to be an enhancements issue-you can select the respective option under importance (instead of normal).

The text inside installation prompts can't be copied. If the "install missing plugin" search doesn't yield any results, you can try clicking on the image which also explains that a plugin needs to be installed. 

You can also use https://addons.mozilla.org/en-US/firefox/browse/type:7 to download mozilla plugins or check in the Add-ons manager, under "plugins" to see what plugins you already have installed.

On the following link you can check to see if your plugins are up to date.
https://www.mozilla.com/en-US/plugincheck/
(In reply to Virgil Dicu from comment #2)
> The text inside installation prompts can't be copied. If the "install missing
> plugin" search doesn't yield any results,
That is my point.

> you can try clicking on the image which also explains that a plugin
> needs to be installed.
You mean the button that I explicitly said I did not want to push?

As I said, the screen does not reveal what it is trying to do.

If you want the user to click the urls you are talking about then put
them on that screen.

But still the screen does not reveal what it packages it is trying to
install at the moment. etc. as I mentioned.
Severity: normal → minor
I can confirm it happens here too, using FF 3.6.20.

Steps to reproduce:
Browse a page that requires some plugin X that is not currently installed.

Because there is no X plugin installed, yellow bar appears saying
"Additional plugins are required to display all the media on this page."
with a button [Install Missing Plugins...].  Nothing identifies X, the
needed plugin.

If the user is reckless enough to click the button without any knowledge
of what plugin is to be installed, Plugin Finder Service window appears,
and says something like "Firefox is now searching available plugins."
(This may be approximate because the message is not visible long enough
to read it.)

In my case, the next message says "No suitable plugins were found."
Still nothing reveals the identity of X.  A link says "Find out more
about Plugins or manually find missing plugins."  The link only goes
to a generic add-ons search page.  Still nothing says what X is to
allow the user to search for it.

But if the user can hire a psychic to find out what plugin is missing,
the user can now manually install it.

I would dispute classifying this as an enhancement issue.  Any user
interface that is this catastrophically unhelpful, because it does not
give the user the single piece of relevant information from which the
whole interaction arises, is hard not to see as a bug.  In fact, it is
hard not to see it as deliberate, open hostility toward the user....

Whose idea was it to say "hmm, you're missing something" and make it
impossible to find out what that is?
(In reply to Chapman Flack from comment #4)
So I was not dreaming after all about Firefox's holier than thou attitude.
Version: 7 Branch → 8 Branch
I can confirm too it happens with FF 8.0, and nightly.
Why is it still in the UNCONFIRMED status?
Can someone who has the permission change the bug status to NEW (confirmed)?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Mozilla/5.0 (X11; Linux x86_64; rv:13.0a1) Gecko/20120208 Firefox/13.0a1

The problem still exists in trunk. 

Also, when I click "Find out more about Plugins or manually find missing plugins." I end up in http://www.mozilla.org/en-US/plugincheck/. That link doesn't let me manually find the missing plugins. And I still don't know what kind of plugin is missing.

I'm not interested in which plugins I have. I already know that. I want to know which plugins I'm missing.
Hardware: x86 → All
Version: 8 Branch → Trunk
Duplicate of bug 529523?
(In reply to Thomas Ahlblom from comment #7)
> Also, when I click "Find out more about Plugins or manually find missing
> plugins." I end up in http://www.mozilla.org/en-US/plugincheck/. That link
> doesn't let me manually find the missing plugins. And I still don't know
> what kind of plugin is missing.
> 
> I'm not interested in which plugins I have. I already know that. I want to
> know which plugins I'm missing.

This is a separate issue that is better suited for a new bug.  I filed bug 725760 for you.
The plugin finder never works on Linux, either on mozilla.org builds or distro ones, so showing the button is just an exercise in frustration. If the message gave a hint of the mime type or any other information about the plug-in, the user could perhaps do something about it.
AFAIC, the kind of plug-in required should be mentioned -- or at least the information should be easily reachable -- as soon as the top-banner notification appears, so as to let the user choose whether he or she actually wants to install it in the first place.
Duplicate of this bug: 697480
This bug appears to be a regression. The exact same problem was reported fixed as Bug 264282.

It is actually *worse* than it was before, because the workaround described in that bug no longer works. When you clicked "Find out more about Plugins or manually find missing plugins.", the URL used to include the mime type needed, but that is lost in the redirection.

That was obscure, but now there doesn't seem to be any way to get the information at all.
Why is it marked with importance of "minor"? 
In my opinion, the importance should be raised from minor to major.

minor is defined as:"minor loss of function, or other problem where easy workaround is present"

However, Due to this bug, users have a major loss of function because they can't find out what plugin they have to install, and therefore remain in a situation where they can't experience the page working as expected, because they are missing the plugin.

In addition, there is no easy workaround as I understand.

Second, I don't understand why does it take this bug so long to be fixed. 
It seems like an easy fix, just write the plugin name needed with the message or the dialog that appears, so the user can at least know what plugin it needs, and install it even manually if the Plugin Finder Service can't find it automatically.
The newly-introduced plugins.click_to_play in about:config seems to identify the plugin type in the box where you would click to play it. I haven't tried, but I wonder if that would show you the plugin name for a missing plugin? Or does the "you're missing a plugin and I'll never tell you which one" dialog come first?
(In reply to Chapman Flack from comment #15)
> The newly-introduced plugins.click_to_play in about:config seems to identify
> the plugin type in the box where you would click to play it. I haven't
> tried, but I wonder if that would show you the plugin name for a missing
> plugin? Or does the "you're missing a plugin and I'll never tell you which
> one" dialog come first?

No, there is no box in my case where I would click to play.

For example: opening www.twitter.com , when you are not logged in as a user, shows the "install missing plugins..." message bar at the top, but there is no media box to click to play, and you are left with no clue as to what plugin is needed and why the message appears.
BTW, it seems like a duplicate of bug 573846 .
This is also a duplicate of the earlier bug 467199
Whiteboard: [dupeme]
Attached image m.png
http://61.60.10.66/TTIC/jsp/main.jsp
What is the user supposed to do?
Bug 836415 has now removed the Plugin Finder Service (PFS) from Firefox. As a result, I'm closing all the remaining PFS bugs.

If you're getting this bugmail for an ancient PFS bug, the basic summary of the world today is:

* NPAPI plugins are a dying technology
* PFS was already restricted to assisting with only the 4 most common plugins
* Sites commonly provide their own UI for install a required plugin
* Mozilla is generally focusing on  improving the web platform so that proprietary plugins are not required.

(Note that "plugins" are a completely separate from "browser extensions", such at those found on addons.mozilla.org. The latter are not going anywhere, and are not impacted by the removal of PFS.)
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WONTFIX
Product: Toolkit → Toolkit Graveyard
Well why don't you tell the user that something is ancient.

Instead here in Firefox 50 you still just tell the user 'a plugin is needed'.

He still must turn to other people in the room,
to ask what he is supposed to do next.

There is no Learn More link.

So, if something is outdated, the user will never know.

All he knows is Firefox dropped the ball.

http://nantoutravel.mmweb.tw/index_s.php?ptype=ieb_map&town_name=jhongliao&map_type=0&L1_id=15/
You need to log in before you can comment on or make changes to this bug.