Closed Bug 678872 Opened 8 years ago Closed 8 years ago

"ASSERTION: aIndex is out of range" in nsSHistory::EvictOutOfRangeWindowContentViewers

Categories

(Core :: Document Navigation, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 680344

People

(Reporter: jruderman, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: assertion, regression, testcase)

Attachments

(2 files)

Attached file testcase
###!!! ASSERTION: aIndex is out of range: 'aIndex < mLength', file docshell/shistory/src/nsSHistory.cpp, line 969

Might be related to bug 610952.
Attached file stack trace
This is a regression.  I don't see this on an Aurora build.
OS: Mac OS X → All
Hardware: x86_64 → All
Can we find a regression range?  This is an issue in Fx8, right?  Requesting tracking for the regression....
I'm bisecting this now.
The first bad revision is:
changeset:   70744:580ddd2f1267
user:        Kyle Huey <khuey@kylehuey.com>
date:        Tue Jun 07 13:04:13 2011 -0700
summary:     Bug 662200: Update the session history object for reloads. r=bz
This is fixed by the patch in Bug 680344 (which, incidentally, was filed with a slightly modified version of this bug's test case).
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 680344
Component: DOM → Document Navigation
QA Contact: general → docshell
Depends on: 693020
No longer blocks: 662200
No longer depends on: 693020
You need to log in before you can comment on or make changes to this bug.