Last Comment Bug 678954 - Build failure with --enable-dtrace on Solaris
: Build failure with --enable-dtrace on Solaris
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: All Solaris
: -- normal (vote)
: mozilla9
Assigned To: Steve Fink [:sfink] [:s:] (PTO Sep23-28)
:
:
Mentors:
Depends on:
Blocks: 574403
  Show dependency treegraph
 
Reported: 2011-08-15 02:47 PDT by Ginn Chen
Modified: 2011-08-23 01:40 PDT (History)
2 users (show)
mounir: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Add back OBJS to dtrace command (966 bytes, patch)
2011-08-17 13:36 PDT, Steve Fink [:sfink] [:s:] (PTO Sep23-28)
no flags Details | Diff | Splinter Review
Add back OBJS to dtrace command (2.06 KB, patch)
2011-08-19 12:07 PDT, Steve Fink [:sfink] [:s:] (PTO Sep23-28)
khuey: review+
Details | Diff | Splinter Review

Description Ginn Chen 2011-08-15 02:47:57 PDT
It was broken since Bug 574403 was committed.

While linking js

Undefined			first referenced
 symbol  			    in file
__dtraceenabled_javascript___execute__start ../libjs_static.a(jsinvoke.o)
__dtrace_javascript___execute__start ../libjs_static.a(jsinvoke.o)
__dtrace_javascript___function__return ../libjs_static.a(jsprobes.o)
__dtraceenabled_javascript___object__finalize ../libjs_static.a(jsgc.o)
__dtraceenabled_javascript___execute__done ../libjs_static.a(jsinvoke.o)
__dtrace_javascript___object__create ../libjs_static.a(jsapi.o)
__dtraceenabled_javascript___function__entry ../libjs_static.a(jsarray.o)
__dtrace_javascript___execute__done ../libjs_static.a(jsinvoke.o)
__dtraceenabled_javascript___function__return ../libjs_static.a(jsarray.o)
__dtrace_javascript___object__finalize ../libjs_static.a(jsgc.o)
__dtraceenabled_javascript___object__create ../libjs_static.a(jsapi.o)
__dtrace_javascript___function__entry ../libjs_static.a(jsprobes.o)
ld: fatal: symbol referencing errors. No output written to js

It is incorrect to remove $(OBJS) from dtrace command line.
Please add #if LINUX, if you have to do so.
Comment 1 Steve Fink [:sfink] [:s:] (PTO Sep23-28) 2011-08-17 13:36:47 PDT
Created attachment 553885 [details] [diff] [review]
Add back OBJS to dtrace command

Does this work for you? systemtap's dtrace seems fine with the object files, now that they are no longer necessary.
Comment 2 Ginn Chen 2011-08-17 23:19:37 PDT
It works, thanks!

BTW: You need to keep config/rules.mk and js/src/config/rules.mk identical.
Comment 3 Steve Fink [:sfink] [:s:] (PTO Sep23-28) 2011-08-19 12:07:56 PDT
Created attachment 554500 [details] [diff] [review]
Add back OBJS to dtrace command
Comment 4 Mounir Lamouri (:mounir) 2011-08-23 01:40:19 PDT
http://hg.mozilla.org/mozilla-central/rev/713be47aa3f9

Note You need to log in before you can comment on or make changes to this bug.