Last Comment Bug 679334 - LINK : fatal error LNK1266: error reading instrumentation file 'firefox.pgd'; File not found
: LINK : fatal error LNK1266: error reading instrumentation file 'firefox.pgd';...
Status: RESOLVED FIXED
fixed-in-bs
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: x86_64 Windows Server 2008
: -- normal (vote)
: mozilla9
Assigned To: Mike Hommey [:glandium]
:
Mentors:
: 669031 678409 (view as bug list)
Depends on:
Blocks: tracking_win64 659942
  Show dependency treegraph
 
Reported: 2011-08-16 06:31 PDT by Armen Zambrano [:armenzg] (EDT/UTC-4)
Modified: 2011-08-31 23:18 PDT (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Don't remove pgd files, but clear them with pgomgr instead (1.33 KB, patch)
2011-08-16 07:06 PDT, Mike Hommey [:glandium]
ted: review+
Details | Diff | Splinter Review
Don't remove pgd files, but clear them with pgomgr instead. NSPR part (1.05 KB, patch)
2011-08-16 07:09 PDT, Mike Hommey [:glandium]
no flags Details | Diff | Splinter Review
Don't remove pgd files, but clear them with pgomgr instead (1.34 KB, patch)
2011-08-16 07:19 PDT, Mike Hommey [:glandium]
ted: review+
Details | Diff | Splinter Review
Don't remove pgd files, but clear them with pgomgr instead. NSPR part (1.05 KB, patch)
2011-08-16 07:19 PDT, Mike Hommey [:glandium]
ted: review+
Details | Diff | Splinter Review

Description Armen Zambrano [:armenzg] (EDT/UTC-4) 2011-08-16 06:31:53 PDT
I am hitting this compilation error on the Windows 64-bit builds and is keeping the builds red.

nsBrowserApp.obj 
LINK : fatal error LNK1266: error reading instrumentation file 'firefox.pgd'; File not found
make[6]: Leaving directory `/e/builds/moz2_slave/m-cen-w64/build/obj-firefox/browser/app'
make[6]: *** [firefox.exe] Error 242
make[5]: Leaving directory `/e/builds/moz2_slave/m-cen-w64/build/obj-firefox/browser'
make[4]: Leaving directory `/e/builds/moz2_slave/m-cen-w64/build/obj-firefox'
make[5]: *** [libs] Error 2
make[4]: *** [libs_tier_app] Error 2
make[3]: Leaving directory `/e/builds/moz2_slave/m-cen-w64/build/obj-firefox'
make[3]: *** [tier_app] Error 2
make[2]: *** [default] Error 2
make[2]: Leaving directory `/e/builds/moz2_slave/m-cen-w64/build/obj-firefox'
make[1]: Leaving directory `/e/builds/moz2_slave/m-cen-w64/build'
make[1]: *** [realbuild] Error 2
make: *** [profiledbuild] Error 2
Comment 1 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2011-08-16 06:33:54 PDT
Probably related to Bug 669031 ...
Comment 2 Mike Hommey [:glandium] 2011-08-16 06:34:27 PDT
It kind of partially looks like bug 678409, in that you somehow don't have profiling information, and the linker fails because of it, while it shouldn't.
Comment 3 Mike Hommey [:glandium] 2011-08-16 06:35:54 PDT
(In reply to Kyle Huey [:khuey] (khuey@mozilla.com) from comment #1)
> Probably related to Bug 669031 ...

Not quite, in that the file missing from bug 669031 is pretty much expected not to be there. Firefox.pgd being missing is not. Except if PROFILE_GEN_SCRIPT does nothing.
Comment 4 Armen Zambrano [:armenzg] (EDT/UTC-4) 2011-08-16 06:43:30 PDT
I have also hit this in the last week:
"LINK : fatal error LNK1266: error reading instrumentation file 'plc4.pgd'; File not found"

If I disable PGO on win64 do you think it will make us complete the step?
Comment 5 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2011-08-16 06:46:18 PDT
Yes, because this step will never be run.
Comment 6 Mike Hommey [:glandium] 2011-08-16 06:48:02 PDT
(In reply to Armen Zambrano G. [:armenzg] - Release Engineer from comment #4)
> I have also hit this in the last week:
> "LINK : fatal error LNK1266: error reading instrumentation file 'plc4.pgd';
> File not found"
> 
> If I disable PGO on win64 do you think it will make us complete the step?

You can also clobber.
Comment 7 Mike Hommey [:glandium] 2011-08-16 07:01:52 PDT
*** Bug 678409 has been marked as a duplicate of this bug. ***
Comment 8 Mike Hommey [:glandium] 2011-08-16 07:06:35 PDT
Created attachment 553458 [details] [diff] [review]
Don't remove pgd files, but clear them with pgomgr instead
Comment 9 Mike Hommey [:glandium] 2011-08-16 07:09:44 PDT
Created attachment 553461 [details] [diff] [review]
Don't remove pgd files, but clear them with pgomgr instead. NSPR part
Comment 10 Ted Mielczarek [:ted.mielczarek] 2011-08-16 07:10:38 PDT
Comment on attachment 553458 [details] [diff] [review]
Don't remove pgd files, but clear them with pgomgr instead

Review of attachment 553458 [details] [diff] [review]:
-----------------------------------------------------------------

::: config/rules.mk
@@ +903,5 @@
>  ifdef MOZ_PROFILE_GENERATE
>  # Clean up profiling data during PROFILE_GENERATE phase
>  export::
>  ifeq ($(OS_ARCH)_$(GNU_CC), WINNT_)
> +	-$(for pgd,$(wildcard *.pgd),pgomgr -clear $(pgd);)

ITYM $(foreach) here. Will this blow up if there are no pgd files present? (This will expand to just - then.)
Comment 11 Mike Hommey [:glandium] 2011-08-16 07:19:04 PDT
Created attachment 553464 [details] [diff] [review]
Don't remove pgd files, but clear them with pgomgr instead
Comment 12 Mike Hommey [:glandium] 2011-08-16 07:19:52 PDT
Created attachment 553465 [details] [diff] [review]
Don't remove pgd files, but clear them with pgomgr instead. NSPR part
Comment 13 Armen Zambrano [:armenzg] (EDT/UTC-4) 2011-08-16 13:09:36 PDT
Clobbering did the job. Clobberer was not working on staging.

This is not a valid bug anymore but I see patches. Feel free to close it or whatever you feel is right.
Comment 14 Armen Zambrano [:armenzg] (EDT/UTC-4) 2011-08-24 06:47:45 PDT
I have hit this again in production.

I have marked every builder to clobber since they could have objdirs from when they were connected to staging.
Comment 15 Ted Mielczarek [:ted.mielczarek] 2011-08-24 12:29:17 PDT
NSPR patch:
Checking in config/rules.mk;
/cvsroot/mozilla/nsprpub/config/rules.mk,v  <--  rules.mk
new revision: 3.82; previous revision: 3.81
done
Comment 16 Mike Hommey [:glandium] 2011-08-28 22:39:52 PDT
http://hg.mozilla.org/projects/build-system/rev/e25c18bf42d2
Comment 17 Mike Hommey [:glandium] 2011-08-29 10:29:55 PDT
http://hg.mozilla.org/projects/build-system/rev/14497b5c651e
Comment 18 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2011-08-31 08:03:13 PDT
http://hg.mozilla.org/mozilla-central/rev/e25c18bf42d2
Comment 19 Mike Hommey [:glandium] 2011-08-31 23:18:30 PDT
*** Bug 669031 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.