Creation of new bookmark folders doesn't work

VERIFIED DUPLICATE of bug 68539

Status

VERIFIED DUPLICATE of bug 68539
18 years ago
14 years ago

People

(Reporter: matt, Assigned: bugs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Build 2001020708, Linux 2.4.1 i686, RedHat 6.1

When trying to create a new bookmark folder, a "NewFolder" items
appears with a textfield for changing its name.  I can go and change
the name like I want, but when I press ENTER, the name reverts back to 
"NewFolder"; additionally, when I exit from the bookmark manager and
enter it again, there is no new folder.

Looking at the Mozilla output when I try to create a folder, I see
this:

************************************************************
* Call to xpconnect wrapped JSObject produced this error:  *
[Exception... "[JavaScript Error: "field.select is not a function" {file:
"chrome://global/content/treeBindings.xml#treecell-indented-folder-inline-edit-base.setMode()"
line: 17}] [nsIController::doCommand]"  nsresult: "0x80570021
(NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame ::
chrome://global/content/globalOverlay.js :: goDoCommand :: line 71"  data: yes]
************************************************************
An error occurred executing the cmd_newfolder command

In the "setMode" method of treecell-indented-folder-inline-edit-base
in file chrome/toolkit/content/global/treeBindings.xml, the variable
"field" is set as following:

Line 79:
              var field = document.createElementNS(kXULNS, "textfield");

And then select() is invoked on "field" several lines later.
I can confirm this on windows also with
user agent: Mozilla/5.0 (Windows; U; Win98; en-US; 0.8) Gecko/20010210
build: 2001021008

Changing OS to All
OS: Linux → All

Comment 2

18 years ago
reporter, do you reproduce this as described in bug 68539? if yes then it's a
dup (I know this bug is older but we have a tracking bug already tracking bug
68538). If not please give us exact steps to reproduce. It works for me if I
don't have to scroll before changing the name and hitting ENTER.
This really is a duplicate of bug 68539.

*** This bug has been marked as a duplicate of 68539 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 4

18 years ago
Yup, this is indeed a duplicate.  Marking as VERIFIED.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.