Closed Bug 679545 Opened 9 years ago Closed 9 years ago

Add mn and sw locales to Tuxedo and product details

Categories

(Webtools :: Bouncer, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 679350

People

(Reporter: aki, Unassigned)

References

Details

+++ This bug was initially created as a clone of Bug #624658 +++

7.0b1 has 2 new locales, so adding bouncer entries using Tuxedo REST API didn't work as expected.

Could you add them to Tuxedo?
Thanks!
Per wenzel on IRC, the changes needed are in product-details, and locales need to be added by l10n-drivers.

http://viewvc.svn.mozilla.org/vc/libs/product-details/localeDetails.class.php?revision=91980&view=markup

Once this is sorted out, we will want to add a step in the new-locale process for this.
Assignee: nobody → registration
Component: Bouncer → Registration & Management
Product: Webtools → Mozilla Localizations
QA Contact: bouncer → registration
Version: Trunk → unspecified
The revision log in http://viewvc.svn.mozilla.org/vc/libs/product-details/localeDetails.class.php?view=log is full of people that are not l10n-drivers.

Also, Mozilla Localizations is the completely wrong product for this.

Moving this back and resolving this as dupe of bug 679350, which I had filed right when I added the locales.

Regarding process, RiK has an action item to rewrite product details, I guess we should actually spec what we hope that system to do in terms of getting data. Fred, RiK, where is a good place to do that?
Assignee: registration → nobody
Status: NEW → RESOLVED
Closed: 9 years ago
Component: Registration & Management → Bouncer
Product: Mozilla Localizations → Webtools
QA Contact: registration → bouncer
Resolution: --- → DUPLICATE
Version: unspecified → Trunk
Duplicate of bug: 679350
(In reply to Axel Hecht [:Pike] from comment #2)
> Regarding process, RiK has an action item to rewrite product details, I
> guess we should actually spec what we hope that system to do in terms of
> getting data. Fred, RiK, where is a good place to do that?

Do you want to start a wiki page or etherpad and jot down some of the things you want product-details to do? There are many users of this as a common data source (I know of at least most of our localizable websites for the L10n part of this, version info is consumed by Input and Socorro, and region data is pulled in by AMO(?)), and all of them need to weigh in to make sure a rewrite doesn't make it worse than it is now :).
About product-details, I've created https://wiki.mozilla.org/Mozilla.com/ProductDetailsRefactoring

Gonna spread it around tomorrow.
You need to log in before you can comment on or make changes to this bug.