After upgrading to Firefox 6 and Thunderbird 6, Add-ons Manager has no category set

VERIFIED FIXED in Firefox 7

Status

()

Toolkit
Add-ons Manager
VERIFIED FIXED
6 years ago
4 years ago

People

(Reporter: kohei, Assigned: mossop)

Tracking

(4 keywords)

6 Branch
mozilla9
regression, relnote, verified-aurora, verified-beta
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox7+ fixed, firefox8+ fixed)

Details

(Whiteboard: [inbound][qa!])

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

6 years ago
I've found an issue on the Add-ons Manager that after upgrading from Firefox 5.0.1 to Firefox 6. The Loading throbber continues spinning, and the content is never loaded. The Get Add-ons tab is not selected. 

The content was loaded when I manually selected the Get Add-ons tab.

This also happens with Thunderbird 6. Some users are tweeting about this.
(Reporter)

Updated

6 years ago
Summary: After upgrading to Firefox 6 and Thunderbird 6, Add-ons Manager is broken → After upgrading to Firefox 6 and Thunderbird 6, Add-ons Manager looks broken (the content is never loaded until the Get Add-ons tab is selected)
(Assignee)

Comment 1

6 years ago
What extensions do you have installed? Do any messages appear in the error console when this happens?
(Reporter)

Comment 2

6 years ago
Created attachment 553685 [details]
screenshot

The issue is reproducible with a clean profile.

Error Console says:
> Error: aViewId is null
> Source File: chrome://mozapps/content/extensions/extensions.js
> Line: 573

Comment 3

6 years ago
Does this go away once you click on a different tab (i.e. Plugins) and then click back?  We're seeing some reports of this on SUMO, also.

https://support.mozilla.com/en-US/questions/862087
(Reporter)

Comment 4

6 years ago
(In reply to [:Cww] from comment #3)
> Does this go away once you click on a different tab (i.e. Plugins) and then
> click back?

That's right.
Summary: After upgrading to Firefox 6 and Thunderbird 6, Add-ons Manager looks broken (the content is never loaded until the Get Add-ons tab is selected) → After upgrading to Firefox 6 and Thunderbird 6, Add-ons Manager looks broken (the content is never loaded until a tab is selected)
(Assignee)

Comment 5

6 years ago
I just tested with a clean profile and couldn't reproduce this.
Keywords: qawanted
(Assignee)

Comment 6

6 years ago
Actually, what were the STR for testing with a clean profile?
(Reporter)

Comment 7

6 years ago
To reproduce the issue,
1. create a profile with Firefox 5
2. upgrade to Firefox 6
3. open the Add-ons Manager

A new profile created with Firefox 6 has no issue.
(Reporter)

Comment 8

6 years ago
Created attachment 553690 [details] [diff] [review]
quick fix
Dave, I think that it has been caused by bug 595848 when we have changed the id of the categories to be able to support custom add-on types. The id is not valid in Firefox 6 so no category is selected. I haven't proven it yet, but will do right in a couple of minutes.
As mentioned in my last comment it's a regression from bug 595848. It only happens once after an upgrade and a click on the category fixes it. So it's not a major issue but should we mention it in the release notes?
Blocks: 595848
Severity: major → normal
Keywords: qawanted → regression, relnote
Summary: After upgrading to Firefox 6 and Thunderbird 6, Add-ons Manager looks broken (the content is never loaded until a tab is selected) → After upgrading to Firefox 6 and Thunderbird 6, Add-ons Manager has no category set
Version: unspecified → 6 Branch
As an additional note, this will also happen if you downgrade Firefox.

Comment 12

6 years ago
If have tried this on 
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:6.0) Gecko/20100101 Firefox/6.0,
Mozilla/5.0 (Windows NT 6.1; rv:6.0) Gecko/20100101 Firefox/6.0
and also on
Mozilla/5.0 (Windows NT 6.0; rv:6.0) Gecko/20100101 Firefox/6.0

and the issue is reproducible, but only once as Henrik described in the previous comments.
Duplicate of this bug: 679635

Comment 14

6 years ago
As mentioned in bug 679635 it also stops happening if you visit addons.mozilla.org

Comment 15

6 years ago
Add to release notes.
(Assignee)

Comment 16

6 years ago
Created attachment 553851 [details] [diff] [review]
patch rev 1

The comment suggests I meant to do this check in the first place, the test accurately tests the situation we're hitting.
Assignee: nobody → dtownsend
Attachment #553690 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #553851 - Flags: review?(bmcbride)

Comment 17

6 years ago
in my testing the other day, v5 -> v6 is borked, but v6 -> later was fine
(Assignee)

Comment 18

6 years ago
(In reply to aja+bugzilla from comment #17)
> in my testing the other day, v5 -> v6 is borked, but v6 -> later was fine

Yeah, this will only reveal itself the first time you move from v4 or v5 to v6 or later
(Assignee)

Comment 19

6 years ago
Which does make this somewhat low priority to fix, but the fix is simple and the test is worthwhile.
Attachment #553851 - Flags: review?(bmcbride) → review+
(Reporter)

Comment 20

6 years ago
Many people are saying the Add-ons Manager *is* broken. They won't read relnotes.

Comment 21

6 years ago
Right. But what they probably *will* do is click around, which will fix it.
(Assignee)

Comment 22

6 years ago
http://hg.mozilla.org/integration/mozilla-inbound/rev/3de869db521c
Flags: in-testsuite+
Whiteboard: [inbound]
http://hg.mozilla.org/mozilla-central/rev/3de869db521c
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla9
Duplicate of this bug: 680178

Updated

6 years ago
Duplicate of this bug: 679811
Given that this bug is part of the release notes I wanna ask if we can get track it for Firefox 8 and Firefox 7.
tracking-firefox7: --- → ?
tracking-firefox8: --- → ?
(Assignee)

Comment 27

6 years ago
Comment on attachment 553851 [details] [diff] [review]
patch rev 1

Yeah. This is broken UI that is easily corrected with this very simple risk free patch. It would be good to take this on the branches for those that haven't happened to open the add-ons manager in the 6 week period that that have Firefox 6 for.
Attachment #553851 - Flags: approval-mozilla-beta?
Attachment #553851 - Flags: approval-mozilla-aurora?

Updated

6 years ago
Attachment #553851 - Flags: approval-mozilla-beta?
Attachment #553851 - Flags: approval-mozilla-beta+
Attachment #553851 - Flags: approval-mozilla-aurora?
Attachment #553851 - Flags: approval-mozilla-aurora+
(Assignee)

Comment 28

6 years ago
http://hg.mozilla.org/releases/mozilla-aurora/rev/463cbb911c43
http://hg.mozilla.org/releases/mozilla-beta/rev/c55dabfdbc8b
status-firefox7: --- → fixed
status-firefox8: --- → fixed
tracking-firefox7: ? → +
tracking-firefox8: ? → +
Duplicate of this bug: 685276
qa+ for verification in Firefox 7 and 8
Whiteboard: [inbound] → [inbound][qa+]

Comment 31

6 years ago
I was able to get around this as well by starting up in safe mode, hitting the check for updates button, exiting, then starting up normally.

Comment 32

6 years ago
I have verified this on Windows 7 x86, Mac OS X 10.6, Windows Xp and Ubuntu 11.04 x64 by upgrading from Firefox 5.0.1 to 6.0 to 6.0.2 to 7.0RC to Latest Aurora and to Latest Nightly with the same profile and the issue isn't reproduced anymore.

The Add-ons manager is loading every time.
Status: RESOLVED → VERIFIED
Keywords: verified-aurora, verified-beta
Whiteboard: [inbound][qa+] → [inbound][qa!]
You need to log in before you can comment on or make changes to this bug.