Closed Bug 679669 Opened 9 years ago Closed 9 years ago

WCAP calendars not working; Update calendar for nsIUnicharStreamLoader changes

Categories

(Calendar :: Provider: WCAP, defect, major)

Lightning 1.0b5
defect
Not set
major

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: serge.spader, Assigned: Fallen)

References

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:6.0) Gecko/20100101 Firefox/6.0
Build ID: 20110811165603

Steps to reproduce:

Today I upgraded to TB6 

I downgrade with TB5 and it works



Actual results:

My wcap doesn't work.
It works with Google Calendar.

warning log :

Avertissement : Une erreur est survenue lors de la lecture de données de l'agenda : xxxxxx. Cependant, l'erreur est certainement mineure ; le programme va donc essayer de poursuivre. Code d'erreur : 0x804a0201. Description : Accès au serveur « agenda-wcap.xxx.xxx:81 » impossible !

and 

Avertissement : Une erreur est survenue lors de la lecture de données de l'agenda : xxxxxx. Cependant, l'erreur est certainement mineure ; le programme va donc essayer de poursuivre. Code d'erreur : READ_FAILED. Description : READ_FAILED
Severity: normal → major
Hardware: All → x86
Error console messages? this might be bug 679655.
Seing similar behaviour with error code 0x804a0201.
Actual connection to server does not seem to be an issue,  several wcap /version.wcap calls hit the server and yields result (seen in wireshark) but I can't see any login attempts. 

I do see some 'not a function' and undefined lines in wcap logs though:

unicharData.readString is not a function
getSessionId_resp_(): undefined




### WCAP log entry: 2011/08/17 17:26:06 Europe/Paris isDate=0
login queue: 5

### WCAP log entry: 2011/08/17 17:26:06 Europe/Paris isDate=0
[calWcapNetworkRequest id=c0d79878-c101-4029-8647-9697a5b3543e-2, parent-id=<none> (http://debug-server/version.wcap?fmt-out=text%2Fcalendar), isPending=true, status=NS_OK]
status: NS_OK

### WCAP log entry: 2011/08/17 17:26:06 Europe/Paris isDate=0
[calWcapNetworkRequest id=c0d79878-c101-4029-8647-9697a5b3543e-2, parent-id=<none> (http://debug-server/version.wcap?fmt-out=text%2Fcalendar), isPending=false, status=NS_OK]
response exec: unicharData.readString is not a function

### WCAP log entry: 2011/08/17 17:26:06 Europe/Paris isDate=0
[context-id: fb7974c0-59c3-4b75-ad0d-01bc7cf00796, uri: http://debug@debug-server/, not logged in]
getSessionId_resp_(): undefined

### WCAP log entry: 2011/08/17 17:26:06 Europe/Paris isDate=0
[context-id: fb7974c0-59c3-4b75-ad0d-01bc7cf00796, uri: http://debug@debug-server/, not logged in]
unlocked login queue.

### WCAP log entry: 2011/08/17 17:26:06 Europe/Paris isDate=0
[calWcapRequest id=c0d79878-c101-4029-8647-9697a5b3543e-1, parent-id=<none> ([context-id: fb7974c0-59c3-4b75-ad0d-01bc7cf00796, uri: http://debug@debug-server/, not logged in, default calendar]
getItems():
	itemFilter=0x1ffff,
	maxResults=0,
	rangeStart=20110731T103400Z,
	rangeEnd=20110911T103400Z), isPending=false, status=[Exception... "Cannot access server debug-server!"  nsresult: "0x804a0201 (<unknown>)"  location: "JS frame :: resource://calendar/modules/calUtils.jsm -> file:///C:/Users/Jens/AppData/Roaming/Thunderbird/Profiles/m3x8mbdl.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calWcapSession.js :: netResp :: line 480"  data: no]]
response exec: [Exception... "Cannot access server debug-server!"  nsresult: "0x804a0201 (<unknown>)"  location: "JS frame :: resource://calendar/modules/calUtils.jsm -> file:///C:/Users/Jens/AppData/Roaming/Thunderbird/Profiles/m3x8mbdl.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calWcapSession.js :: netResp :: line 480"  data: no]
Hmm its possible that some function was removed and we didn't notice. Could you collect all not-a-function messages?
sorry for my sloppy wording.
I did see those two repeatedly (4 times within 2 seconds) in that sequence and each time with reference to version.wcap.
unicharData.readString is not a function
getSessionId_resp_(): undefined

I'll try to downgrade to pre4 tomorrow as soon as I get hands on some system.
Is there any known show-stopper  to that approach (i.e. some conflict or dependency between TB6 and pre4)?
pre4? Thunderbird 6 requires Lightning 1.0b5.

It seems bug 541496 is the culprit. This is going to bite us in multiple places :-(
Assignee: nobody → philipp
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Summary: wcap on Lightning 1.0b5 not working since TB6 → Update calendar for nsIUnicharStreamLoader changes
Attached patch Fix - v1Splinter Review
Untested, but should work
Attachment #553897 - Flags: review?(matthew.mecca)
Flags: blocking-calendar1.0+
Hotfix from attachment 553897 [details] [diff] [review] works for me (at first glance).
Thanks Philipp!
I can confirm that the patch is working on my configuration too.
I hope it will be included in the next release of the addon.
Thanks a lot for this very prompt reactivity.
Comment on attachment 553897 [details] [diff] [review]
Fix - v1

Review of attachment 553897 [details] [diff] [review]:
-----------------------------------------------------------------

I don't have a wcap server to test with, but based on comment #7 and comment #8 it works.

Looks good, r=mmecca

::: calendar/base/content/calendar-dnd-listener.js
@@ +330,5 @@
>                          return charset;
>                      },
>  
> +                    onStreamComplete: function(loader, context, status, unicharString) {
> +                        var parser = Components.classes["@mozilla.org/calendar/ics-parser;1"]

Might as well change the var to let while you're here.
Attachment #553897 - Flags: review?(matthew.mecca) → review+
I can confirm that the patch is working on my computer and on my coworkers configuration
Duplicate of this bug: 680791
the patch is working on my configuration too.

Thanks
Pushed to comm-central rev 2be064842b07
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Hardware: x86 → All
Resolution: --- → FIXED
Target Milestone: --- → Trunk
I think this patch should be ported back to comm-aurora and comm-beta to be included in the next release.
Duplicate of this bug: 682826
Summary: Update calendar for nsIUnicharStreamLoader changes → WCAP calendars not working; Update calendar for nsIUnicharStreamLoader changes
I agree, I'll be doing this together with some more changesets from trunk soon.
Backported to comm-aurora <http://hg.mozilla.org/releases/comm-aurora/rev/71929579880e>
Target Milestone: Trunk → 1.0b6
Target Milestone is set to 1.0b6 but the patch has not been checked in to comm-beta.
Good catch, thanks!
Duplicate of this bug: 685502
Could someone who uses WCAP calendar help to verify that it still works in Thunderbird 7? Last time the problem with WCAP calendar were always reported after the final Thunderbird releases (i.e. too late).

Thunderbird 7 Beta is available for testing from http://www.mozilla.org/en-US/thunderbird/all-beta.html

First Lightning 1.0b7pre test builds are available for testing from https://ftp.mozilla.org/pub/mozilla.org/calendar/lightning/tinderbox-builds/comm-beta/
I'm willing to test to make sure WCAP works before the next releases.

Here are my findings using the latest builds:

https://bugzilla.mozilla.org/show_bug.cgi?id=686273
I did a quick test and was able to read my wcap calendars

(In reply to Stefan Sitter from comment #22)
> Could someone who uses WCAP calendar help to verify that it still works in
> Thunderbird 7? Last time the problem with WCAP calendar were always reported
> after the final Thunderbird releases (i.e. too late).
> 
> Thunderbird 7 Beta is available for testing from
> http://www.mozilla.org/en-US/thunderbird/all-beta.html
> 
> First Lightning 1.0b7pre test builds are available for testing from
> https://ftp.mozilla.org/pub/mozilla.org/calendar/lightning/tinderbox-builds/
> comm-beta/
I think the problem is still there. I tried under several applications (Thunderbird, Seamonkey, Sunbird, Spicebird - in Sunbird and in Thunderbird 2, similarly works well the WCAL) to watch wcal calendars. It works well (perfect!!) under Thunderbird 2 and shows on the web subscribed calendars of me. But the higher (of course older than the actual v.) L. versions could not show the wcal cals: the WCAL calendar line simply disappears from the list (when i try to turn on the calendar). In contrast to the Sunbird and the Thunderbird 2 cases, the disappearance of the subscribed wcal calendar next to the current T&L version now does not require a password to retrieve the WCAL calendar.
Are you getting the specific error message shown here in the error console? Or any other messages?
There are no any message, any popup, nothing. The - theoretically - added calendar simply disappears from the list. 
(Meanwhile, I have cloned the well-functioning virtual machine clone with the OK Thunderbird 2 + old v. of. Lightning. In the new clone I upgraded to the current Thunderbird and Lightning versions. All wcals former listed and displayed  disappeared after the upgrade and adding the calendars again works not: it seems everything ok while the ad new calendar process, but after it it's not asking for the user id and password to acces the gives server URL adress, and the added calender whoooosh disappear (the password remembering function is turned off to see, if it will ask for the uid&pwd or not).
Please clarify what you mean with WCAL calendar. This bug is about accessing a Sun Java Calendar Server instance using the Web Calendar Access Protocol (WCAP). Otherwise I would suggest to retest using the most current release of Thunderbird + Lightning instead of using ancient applications and file a new bug for your specific problem.
Sun™ Convergence mailserver (http://webmail.somedomain.hu) with a Sun Java System Calendar Express (http://calserver.somedomain.hu:port), its possible to connect not only on the web, but even with client software like Thunderbird etc. using of POP3 and IMAP protocol, too. The calendars output format of the server for Lightning is http://calserv2.somedomain.hu:someport/?calid=UID@somedomain.hu:calendarname  with the process Add new calendar>>Sun Java System Calendar Server(WCAP) etc.
Sorry, in the former post i see now, i write WCAL, but  wanted write WCAP. (I'm not english people, and my english knowlidge is terrible bad.)
You need to log in before you can comment on or make changes to this bug.