Open Bug 680080 Opened 8 years ago Updated 3 years ago

Provide mobile client (Thunderbird for Android)

Categories

(Thunderbird :: General, enhancement)

ARM
Android
enhancement
Not set

Tracking

(Not tracked)

REOPENED

People

(Reporter: pwd.mozilla, Unassigned)

References

(Depends on 1 open bug, Blocks 1 open bug, )

Details

(Keywords: student-project, Whiteboard: [gs][not planned])

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:9.0a1) Gecko/20110817 Firefox/9.0a1
Build ID: 20110817061121

Steps to reproduce:

Firefox for Mobile has been a resounding success and that's going up against many very good competitors, however in regards to email clients, there's a very limited number of competitors available on the mobile platforms and even fewer that pack a real punch. As such, Mozilla should piggyback the hard work that makes the platform so versatile and roll out a mobile (Android) client.
OS: Windows 7 → Android
Hardware: x86 → ARM
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 658570
Blocks: 658570
Reopened, see comment in bug 658570
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: DUPLICATE → ---
All of the leading mobile clients are propriatary, so Mozilla is obligated to work on this. Porting lightning would be a must and a problem. The UI would need a complete redo.
Depends on: 788897
Whiteboard: [gs]
Best alternative so far seems to be K9 mail, though it doesn't handle (i.e. make easy to use and manage) large amounts of folders (100+) well enough yet.
https://play.google.com/store/apps/details?id=com.fsck.k9&hl=en
http://code.google.com/p/k9mail/
https://github.com/k9mail

...Thunderbird would still be my favorite option if available.
I was using K9, however one day it stopped fetching my emails and the developers seem to have no idea why.
Gaia Mail (from Firefox OS) should be usable on Firefox Android I guess.
also this is a duplicate of bug 658570
We need a great email app for Android. The app that is pre-loaded on current tablets is bare bones with no option to manage an address book. It can collect addresses from incoming email, but provides no way to edit, add or remove them. K-9 Mail is only slightly better in that it syncs with Google contact list, but has none of its own. I have several hundred addresses in Thunderbird on my computer and would like to have awfully functional email app that actually works. I want Thunderbird for Android. Mozilla needs to raise this "bug" to the highest priority and get it done.
Just to be clear ... there is no progress in blocker bug 788897 nearing 2 years, and this is not in the plans of anyone currently active the community.  When we get postings in support forums requesting this, they are pointed to https://getsatisfaction.com/mozilla_messaging/topics/thunderbird_client_for_android which diplomatically says, "don't count on seeing it".
Severity: normal → enhancement
Whiteboard: [gs] → [gs][not planned]
This was added to the Mozilla Student Projects list (https://github.com/Mozilla-Student-Projects/Projects-Tracker/issues/96) yesterday. Someone should add the "student-project" keyword to also add it to this page: https://bugzil.la/kw:student-project. There seems to be many people interested in working on this project.
Keywords: student-project
I doubt if this is viable as a student project.
(In reply to Kent James (:rkent) from comment #11)
> I doubt if this is viable as a student project.

Considering no progress has been made in about 5 years, if a student group were to get a start on this project, then other developers might become more interested. They could at least get Thunderbird to build on Android with a basic UI, possibility reusing some of the components of Firefox for Android.
You need to log in before you can comment on or make changes to this bug.