Status

enhancement
RESOLVED DUPLICATE of bug 1126005
8 years ago
4 years ago

People

(Reporter: gandalf, Unassigned)

Tracking

Details

(Whiteboard: [ux][Triage 2015-04-17])

Mozillians should allow me to build my project contribution record in form of badges. Open Badges provide the infra for that.

Things like:
 - I participated in AllHands 2010
 - I worked on Glow project
 - I localized Fennec 4

would help strengthen our meritocratic system where people could learn what the contributor represents basing on his experience
Word, this'll be great to have in once OpenBadges and our own hierarchy of development is set up. Though, it's going to be....awhile.
Assignee: nobody → mozaakash
Severity: normal → enhancement
Target Milestone: --- → Future
Component: mozillians.org → Phonebook
Product: Websites → Community Tools
QA Contact: mozillians-org → phonebook
Target Milestone: Future → ---
Version: unspecified → other
OS: Mac OS X → All
Hardware: x86 → All
Since I just got CC'd on this, I'll offer my US$0.02 - use django-badger as a starting point:

https://github.com/lmorchard/django-badger

Open Badges offers *some* infrastructure for making badges portable. But, the OBI project doesn't offer a complete solution for issuing badges. And, even if/when they do, it might not be quite the right fit for mozillians
(In reply to Les Orchard [:lorchard] from comment #2)
> Since I just got CC'd on this, I'll offer my US$0.02 - use django-badger as
> a starting point:
> 
> https://github.com/lmorchard/django-badger
> 
> Open Badges offers *some* infrastructure for making badges portable. But,
> the OBI project doesn't offer a complete solution for issuing badges. And,
> even if/when they do, it might not be quite the right fit for mozillians

Thanks for the info; I'm not the most well-read person on badge issuance, so what potential miscues with direction could happen there? One other question, are you planning on supporting OBI with django-badger at some point?
(In reply to Aakash Desai [:aakashd] from comment #3)

> Thanks for the info; I'm not the most well-read person on badge issuance, so
> what potential miscues with direction could happen there?

The OBI team is working on OpenBadger [1], which will be a "lightweight badge issuing platform". It'll be targeted as an easy-to-use service for issuers. Not sure if that will be a good match for Mozillians or not, yet.

[1] https://github.com/mozilla/openbadger/wiki

> One other question, are you planning on supporting OBI with django-badger at 
> some point?

django-badger supports it now, in that it produces the JSON metadata format supported by the OBI. You can push badges into the OBI backpack from my demo site - http://badg.us/
This bug is very similar to bug 679407, so there might be potential to combine efforts.
See Also: → 679407
FWIW, I've started hacking django-badger into MDN as a side project:

https://github.com/lmorchard/kuma/compare/badger-play
(In reply to William Reynolds [:williamr] from comment #5)
> This bug is very similar to bug 679407, so there might be potential to
> combine efforts.

So, in terms of the Open Badge Infrastructure, I think what you're looking for is something like:

1) MDN as Issuer - http://openbadges.org/en-US/issuer.html

2) Mozillians as Displayer - http://openbadges.org/en-US/displayer.html
Assignee: mozaakash → nobody
Summary: openbadges integration → Display badges on profiles
FWIW, I've been thinking about how to integrate badges from the OBI backpack with Mozillians for awhile now. I was planning to volunteer a pull request at some point, because I think I pretty well understand the moving parts on both sides of the equation.

I left this comment on the openbadges project, discussing a few tweaks to that project which I think would make things work better for mozillians as well:

https://github.com/mozilla/openbadges/issues/131#issuecomment-13150225
FWIW, I submitted a pull request to start this feature:

https://github.com/mozilla/mozillians/pull/390
Whiteboard: [ux]
Why has this feature been on hold for two months without any public reasoning? Seems a bit sad, having Badges on Mozillians would be pretty cool.
Hi, Dirkjan - 

It's certainly not on hold. We're making good progress on it, even if it's not being reported back to this bug. A lot of discussion is happening on the Mozillians mailing list:

https://groups.google.com/forum/?fromgroups#!forum/mozilla.mozillians

... and you can browse that list for more information.
Ah, good. Would have been useful if there was something on this bug or the pull request mentioned in comment 9, though.
In Q2 we hope to redesign the homepage and user profile pages, and both will include some badges from badges.mozilla.org. There's a draft spec for the badges functionality here:

https://wiki.mozilla.org/Mozillians/Releases/Badges

Next steps on this bug are to connect Mozillians Developers with People Who Know Stuff About Badges. The core Mozillians devs are out of the office this week; I'll be working to set up that meeting next week.

If you're interested in contributing...
* There'll be some work integrating badges with Mozillians, and
* The more badges available when we launch this feature, the better!
(In reply to Dirkjan Ochtman (:djc) from comment #12)
> Ah, good. Would have been useful if there was something on this bug or the
> pull request mentioned in comment 9, though.

FWIW, to be honest, my pull request was totally unsolicited and there's no guarantee that what I did will be right for the project in the end. I just spent a Saturday afternoon giving a try at hacking Open Badges support into Mozillians and submitted the result as a conversation starter.

That said, I do think using backpack.openbadges.org is the right approach. If Mozillians can display badges from there, it'll be able to catch badges awarded from many sites around the Mozilla network (eg. badges.mozilla.org, MDN, SUMO, etc)
(In reply to Justin Crawford [:hoosteeno] from comment #13)
> In Q2 we hope to redesign the homepage and user profile pages, and both will
> include some badges from badges.mozilla.org. There's a draft spec for the
> badges functionality here:
> 
> https://wiki.mozilla.org/Mozillians/Releases/Badges

One thing I would say to tweak that spec is don't focus on badges.mozilla.org in particular.

badges.m.o and many other sites (eg. MDN, SUMO, etc) will issue Open Badges and push them to backpack.openbadges.org. And in that backpack, there's a Displayer API where a site like Mozillians can get access to a user's badges originating from any number of issuers.

Also as a bonus, I think some of the features listed in the spec can be "outsourced" to the Open Badges Backpack. (ie. general badge management & visibility)

One last thing that might be cool, maybe for future expansion: Index profiles by badges. That way, from Mozillians, you could search for people by the badges they've publicly shared.
(In reply to Les Orchard [:lorchard] from comment #15)
> One thing I would say to tweak that spec is don't focus on
> badges.mozilla.org in particular.
> 
> badges.m.o and many other sites (eg. MDN, SUMO, etc) will issue Open Badges
> and push them to backpack.openbadges.org. And in that backpack, there's a
> Displayer API where a site like Mozillians can get access to a user's badges
> originating from any number of issuers.

Thanks for the tweak idea to not focus on badges.mozilla.org in particular. I was thinking that badges.mozilla.org would be the issuer of all Mozilla related badges, but from your comment it sounds like individual Mozilla sites (eg MDN, SUMO, etc) will issue badges and they will push them to backpack.openbadges.org. Is that correct?

> Also as a bonus, I think some of the features listed in the spec can be
> "outsourced" to the Open Badges Backpack. (ie. general badge management &
> visibility)
> 
> One last thing that might be cool, maybe for future expansion: Index
> profiles by badges. That way, from Mozillians, you could search for people
> by the badges they've publicly shared.

Agreed about the "outsourced" functionality that the Open Badges Backpack provides.

I also like the idea of indexing profiles by badges as a future expansion.
(In reply to William Reynolds [:williamr] from comment #16)

> Thanks for the tweak idea to not focus on badges.mozilla.org in particular.
> I was thinking that badges.mozilla.org would be the issuer of all Mozilla
> related badges, but from your comment it sounds like individual Mozilla
> sites (eg MDN, SUMO, etc) will issue badges and they will push them to
> backpack.openbadges.org. Is that correct?

Correct - badges.mozilla.org is *not* meant to be the single issuing service for all of Mozilla. It's meant for groups & efforts that want to issue badges, but don't have or want a site capable of issuing them. (ie. webdev, IT, etc). So, badges.mozilla.org will be just one Mozilla-related Open Badge issuer of many.

For example, there's webmaker.org on the Foundation side. They issue badges from their own site, using their own service, and push them into the Backpack. They have nothing to do with badges.mozilla.org

Someday, MDN will issue badges (bug 671908) from the developer.mozilla.org domain. That will use the Backpack, and not badges.mozilla.org
Depends on: 1058905
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Whiteboard: [ux] → [ux][Triage 2015-04-17]
Duplicate of bug: 1126005
You need to log in before you can comment on or make changes to this bug.