Closed Bug 680396 Opened 9 years ago Closed 9 years ago

TB 6.0 crash when sending or saving an e-mail with attached PDF [@ nsSJISProber::HandleData]

Categories

(MailNews Core :: Composition, defect)

x86
macOS
defect
Not set
critical

Tracking

(thunderbird7 fixed, thunderbird8 fixed)

VERIFIED FIXED
Thunderbird 9.0
Tracking Status
thunderbird7 --- fixed
thunderbird8 --- fixed

People

(Reporter: portomomo, Assigned: m_kato)

References

()

Details

(4 keywords, Whiteboard: [gs])

Crash Data

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:6.0) Gecko/20100101 Firefox/6.0
Build ID: 20110811165603

Steps to reproduce:

Attach a pdf file to a mail message and try to send or save the message.
TB 6 on mac os 10.6.6 32 Bit


Actual results:

TB crashes and exit.
Attaching other files works normally.
All addons and extras are deactivated.


Expected results:

Mail message sent or saved.
Crash ID:
bp-1a041edf-981d-4415-bd1a-d1fbf2110817

The same as Bug 673673 but on TB 6
Did you submit the crash ? Can you double check the ID because I can't find it.
yeah, this is our new topcrash :(
Severity: normal → critical
Status: UNCONFIRMED → RESOLVED
Crash Signature: [@ nsSJISProber::HandleData]
Closed: 9 years ago
Resolution: --- → DUPLICATE
Summary: TB 6.0 crash when sending or saving an e-mail with attached PDF: Crash ID: bp-1a041edf-981d-4415-bd1a-d1fbf2110817 → TB 6.0 crash when sending or saving an e-mail with attached PDF: Crash ID: bp-1a041edf-981d-4415-bd1a-d1fbf2110817 [@ nsSJISProber::HandleData]
Duplicate of bug: 601261
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: DUPLICATE → ---
We have to fix this on comm-central side too.  So reopen this.
Depends on: 601261
Attached patch fix for c-cSplinter Review
Assignee: nobody → m_kato
Status: REOPENED → ASSIGNED
Comment on attachment 555042 [details] [diff] [review]
fix for c-c

need fix on c-c too.  more detail is bug 601261
Attachment #555042 - Flags: review?(dbienvenu)
Component: General → Composition
Product: Thunderbird → MailNews Core
QA Contact: general → composition
Comment on attachment 555042 [details] [diff] [review]
fix for c-c

thx for the patch - it sure seems like the decoder should handle empty input, however.
Attachment #555042 - Flags: review?(dbienvenu) → review+
http://hg.mozilla.org/comm-central/rev/8b88b6667dbe
Status: ASSIGNED → RESOLVED
Closed: 9 years ago9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 9.0
Attachment #555042 - Flags: approval-comm-beta?
Attachment #555042 - Flags: approval-comm-aurora?
Attachment #555042 - Flags: approval-comm-beta?
Attachment #555042 - Flags: approval-comm-beta+
Attachment #555042 - Flags: approval-comm-aurora?
Attachment #555042 - Flags: approval-comm-aurora+
Thanks for doing this Makoto

was this regression caused by bug 661876?
Summary: TB 6.0 crash when sending or saving an e-mail with attached PDF: Crash ID: bp-1a041edf-981d-4415-bd1a-d1fbf2110817 [@ nsSJISProber::HandleData] → TB 6.0 crash when sending or saving an e-mail with attached PDF [@ nsSJISProber::HandleData]
according to reporter of bp-df83c893-2d76-4fb2-8182-0c0482110808, today's ftp://ftp.mozilla.org/pub/thunderbird/nightly/latest-comm-aurora/ resolves the crash
Status: RESOLVED → VERIFIED
Duplicate of this bug: 673673
according to crash-stats, linux was also affected
Whiteboard: [gs]
You need to log in before you can comment on or make changes to this bug.