Test test_bug511075.html is calling finish() twice

RESOLVED FIXED in mozilla10

Status

defect
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: enndeakin, Assigned: enndeakin)

Tracking

Trunk
mozilla10
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Assignee

Description

8 years ago
Posted patch sample fixSplinter Review
This issue causes the next test to not run properly.

The attached patch shows the issue: the scroll event is firing twice, but I don't know whether this is a test issue or the test showing an actual bug.
Attachment #554410 - Flags: feedback?(Olli.Pettay)
Comment on attachment 554410 [details] [diff] [review]
sample fix

Clicking scrollbar sends several scroll events.
Attachment #554410 - Flags: feedback?(Olli.Pettay) → feedback+
at least if smooth scrolling is enabled.
Hmm, but without smooth scroll, there should be only one scroll event.
Posted file test
Assignee

Comment 6

8 years ago
Hmmm. I for some reason forgot about that issue, even though I have a patch for it.
http://hg.mozilla.org/mozilla-central/rev/f19404f45022
and backout:
http://hg.mozilla.org/mozilla-central/rev/dbc9ed28ba95
Assignee: nobody → enndeakin
Version: unspecified → Trunk
Status: NEW → ASSIGNED
Assignee

Updated

8 years ago
Duplicate of this bug: 686022
Assignee

Updated

8 years ago
Depends on: 659338

Updated

8 years ago
Blocks: 668728
https://hg.mozilla.org/mozilla-central/rev/6cc4966475c2
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla10
Assignee

Updated

8 years ago
Flags: in-testsuite-
You need to log in before you can comment on or make changes to this bug.