Last Comment Bug 659338 - layout/xul/base/test/test_resizer.xul needs to move to mochitest-chrome, but fails on osx and winxp
: layout/xul/base/test/test_resizer.xul needs to move to mochitest-chrome, but ...
Status: RESOLVED FIXED
[specialpowers]
:
Product: Core
Classification: Components
Component: Layout (show other bugs)
: Other Branch
: x86 Linux
: -- normal (vote)
: mozilla10
Assigned To: Neil Deakin (away until Oct 3)
:
Mentors:
: 686016 (view as bug list)
Depends on: 683394
Blocks: 462483 680431
  Show dependency treegraph
 
Reported: 2011-05-24 08:46 PDT by Joel Maher ( :jmaher)
Modified: 2012-02-08 17:56 PST (History)
7 users (show)
enndeakin: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch to move test_resizer.xul to mochitest-chrome (5.07 KB, patch)
2011-05-24 08:46 PDT, Joel Maher ( :jmaher)
no flags Details | Diff | Splinter Review
updated patch (11.53 KB, patch)
2011-08-30 17:51 PDT, Neil Deakin (away until Oct 3)
no flags Details | Diff | Splinter Review

Description Joel Maher ( :jmaher) 2011-05-24 08:46:58 PDT
Created attachment 534782 [details] [diff] [review]
patch to move test_resizer.xul to mochitest-chrome

in working on moving the .xul files from mochitest-plain to mochitest-chrome, I found that test_resizer.xul works great on linux and windows7, but fails on winxp and osx* with 108 failures.

Some logs from a try server run:
http://people.mozilla.org/~jmaher/specialpowers/

Here is an example of some of the failures:
7575 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/layout/xul/base/test/test_resizer.xul | window not moved for non-chrome window screenX - got 195, expected 200
7576 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/layout/xul/base/test/test_resizer.xul | window not moved for non-chrome window screenY - got 195, expected 200
7577 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/layout/xul/base/test/test_resizer.xul | window not moved for non-chrome window outerWidth - got 305, expected 300
7578 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/layout/xul/base/test/test_resizer.xul | window not moved for non-chrome window outerHeight - got 305, expected 300
7579 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/layout/xul/base/test/test_resizer.xul | window not moved for non-chrome window screenX - got 195, expected 200
7581 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/layout/xul/base/test/test_resizer.xul | window not moved for non-chrome window outerWidth - got 305, expected 300
7583 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/layout/xul/base/test/test_resizer.xul | window not moved for non-chrome window screenX - got 195, expected 200
7584 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/layout/xul/base/test/test_resizer.xul | window not moved for non-chrome window screenY - got 205, expected 200
7585 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/layout/xul/base/test/test_resizer.xul | window not moved for non-chrome window outerWidth - got 305, expected 300
7586 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/layout/xul/base/test/test_resizer.xul | window not moved for non-chrome window outerHeight - got 295, expected 300
7588 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/layout/xul/base/test/test_resizer.xul | window not moved for non-chrome window screenY - got 195, expected 200
7590 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/layout/xul/base/test/test_resizer.xul | window not moved for non-chrome window outerHeight - got 305, expected 300
7596 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/layout/xul/base/test/test_resizer.xul | window not moved for non-chrome window screenY - got 205, expected 200


If this shouldn't be moved to mochitest-chrome, let it be known.  Otherwise, some tips on what we need to change in order to get this running green.
Comment 1 Neil Deakin (away until Oct 3) 2011-07-04 10:18:51 PDT
This test opens the test window (window_resizer.xul) twice, once as a top-level chrome window and one as a non-chrome document window. This test ensures that a non-privileged window cannot contain a resizer to resize the window. But because the test is running as a chrome url, it always succeeds.
Comment 2 Ted Mielczarek [:ted.mielczarek] 2011-07-05 05:26:45 PDT
Is this part of the test even relevant anymore now that we prohibit loading XUL from content pages?
Comment 3 Joel Maher ( :jmaher) 2011-07-08 08:50:32 PDT
should we revisit this testcase?  should this run as a mochitest-chrome test?
Comment 4 Neil Deakin (away until Oct 3) 2011-07-08 12:26:37 PDT
Resizers can appear in unprivileged pages via the resize property, so a test to ensure one doesn't resize the window seems useful.
Comment 5 Joel Maher ( :jmaher) 2011-07-08 13:00:35 PDT
so should we move this to mochitest-chrome and then create a mochitest-plain test case?
Comment 6 Neil Deakin (away until Oct 3) 2011-08-30 17:51:08 PDT
Created attachment 557050 [details] [diff] [review]
updated patch

As part of this patch, I split the content portion into a separate test, which uncovered bug 683394 which this new tests now correctly checks.
Comment 7 Matt Brubeck (:mbrubeck) 2011-09-29 20:42:49 PDT
https://hg.mozilla.org/mozilla-central/rev/77b3b2868269
Comment 8 Bobby Holley (:bholley) (busy with Stylo) 2012-02-08 17:56:10 PST
*** Bug 686016 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.