Last Comment Bug 680564 - Nightly seems choppy on air.mozilla.org
: Nightly seems choppy on air.mozilla.org
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Audio/Video (show other bugs)
: Trunk
: x86_64 Mac OS X
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Maire Reavy [:mreavy]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-19 15:11 PDT by Graydon Hoare :graydon
Modified: 2012-02-14 10:50 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Graydon Hoare :graydon 2011-08-19 15:11:49 PDT
I've had to watch the past several weeks' air.mozilla.org events on chrome, due to hiccups in the playback on firefox nightly channel. This is on OSX, in the vancouver office. Happy to provide further details or assist in diagnostics.
Comment 1 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2011-08-24 12:08:10 PDT
Is it still choppy? Can you provide build specifics?
Comment 2 Ralph Giles (:rillian) needinfo me 2011-08-24 13:19:08 PDT
So, just now Nightly 9.0a1 from 2011-08-23 on MacOS 10.7.1 was choppy watching the default airmozilla stream (intern presentations currently going on).

I added the nightly tester tools to get the build id, restarted to Nightly 9.0a1 2010-08-24 and now it's fine.
Comment 3 Graydon Hoare :graydon 2011-08-24 13:22:17 PDT
Yes. Not right off the bat but after a few minutes of watching it changes to a mode where it has a clump of 4 or 5 half-second audio dropouts then 1-2s of audio then another clump of 4-5 more half-second dropouts. Not usable.

This is nightly; about:buildconfig says
Built from http://hg.mozilla.org/mozilla-central/rev/1881f9b5f8b5
i386-apple-darwin10.2.0
x86_64-apple-darwin10.2.0

What else can I provide?
Comment 4 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2011-08-24 13:24:14 PDT
Graydon, the build config is dated August 19. Can you please try today's nightly (2011-08-24)?
Comment 5 Graydon Hoare :graydon 2011-08-24 13:24:44 PDT
Not perfectly consistent -- sometimes I get period of respite -- so it may well have to do with low bandwidth to the office. On the other hand, same machine and same network it is not an issue on chrome, I can get through full meetings w/o dropouts.
Comment 6 Graydon Hoare :graydon 2011-08-24 13:25:29 PDT
Ah. I'll blame the updater for thinking that was "most recent" (I had just updated before checking). Re-checking the about dialogue is moving me to another one. Tell you in a minute!
Comment 7 Graydon Hoare :graydon 2011-08-24 13:29:32 PDT
Ok. Just applied update to:

http://hg.mozilla.org/mozilla-central/rev/198c7de0699d

(according to about:buildconfig)

and am still getting same dropouts. Something else I should paste in from about:support?
Comment 8 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2011-08-24 13:31:34 PDT
Does this happen on a new profile?
Comment 9 Graydon Hoare :graydon 2011-08-24 13:42:44 PDT
(In reply to Anthony Hughes, Mozilla QA (irc: ashughes) from comment #8)
> Does this happen on a new profile?

Just checked, yes.
Comment 10 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2011-08-24 14:08:26 PDT
Can you attach a plain-text file containing a paste of your about:support page?
Comment 11 Matthew Gregan [:kinetik] 2011-09-04 22:27:24 PDT
(In reply to Graydon Hoare :graydon from comment #3)
> Yes. Not right off the bat but after a few minutes of watching it changes to
> a mode where it has a clump of 4 or 5 half-second audio dropouts then 1-2s
> of audio then another clump of 4-5 more half-second dropouts. Not usable.

This sounds like bug 641273, which I have seen once locally, but have been unable to reproduce in a debug environment.
Comment 12 Graydon Hoare :graydon 2012-02-14 10:50:52 PST
Has been fine for quite a while now, thanks.

Note You need to log in before you can comment on or make changes to this bug.