Closed Bug 680680 Opened 8 years ago Closed 8 years ago

Renaming attachments during composition broken (does not update display name in the pane)

Categories

(Thunderbird :: Message Compose Window, defect)

8 Branch
x86
Windows 7
defect
Not set

Tracking

(thunderbird8 fixed)

RESOLVED FIXED
Thunderbird 9.0
Tracking Status
thunderbird8 --- fixed

People

(Reporter: bugzilla2007, Assigned: squib)

Details

Attachments

(2 files)

STR

1) compose, add attachment(s)
2) rename attachment (right-click, rename, enter new name, confirm)

Actual result
- attachment name in the pane does not change (display name not updated, the bug)
- otherwise the real name of the attachment is changed as expected (try renaming again to verify, or sending -> sends with correct new name)


Expected
- update the display name, too (major UI confusion for the user, as display name is different from real attachment name that gets sent)

this is a regression, perhaps caused by bug 630759
How I wish bug 526998 could be fixed alongside...
Reported against Earlybird 8.0a2 2011-08-19
Summary: Renaming attachments during composition broken (does not update name in the pane) → Renaming attachments during composition broken (does not update display name in the pane)
Whoops, I forgot about this, and the attachment renaming test didn't cover this part, but now it does.
Assignee: nobody → squibblyflabbetydoo
Status: NEW → ASSIGNED
Attachment #554724 - Flags: review?(bwinton)
While we're here, we might as well remove the attachmentNameAndSize strings, since they're no longer relevant.
Attachment #554724 - Attachment is obsolete: true
Attachment #554724 - Flags: review?(bwinton)
Attachment #554727 - Flags: review?(bwinton)
Comment on attachment 554727 [details] [diff] [review]
Remove strings too

Review of attachment 554727 [details] [diff] [review]:
-----------------------------------------------------------------

Seems easy enough, the code works for me, and I don't see anything wrong with it.

r=me.

Thanks,
Blake.
Attachment #554727 - Flags: review?(bwinton) → review+
Checked in: http://hg.mozilla.org/comm-central/rev/e64fa2caa9d8
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 9.0
Comment on attachment 554727 [details] [diff] [review]
Remove strings too

We should try to get this for 8.0...
Attachment #554727 - Flags: approval-comm-aurora?
Comment on attachment 554727 [details] [diff] [review]
Remove strings too

Not with the string changes, but attach the patch without the string changes and we can land that on aurora.
Attachment #554727 - Flags: approval-comm-aurora? → approval-comm-aurora-
Comment on attachment 554724 [details] [diff] [review]
Fix this and test it (no strings)

Oops, I forgot to ask for approval for a no-strings version. Luckily, I'd already attached such a patch.
Attachment #554724 - Attachment description: FIx this and test it → Fix this and test it (no strings)
Attachment #554724 - Attachment is obsolete: false
Attachment #554724 - Flags: approval-mozilla-beta?
Attachment #554724 - Flags: approval-mozilla-beta? → approval-mozilla-aurora?
Comment on attachment 554724 [details] [diff] [review]
Fix this and test it (no strings)

Setting the *right* approval flag would help...
Attachment #554724 - Flags: approval-mozilla-aurora? → approval-comm-aurora?
Attachment #554724 - Flags: approval-comm-aurora? → approval-comm-aurora+
You need to log in before you can comment on or make changes to this bug.