bug: opera redirects to japanese

REOPENED
Unassigned

Status

developer.mozilla.org
General
--
major
REOPENED
7 years ago
2 years ago

People

(Reporter: groovecoder, Unassigned)

Tracking

unspecified
x86
Mac OS X

Details

(Whiteboard: [type:bug][tech=django])

Attachments

(1 attachment)

Comment hidden (empty)
(Reporter)

Updated

7 years ago
Assignee: nobody → lcrouch
(Reporter)

Comment 1

7 years ago
Changed to funfactory LocaleURLMiddleware and urlresolvers. 

Raymond,

Please test a number of languages and click around thru a number of links to make sure the language is not lost during navigation.
Assignee: lcrouch → mozbugs.retornam
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Keywords: qawanted
Resolution: --- → FIXED
qa-verified http://developer-stage9.mozilla.org
Keywords: qawanted
Assignee: mozbugs.retornam → nobody
verified fixed http://developer.mozilla.org
Status: RESOLVED → VERIFIED
Created attachment 627352 [details]
Headers -- shows en in Opera goes to ja
Reopening -- this is clearly still happening.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
Yep.
Open Opera on Mac.
Clear out all settings.
In the search bar (Google or Yahoo), search for MDN.
Click on the link to Mozilla Developer Network.
Get the ja version of the site.
I don't see this behavior. What's the URL you click on the search result?
Duped on two Macs now (running 10.7).
Open latest version of Opera.
Search (in Google or Yahoo) for "Mozilla Developer Network" or "MDN"
First, or best, choice link says this:
"Mozilla Developer Network
https://developer.mozilla.org/
Organized by topics provides documentation about extensions, themes, applications, frameworks and technologies."

The actual link shown if I hover over it is
https://developer.mozilla.org/

But, if I simply click on it, I get this instead:
https://developer.mozilla.org/ja/
I can confirm strange behavior, though I'm getting redirected to French locale.

Opera 11.64/OS X 10.7.3 reports the following request/response cycle when hitting http://developer.mozilla.org/

Request details
GET / HTTP/1.1 
User-Agent: Opera/9.80 (Macintosh; Intel Mac OS X 10.7.3; U; en) Presto/2.10.229 Version/11.64
Host: developer.mozilla.org
Accept: text/html, application/xml;q=0.9, application/xhtml+xml, image/png, image/webp, image/jpeg, image/gif, image/x-xbitmap, */*;q=0.1
Accept-Language: en,en-US;q=0.9,fr;q=0.8
Accept-Encoding: gzip, deflate
Cookie: csrftoken=918e96fd6cd29b32c6e6204ec385bcac; WT_FPC=id=24.124.86.65-944520160.30171790:lv=1338195469299:ss=1338195241356
Connection: Keep-Alive
Request body

No request data
Response details
HTTP/1.1 301 MOVED PERMANENTLY 
Server: Apache
Vary: Accept-Language
X-Backend-Server: dekiwiki1.webapp.scl3.mozilla.com
Cache-Control: no-cache, must-revalidate
Content-Type: text/html; charset=utf-8
Date: Mon, 28 May 2012 11:58:47 GMT
Location: https://developer.mozilla.org/fr/
Keep-Alive: timeout=5, max=992
Expires: Thu, 19 Nov 1981 08:52:00 GMT
Pragma: no-cache
Connection: Keep-Alive
X-Apache-Time: D=2760 us
x-frame-options: DENY
X-Cache-Info: not cacheable; response specified "Cache-Control: no-cache"
Content-Length: 0
(Assignee)

Updated

6 years ago
Version: MDN → unspecified
(Assignee)

Updated

6 years ago
Component: Website → Landing pages
Product: Mozilla Developer Network → Mozilla Developer Network
Duplicate of this bug: 806926
(Reporter)

Updated

6 years ago
Whiteboard: c=bug p=1 u=visitor → c=bug p=1 u=visitor [mentor=groovecoder tech=django]

Updated

6 years ago
Priority: -- → P1
Whiteboard: c=bug p=1 u=visitor [mentor=groovecoder tech=django] → [type:bug][mentor=groovecoder tech=django]

Updated

4 years ago
Severity: normal → major
Priority: P1 → --

Updated

4 years ago
Component: Landing pages → General
Mentor: lcrouch
Whiteboard: [type:bug][mentor=groovecoder tech=django] → [type:bug][tech=django]
(Reporter)

Updated

2 years ago
Mentor: lcrouch
You need to log in before you can comment on or make changes to this bug.