Last Comment Bug 680926 - Long tapping for too long will copy text to clipboard
: Long tapping for too long will copy text to clipboard
Status: VERIFIED WORKSFORME
: regression
Product: Fennec Graveyard
Classification: Graveyard
Component: General (show other bugs)
: Trunk
: ARM Android
: -- normal (vote)
: ---
Assigned To: Matt Brubeck (:mbrubeck)
:
Mentors:
Depends on:
Blocks: 661388 680425
  Show dependency treegraph
 
Reported: 2011-08-22 09:09 PDT by Brad Lassey [:blassey] (use needinfo?)
Modified: 2011-10-06 22:26 PDT (History)
5 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Brad Lassey [:blassey] (use needinfo?) 2011-08-22 09:09:03 PDT
If I long tap to make a selection and leave my finger there until I see the selection happen the selection will dismiss as soon as I lift my finger and copy the text to the key board. 

After some practice I learned how to hold my finger down long enough to register a long press but not long enough to copy the text. But this is still awful.
Comment 1 Martijn Wargers [:mwargers] (not working for Mozilla) 2011-08-24 05:11:13 PDT
This used to work after bug 661388 was fixed. I suspect this is a regression from bug 667243. Might be good to get a regression range.
Comment 2 Catalin Suciu [:csuciu] 2011-08-26 01:50:35 PDT
I was able to reproduce this issue on Build id : Mozilla/5.0 (Android;Linux armv7l;rv:9.0a1)Gecko/20110825 Firefox/9.0a1 Fennec/9.0a1
Device: HTC Desire
OS: Android 2.2
using this steps:
1. Long tap on a word to perform a text selection
2. Without dismissing the previously text selection long tap on another word

Actual:
The second selection is performed, but when lifting the finger, the selection is dismissed and the text is copied to clipboard.

Note:
The first text selection is performed correctly.
Comment 3 Catalin Suciu [:csuciu] 2011-08-26 02:47:13 PDT
This issue doesn't occur on:
Build id : Mozilla/5.0 (Android;Linux armv7l;rv:9.0a1)Gecko/20110821
Firefox/9.0a1 Fennec/9.0a1
http://hg.mozilla.org/mozilla-central/rev/6dc468c41136

but it occurs on:
Build id : Mozilla/5.0 (Android;Linux armv7l;rv:9.0a1)Gecko/20110822
Firefox/9.0a1 Fennec/9.0a1
http://hg.mozilla.org/mozilla-central/rev/33e4aa663bba

Possible range:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=6dc468c41136&tochange=33e4aa663bba
Comment 4 Martijn Wargers [:mwargers] (not working for Mozilla) 2011-08-28 01:42:24 PDT
I guess that makes this a regression from bug 680425, then.
Comment 5 Gabriela [:gaby2300] 2011-09-23 15:29:10 PDT
Build ID: Mozilla/5.0 (Android; Linux armv7l; rv:9.0a 1)Gecko/20110922 Firefox/9.0a1 Fennec/9.0a1
SO: Android 3.1
Device: Samsung Galaxy Tab 10.1

I cannot reproduce this bug.
Comment 6 Catalin Suciu [:csuciu] 2011-10-06 22:26:53 PDT
This is not reproducible on Mozilla/5.0 (Android;Linux armv7l;rv:10.0a1)Gecko/20111006 Firefox/10.0a1 Fennec/10.0a1
Device: HTC Desire
OS: Android 2.2

Note You need to log in before you can comment on or make changes to this bug.