make[6]: *** [nsThreadUtils.obj] Error 2 (WINNT 6.1 x64)

RESOLVED DUPLICATE of bug 680818

Status

Firefox Build System
General
RESOLVED DUPLICATE of bug 680818
7 years ago
2 months ago

People

(Reporter: armenzg, Unassigned)

Tracking

Trunk
x86
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

This is a new compile bug. It is preventing us from compiling in Windows 64-bit.
This is ridiculous. Every time I file a new compilation bug for Win 64-bit a new one shows up in few days.
I wonder when we will reach green and unhide the jobs.

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1314025912.1314026302.13695.gz#err0

make -C glue libs
make[6]: Entering directory `/e/builds/moz2_slave/m-cen-w64/build/obj-firefox/xpcom/glue'
nsThreadUtils.cpp
c:/mozilla-build/python/python2.6.exe -O e:/builds/moz2_slave/m-cen-w64/build/build/cl.py cl -FonsThreadUtils.obj -c -D_HAS_EXCEPTIONS=0 -I../../dist/stl_wrappers  -DOSTYPE=\"WINNT6.1\" -DOSARCH=WINNT -D_USE_ANSI_CPP -DTARGET_XPCOM_ABI=\"x86_64-msvc\" -I/e/builds/moz2_slave/m-cen-w64/build/xpcom/glue/../build  -I/e/builds/moz2_slave/m-cen-w64/build/xpcom/glue -I. -I../../dist/include -I../../dist/include/nsprpub  -Ie:/builds/moz2_slave/m-cen-w64/build/obj-firefox/dist/include/nspr -Ie:/builds/moz2_slave/m-cen-w64/build/obj-firefox/dist/include/nss         -TP -nologo -W3 -Gy -Fdgenerated.pdb -wd4800 -we4553  -DNDEBUG -DTRIMMED -Zi -Oy- -Zi -UDEBUG -DNDEBUG -GL -O1 -MT            -FI ../../dist/include/mozilla-config.h -DMOZILLA_CLIENT -Zl /e/builds/moz2_slave/m-cen-w64/build/xpcom/glue/nsThreadUtils.cpp
nsThreadUtils.cpp

e:\builds\moz2_slave\m-cen-w64\build\xpcom\glue\nsStringAPI.h(1323) : warning C4244: 'argument' : conversion from '__int64' to 'PRUint32', possible loss of data

e:\builds\moz2_slave\m-cen-w64\build\xpcom\glue\nsStringAPI.h(1361) : warning C4244: 'argument' : conversion from '__int64' to 'PRUint32', possible loss of data

e:\builds\moz2_slave\m-cen-w64\build\xpcom\glue\nsThreadUtils.h(325) : error C2953: 'nsRunnableMethodTraits<R(__cdecl C::* )(void),Owning>' : class template has already been defined

        e:\builds\moz2_slave\m-cen-w64\build\xpcom\glue\nsThreadUtils.h(313) : see declaration of 'nsRunnableMethodTraits<R(__cdecl C::* )(void),Owning>'

make[6]: Leaving directory `/e/builds/moz2_slave/m-cen-w64/build/obj-firefox/xpcom/glue'
make[5]: Leaving directory `/e/builds/moz2_slave/m-cen-w64/build/obj-firefox/xpcom'
make[4]: Leaving directory `/e/builds/moz2_slave/m-cen-w64/build/obj-firefox'
make[3]: Leaving directory `/e/builds/moz2_slave/m-cen-w64/build/obj-firefox'
make[2]: Leaving directory `/e/builds/moz2_slave/m-cen-w64/build/obj-firefox'
make[1]: Leaving directory `/e/builds/moz2_slave/m-cen-w64/build'
make[6]: *** [nsThreadUtils.obj] Error 2
make[5]: *** [libs] Error 2
make[4]: *** [libs_tier_platform] Error 2
make[3]: *** [tier_platform] Error 2
make[2]: *** [default] Error 2
make[1]: *** [realbuild] Error 2
make: *** [profiledbuild] Error 2
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 680818
No longer blocks: 471090, 558448

Updated

2 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.