IPv6 sites fails to load if IPv6 is not available.

UNCONFIRMED
Unassigned

Status

()

P3
normal
UNCONFIRMED
7 years ago
11 months ago

People

(Reporter: GRMrGecko, Unassigned)

Tracking

6 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [http-conn][ipv6][necko-backlog])

Attachments

(1 attachment)

43.14 KB, text/plain
Details
(Reporter)

Description

7 years ago
Created attachment 554884 [details]
HTTP Log

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:6.0) Gecko/20100101 Firefox/6.0
Build ID: 20110811165603

Steps to reproduce:

Went from home to work, visited https://addons.mozilla.org/en-US/firefox/addon/live-http-headers/ and my own personal site and neither of them loads. Google's site and other sites loads, it's just random sites such as your own site.


Actual results:

I tried multiple things to get these sites to load such as starting in safe mode, deleting all preferences to FireFox, clearing the cache, and changing DNS servers from OpenDNS to Google Public DNS. Nothing fixes the issue. I am able to visit these sites with both Safari and Chrome, so this issue is confined to FireFox only.

I followed instructions, here https://developer.mozilla.org/en/HTTP_Logging, to get some logs that might be useful to help find the cause to this issue. If there is any other logs you might want, let me know. I do not have any Proxies or VPNs on, so there should be no issues with that.

I have not played around with changing settings in About:Config as I should not have to and I started a fresh setup with FireFox. The Web Console only says  [11:30:11.054] GET https://addons.mozilla.org/en-US/firefox/addon/live-http-headers/ [undefined 8090ms].

Thanks for any help on this issue, I'm having to use Safari to connect to my personal web site, it's not much of a problem, but FireFox should never have issues such as this.


Expected results:

All sites load as it does in both Safari in Chrome.

Comment 1

7 years ago
WFM on Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:6.0.1) Gecko/20100101 Firefox/6.0.1

The link from the description opens in a new tab.
The same behavior in the latest Firefox 7 beta and latest Nightly.

Comment 2

7 years ago
Based on comment1, setting resolution to Resolved WFM.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

7 years ago
Still happens to me in Nightly 9.0a1 2011-09-17. Can you please instruct me on how I can get debug information for you?
(Reporter)

Updated

7 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 4

7 years ago
Have you tried loading the site on a new, empty testing profile? (Don't install any addons into it):
http://support.mozilla.com/kb/Basic+Troubleshooting#w_8-make-a-new-profile

Also try to update to Firefox 6.0.2, if this still doesn't work, try a fresh install of Firefox.
(Reporter)

Comment 5

7 years ago
HttpFox results...
00:00:34.535	7.601	606	0	GET	(Error)	NS_ERROR_FAILURE	https://developer.mozilla.org/en/HTTP_Logging

(Request-Line)	GET /en/HTTP_Logging HTTP/1.1

Host	developer.mozilla.org

User-Agent	Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:9.0a1) Gecko/20110919 Firefox/9.0a1

Accept	text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8

Accept-Language	en-us,en;q=0.5

Accept-Encoding	gzip, deflate

DNT	1

Connection	keep-alive

Referer	https://bugzilla.mozilla.org/show_bug.cgi?id=680932

Cookie	__qca=P0-1319192563-1294841772392; __unam=f7237fc-12d7a956afb-215bc44d-1; WT_FPC=id=2f0929deee1a514c6f31288019630850:lv=1316389468195:ss=1316389468195; dloadday=64.89.119.124.1300884978366814; wtspl=252216

Notice first post says "deleting all preferences to FireFox" which profiles are preferences and I have deleted them. It's basically the same as reinstalling FireFox. I have tested on 2011-09-19 and it still happens (the version I'm on now).

As I asked, is there a way to debug these types of problems? Maybe a log of every step to visit a website, EG:
Looking up domain: developer.mozilla.org.
Found Domain at IP: 0.0.0.0.
Connecting to IP: 0.0.0.0.
Failed to connect to domain: developer.mozilla.org (TimeOut).

Something like that is what I'm wondering if it's possible to get. I know I can connect to that domain as I can in Safari and Chrome.

If you do tell me to reinstall, please specify the steps in which I am to take to reinstall... The steps I took was:

1. Delete files from ~/Library/Application Support/FireFox/.
2. Delete files from ~/Library/Preferences/org.mozilla.firefox.plist (Not that anything in there would cause problems).
3. Delete files from ~/Library/Caches/FireFox/.
4. Delete files from ~/Library/Caches/org.mozilla.FireFox/.
5. Delete files from ~/Library/Caches/org.mozilla.Nightly/.
6. Re open FireFox.

This will do what you call reinstall as it gives it a fresh start and it does not fix my issue. ~/Library/Application Support/FireFox/ is the profiles which includes all settings, add-ons, and data for the user and therefore nothing should be causing any problems which I have modified.

As I said, both Chrome and Safari works with the domains which FIreFox does not and I have tested this over and over again.

PLEASE DO NOT LEAD ME DOWN THE PATH OF REDOING WHAT I HAVE DONE. Read the whole bug report and make a decision on how I can debug. You can view the log I have already posted when this problem was occurring and I will not redo it unless you have changed the way it reports things since I have ran that test.

Thank you for trying,
Mr. Gecko.

Comment 6

7 years ago
Well, this seems pretty serious.  Jason, can you please make sure that somebody looks at this?

Mr. Gecko, thanks a lot for filing this bug!  I hope that we can assist you in fixing it.  :-)
Component: General → Networking
Product: Firefox → Core
QA Contact: general → networking
The TCP and/or SSL connect is failing

126357504[104501d30]: nsSocketTransport::OnSocketReady [this=bbe8700 outFlags=2]
126357504[104501d30]: ErrorAccordingToNSPR [in=-5994 out=80004005]
126357504[104501d30]:   connection failed! [reason=80004005]

*4005 is just NS_ERROR_FAILURE, in this case it is mapped from NSPR's -5994 which is PR_UNKNOWN_ERROR

It's just a guess, but it seems likely to be coming out of nss through something like http://mxr.mozilla.org/mozilla-central/source/security/nss/lib/ssl/unix_err.c#547 .. this log is using ssl.

it also seems possible to be coming from
http://mxr.mozilla.org/mozilla-central/source/nsprpub/pr/src/io/prsocket.c#341

It's not obvious what to do next. Ideas? Maybe a DLL conflict? (this is wfm btw)
(Reporter)

Comment 8

7 years ago
Don't think a DLL conflict is possible as this is a Mac and Mac's uses Dylib for Dynamic Libraries instead of Dynamic Loading Libraries (DLL) and the only way for a conflict would be if I placed another dynamic library in the place of the one which FireFox loads which I have redownloaded FireFox so many times I don't think that's possible unless it uses a system Library in which I am a programmer so it's possible that I installed over a library which OS X comes with.
(Reporter)

Comment 9

7 years ago
Should I make a list of domains that this happens with? It changes all the time. When I encounter it, I switch to Safari to open the site (ehh?).
(Reporter)

Comment 10

7 years ago
Could this be because my route changes when I go to work? Does FireFox cache routes?

Example:
At home, my site is router to computer.
At work, my site is many routers to computer.

So could it be using some network function that caches the routes to make it faster or something like that?

It is not only my site which does not work in FireFox, I am considering moving to Chrome as it works. However, chrome does not have the extensions I love and they break functionality a lot.
(In reply to Mr. Gecko from comment #10)
> Could this be because my route changes when I go to work? Does FireFox cache
> routes?
> 

nope.

Do you have any vpn or firewalling software installed? We could try disabling that to see if the interaction you are seeing is due to that.
(Reporter)

Comment 12

7 years ago
No. I do not have anything like that. However I do have a Tunnel Broker as my ISP does not provide IPv6 yet and I found that to be my problem. When I'm at work, I do not have IPv6 and that's why it stops working at work. This is a bug in FireFox as FireFox should choose IPv4 whenever IPv6 is unreachable. This is why I said debugging with DNS queries and connection would be useful as it would of popped right out that it's trying to connect to an IPv6 address.

This is how it should work from my understanding.
If IPv6 available, try IPv6 address. If IPv6 fails, fall back to IPv4.
If IPv6 not available, use IPv4.
(Reporter)

Updated

7 years ago
Summary: Website never loads. → IPv6 sites fails to load if IPv6 is not available.
Whiteboard: [http-conn]

Comment 13

4 years ago
I have the same problem with stable Firefox 32 (and 31 before the recent update). My ISP (Comcast) does provide me with IPv6 connectivity, but in the past few weeks the IPv6 connection has been rather flaky and will occasionally stop working entirely. When this happens, sites that were serving content content over IPv6 will stop working properly, as Firefox continues trying to fetch the content over IPv6. When this is happening, the same websites will fall back to IPv4 and load properly on Chrome.

As with Mr. Gecko, I am not using any firewall or VPN that would cause this problem.
Does this still happen in recent Firefox versions? With the work done for bug 939318, Firefox should flush IPv6 state on detected network changes.
Whiteboard: [http-conn] → [http-conn][ipv6][necko-backlog]
You need to log in before you can comment on or make changes to this bug.