Last Comment Bug 68120 - Can't print alternate rendering for object elements
: Can't print alternate rendering for object elements
Status: RESOLVED WORKSFORME
: testcase
Product: Core
Classification: Components
Component: Printing: Output (show other bugs)
: Trunk
: x86 Windows NT
-- normal with 3 votes (vote)
: Future
Assigned To: Nobody; OK to take it and work on it
:
: Jet Villegas (:jet)
Mentors:
http://bugzilla.mozilla.org/showattac...
: 213457 (view as bug list)
Depends on: 208541
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-08 03:53 PST by Andreas Knöpfel
Modified: 2011-11-28 08:57 PST (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
gif for testcase (6.63 KB, image/gif)
2001-02-12 02:15 PST, Boris Zbarsky [:bz] (still a bit busy)
no flags Details
svg for testcase (9.56 KB, image/svg)
2001-02-12 02:17 PST, Boris Zbarsky [:bz] (still a bit busy)
no flags Details
HTML testcase (1.81 KB, text/html)
2001-02-12 02:23 PST, Boris Zbarsky [:bz] (still a bit busy)
no flags Details
Testcase #2 (617 bytes, text/html)
2005-07-23 17:40 PDT, Mats Palmgren (:mats)
no flags Details

Description User image Andreas Knöpfel 2001-02-08 03:53:43 PST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 4.0)
BuildID:    2001010901

The following HTML-code is rendered correctly on screen. Missing the SVG-plug-
in, the content of the object element, the GIF image is displayed. 
Nevertheless, when printing a page containing this HTML-fragment, instead of 
printing the image that part on the page showing the picture remains blank.
...
<object codetype="image/svg" 
data="./Socket_Communication.bd.svgz"
height=578
width=640>
<img src="Socket_Communication.bd.gif">
</object>
...


Reproducible: Always
Steps to Reproduce:
Create a HTML-page, containing some similar code and load the page into 
Mozilla. The page will be displayed correctly, but misses the picture when 
being printed.


Actual Results:  The page will be displayed correctly, but misses the picture 
when being printed.


Expected Results:  Not only display the alternative content, but also print the 
alternative content


It works with Netscape Communicator 4.76 using Linux (I don't know, if this 
helps).
Comment 1 User image Boris Zbarsky [:bz] (still a bit busy) 2001-02-08 10:03:06 PST
Could this be related to bug 27478?  note that it's not the plugin failing to
print itself (as in 27478) but rather mozilla failing to print the stuff it's
displaying instead of the plugin.
Comment 2 User image Boris Zbarsky [:bz] (still a bit busy) 2001-02-12 02:15:46 PST
Created attachment 25053 [details]
gif for testcase
Comment 3 User image Boris Zbarsky [:bz] (still a bit busy) 2001-02-12 02:17:50 PST
Created attachment 25054 [details]
svg for testcase
Comment 4 User image Boris Zbarsky [:bz] (still a bit busy) 2001-02-12 02:23:06 PST
Created attachment 25055 [details]
HTML testcase
Comment 5 User image Boris Zbarsky [:bz] (still a bit busy) 2001-02-12 03:07:38 PST
Andreas, thanks for providing the testcase.
Comment 6 User image Ken Snider 2001-05-06 05:20:20 PDT
Reporter: Is this still the case in a current build?
Comment 7 User image Keyser Sose 2001-05-31 13:19:40 PDT
marking NEW.
Comment 8 User image Andreas Knöpfel 2001-06-01 01:29:49 PDT
In mozilla build 2001050515 the behaviour is slightly different. The graphic is neither printed nor displayed on screen. Perhaps someone else could verify the behaviour with a different use case.
Comment 9 User image Roland Mainz 2001-06-12 05:45:35 PDT
When I try the testcase with my 2001-06-10-08-trunk build (build with
--enable-svg) on Solaris 7 I'll get:
-- snip --
Document http://bugzilla.mozilla.org/showattachment.cgi?attach_id=25055 loaded
successfully
InstantiateEmbededPlugin for image/svg
Inside nsPluginHostImpl::FindStoppedPluginForURL...
killing stream for
http://bugzilla.mozilla.org/showattachment.cgi?attach_id=25054
-- snip --

Looks the build is somehow not able to recognize the image as SVG and does not
use the fallback image instead... ;-(
Comment 10 User image Asa Dotzler [:asa] 2001-12-03 10:44:02 PST
Bugs targeted at mozilla1.0 without the mozilla1.0 keyword moved to mozilla1.0.1 
(you can query for this string to delete spam or retrieve the list of bugs I've 
moved)
Comment 11 User image Vedran Miletic 2003-10-05 08:49:51 PDT
retargeting
Comment 12 User image Christian :Biesinger (don't email me, ping me on IRC) 2004-04-12 11:45:04 PDT
*** Bug 213457 has been marked as a duplicate of this bug. ***
Comment 13 User image Mats Palmgren (:mats) 2005-07-23 17:40:50 PDT
Created attachment 190282 [details]
Testcase #2
Comment 14 User image Helder "Lthere" Magalhães 2009-10-30 09:37:55 PDT
(In reply to comment #0)
> The following HTML-code is rendered correctly on screen. Missing the SVG-plug-
> in, the content of the object element, the GIF image is displayed. 
> Nevertheless, when printing a page containing this HTML-fragment, instead of 
> printing the image that part on the page showing the picture remains blank.

I can't reproduce the symptoms using the current release [1] nor a nightly build [2] on Windows Vista SP2 (successor of NT).

As this seems fixed but no related commits are known, I'd suggest this issue to be marked resolved "works for me".

Andreas: even though Gecko (Communication, Firefox and friends) now supports SVG, the test case was still valid: the SVG content was broken (there was a hanging </text> tag with no matching one opening it; also, no "xmlns" was provided, causing the file to be rendered as XML). As the object source was broken, the GIF image was still being loaded, allowing to quickly check for this issue. ;-)

[1] Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.4) Gecko/20091016 Firefox/3.5.4 (.NET CLR 3.5.30729)
[2] Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.3a1pre) Gecko/20091029 Minefield/3.7a1pre (.NET CLR 3.5.30729)
Comment 15 User image Helder "Lthere" Magalhães 2009-10-30 09:53:01 PDT
(In reply to comment #14)
> I can't reproduce the symptoms using the current release [1] nor a nightly
> build [2] on Windows Vista SP2 (successor of NT).

Oops, guess I didn't mention anything about my testing procedure:
1. Open the testcase;
2. Visually analyze the output of "File" menu, "Print Preview" option.

I've also double checked using a PDF printer (actually simulating the print output).

Sorry for the bug spam!
Comment 16 User image RNicoletto 2010-07-16 11:07:12 PDT
WFM using Mozilla/5.0 (Windows; Windows NT 5.1; en-US; rv:2.0b2pre) Gecko/20100716 Minefield/4.0b2pre

I'm going to mark this FIXED as WFM.

Note You need to log in before you can comment on or make changes to this bug.