Mozilla-central fails to build --with-static-checking

RESOLVED WONTFIX

Status

defect
RESOLVED WONTFIX
8 years ago
Last year

People

(Reporter: jcranmer, Assigned: jcranmer)

Tracking

Trunk
mozilla9
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Notes:
1. Configure documentation suggests using gcc_dehydra.so, which causes things to fail immediately (Detect dehydra v. treehydra or hint to use treehydra).
2. Elfhack throws a JS Exception. --disable-elf-hack works.
3. The frame-verify script uses callable regex.
4. We have two failures for NS_OVERRIDE:
+ gfx/layers/ipc/ShadowLayersParent (RecvGetParentType)
+ content/svg/content/src/SVGMotionSMILAnimationFunction (TreatSingleValueAsStatic)
5. Linking errors in libxul.so:
../../js/jsd/jsd_atom.o: In function `MUST_FLOW_THROUGH':
/tmp/jcranmer-mozilla/obj-mc/js/jsd/../../dist/include/jsstaticcheck.h:48: multiple definition of `MUST_FLOW_THROUGH'
../../js/jsd/jsdebug.o:/tmp/jcranmer-mozilla/obj-mc/js/jsd/../../dist/include/jsstaticcheck.h:48: first defined here
[and more, similar]
6. Two files of the HTML parser (Element and Attribute names) cause out-of-memory errors.
7. I need a small patch to dehydra to add in a TYPE_PACK_EXPANSION to yet another switch statement (c_c).
The gfx/layers/ipc/ShadowLayersParent is a result of patch 3.1 on bug 648484, and appears to be a neglect to remove dead code.
The other NS_OVERRIDE I've traced is to bug 614879, and appears to be an actual problem (someone didn't change the later function).
This changes the callable regex to execs.
Assignee: nobody → Pidgeot18
Status: NEW → ASSIGNED
Attachment #556618 - Flags: review?(tglek)
This is the bustage due to NS_OVERRIDE in gfx.
Attachment #556651 - Flags: review?(jones.chris.g)
Attachment #556618 - Flags: review?(tglek) → review+
Comment on attachment 556651 [details] [diff] [review]
Fix bustage caused by cjones

Is this part of a grand scheme to get automated static checking builds again?  Oh please oh please oh please ...
Attachment #556651 - Flags: review?(jones.chris.g) → review+
Depends on: 683040
These two patches have been pushed to mozilla-inbound.
http://hg.mozilla.org/mozilla-central/rev/23962193053c
http://hg.mozilla.org/mozilla-central/rev/2642c7b0dc60
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
OS: Linux → All
Hardware: x86_64 → All
Resolution: --- → FIXED
Target Milestone: --- → mozilla9
Version: unspecified → Trunk
[not quite fixed yet, see blocking bug and notes about the failure in htmlparser]
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Status: REOPENED → ASSIGNED
Dehydra support is deprecated.
Status: ASSIGNED → RESOLVED
Closed: 8 years ago7 years ago
Resolution: --- → WONTFIX
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.