Last Comment Bug 681666 - Add formnovalidate attribute to test_button_attribute_reflection.html
: Add formnovalidate attribute to test_button_attribute_reflection.html
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM: Core & HTML (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla9
Assigned To: Mounir Lamouri (:mounir)
:
:
Mentors:
Depends on:
Blocks: 673553
  Show dependency treegraph
 
Reported: 2011-08-24 08:59 PDT by Mounir Lamouri (:mounir)
Modified: 2011-08-24 17:24 PDT (History)
2 users (show)
mounir: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1 (2.99 KB, patch)
2011-08-24 08:59 PDT, Mounir Lamouri (:mounir)
Ms2ger: review+
Details | Diff | Splinter Review

Description Mounir Lamouri (:mounir) 2011-08-24 08:59:01 PDT
Created attachment 555426 [details] [diff] [review]
Patch v1
Comment 1 :Ms2ger (⌚ UTC+1/+2) 2011-08-24 11:34:28 PDT
Comment on attachment 555426 [details] [diff] [review]
Patch v1

>--- a/content/html/content/test/forms/test_button_attributes_reflection.html
>+++ b/content/html/content/test/forms/test_button_attributes_reflection.html
>@@ -23,12 +23,19 @@ https://bugzilla.mozilla.org/show_bug.cg
> reflectLimitedEnumerated({
>   element: document.createElement("button"),
>   attribute: "type",
>   validValues: [ "submit", "reset", "button" ],
>   invalidValues: [ "this-is-probably-a-wrong-type", "", "tulip" ],
>   defaultValue: "submit",
> });
> 
>+// .formNoValidate
>+reflectBoolean({
>+  element: document.createElement("button"),
>+  attribute: "formNoValidate",
>+});
>+
>+

One empty line is enough. And I'd rather you didn't add the ',' at the end, but it looks like you got that past me before.
Comment 2 Mounir Lamouri (:mounir) 2011-08-24 12:32:46 PDT
(In reply to Ms2ger from comment #1)
> One empty line is enough.

Oups :)

> And I'd rather you didn't add the ',' at the end,
> but it looks like you got that past me before.

Sorry but I love that trailing comma and I'm pretty sure you don't want to break my hearth :)

Thanks for the quick review!
Comment 3 Matt Brubeck (:mbrubeck) 2011-08-24 17:24:47 PDT
http://hg.mozilla.org/mozilla-central/rev/650aad33a441

Note You need to log in before you can comment on or make changes to this bug.