Attempting to view https sites hangs browser

VERIFIED WORKSFORME

Status

Core Graveyard
Security: UI
--
critical
VERIFIED WORKSFORME
18 years ago
2 years ago

People

(Reporter: Shannon Diener, Assigned: Javier Delgadillo)

Tracking

1.0 Branch
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: critical for mozilla 0.8, URL)

(Reporter)

Description

18 years ago
When trying to view a secure site the browser appears to be working - the
progress bar is spinning - but it never reaches the site.  Pushing Stop or
another link locks the browser.

Reproducible: Always
Steps to Reproduce:
1.  Go to www.amazon.com
2.  Go to the log-in page
3.  You don't have to enter an account, just press the "Sign in using our secure
server" button

Actual Results:  The browser looks like its trying to reach the page but never
does, progress bar is moving.

Expected Results:  A page is reached that either lets you into your account, or
in my example, tells you that you haven't entered enough information.

We first noticed this on HPUX build 2001020721.  This may be a duplicate of
another bug, but can't find one that quite fits.
(Reporter)

Comment 1

18 years ago
updating fields
Blocks: 18687
Whiteboard: critical for mozilla 0.8
(Reporter)

Comment 2

18 years ago
Seen on Linux build 2001020808

Comment 3

18 years ago
Worksforme with the nightly mozilla build. Try a different secure site like 
https://www.verisign.com
Assignee: ddrinan → javi
Did you install as root?  If so, are you running as a regular user?  The user
running mozilla currently needs to be able to write to the PSM install dir....

Comment 5

18 years ago
Works fine for me on https://www.amazon.com and https://www.xtrade.ch
W2K with build 2001020804

Comment 6

18 years ago
WFM on 2001020721 linux
But if this happens when going through a proxy, it's a dup of bug 31174 
(thanks to vikb for pointing that out)
(Reporter)

Comment 7

18 years ago
Ah, I see the problem.  Resolving worksforme.  Looks like what I was seeing may
be a different issue - will file an appropriate bug when I know more.  Thanks
for your help!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 8

18 years ago
verified.
Status: RESOLVED → VERIFIED

Comment 9

17 years ago
Mass changing Security:Crypto to PSM
Component: Security: Crypto → Client Library
Product: Browser → PSM
Version: other → 2.1

Comment 10

17 years ago
Mass changing Security:Crypto to PSM

Updated

13 years ago
Component: Security: UI → Security: UI
Product: PSM → Core

Updated

10 years ago
Version: psm2.1 → 1.0 Branch
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.