Atom Feed Author Name Chokes on "Greater Than" or "Less Than" Characters

RESOLVED FIXED in Thunderbird 27.0

Status

defect
RESOLVED FIXED
8 years ago
3 months ago

People

(Reporter: j3vasko, Assigned: alta88)

Tracking

Thunderbird 27.0
x86
macOS

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

8 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Build ID: 20110413222027

Steps to reproduce:

Added an atom feed that has:
<entry><author><name>

With:
<![CDATA[<(root)>]]>

Make sure the feed does NOT use the tag:
<email>


Actual results:

Thunderbird butchers the name in the [From] name column and displays just:
<

Thunderbird also butchers the [From] name when viewing the individual feed entry as:
< <root>>


Expected results:

Thunderbird should display the name correctly in the [From] name column as:
<(root)>

Thunderbird should also display the name correctly when viewing the individual feed entry as:
<(root)>
(Reporter)

Comment 1

8 years ago
The WORKAROUND for this is to have the atom feed publisher add the email field as follows:
<email>@</email>

The email field is NOT completely filled out because there is no email that applies here.

With this WORKAROUND 1 bad side effect is that when viewing the individual message entry you will see the following in the [From] field:
<(root)> <@>

See attachment:
WORKAROUND: Email Field Specified as @ on the Atom Feed

Also, please note that Thunderbird will allow you to add a contact to your address book with display name:
<(root)>

So it should allow this same author name on a feed.
(Reporter)

Updated

8 years ago
Duplicate of this bug: 679195
Component: Folder and Message Lists → Feed Reader
Product: Thunderbird → MailNews Core
QA Contact: folders-message-lists → feed.reader
(Reporter)

Comment 4

8 years ago
Both screen shots are from the same feed but the code in the feed was updated between screen shots.

This is also an issue if you subscribe to:
http://en.wikipedia.org/w/index.php?title=Special:RecentChanges&feed=atom

Notice all the values in the [From] Column in Thunderbird are surrounded by < and > after subscribing.
(Assignee)

Comment 5

6 years ago
adding <> to email less names is not what imap/pop/nntp does to display From in the threadpane list, it doesn't 'look nicer', and it causes bugs like this.
Assignee: nobody → alta88
Status: UNCONFIRMED → NEW
Ever confirmed: true
Attachment #808204 - Flags: review?(mkmelin+mozilla)
Comment on attachment 808204 [details] [diff] [review]
feedAuthor.patch

Review of attachment 808204 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM! r=mkmelin
Attachment #808204 - Flags: review?(mkmelin+mozilla) → review+
(Assignee)

Updated

6 years ago
Keywords: checkin-needed
https://hg.mozilla.org/comm-central/rev/c769d20360ff
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 27.0

Updated

3 months ago
Depends on: 1522156
You need to log in before you can comment on or make changes to this bug.