Android reftests are disabled for BMP, ICO decoder and encoder

RESOLVED DUPLICATE of bug 753639

Status

()

Core
ImageLib
RESOLVED DUPLICATE of bug 753639
7 years ago
6 years ago

People

(Reporter: bbondy, Assigned: bbondy)

Tracking

Trunk
mozilla15
All
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [android][tegra][mobile_unittests])

Attachments

(1 attachment)

(Assignee)

Description

7 years ago
The reftests for BMP and ICO encoders and decoders (all recently added) are not working on Android so skip Android was added.  This task is to re-enable them and fix anything that doesn't work on Android for these reftests.
Whenever I see a test sticking in a Tegra's craw, I think to myself "I should cc jmaher on this bug!"
(Assignee)

Updated

7 years ago
OS: Windows 7 → Android
Hardware: x86_64 → All
oh, thanks for disabling them and filing a bug.
Whiteboard: [android][tegra][mobile_unittests]
(Assignee)

Comment 3

7 years ago
Created attachment 556616 [details] [diff] [review]
Patch that re-enables android reftests

Running patch which removes the if-android-check through try now in case the problem was just Bug 682568's decodeondraw = true.

http://tbpl.allizom.org/?tree=Try&usebuildbot=1&rev=c79ed4256163
(Assignee)

Comment 4

7 years ago
The problem is with one of the corrupted BMP bitmaps.  The corrupted image should show the background color but instead it shows nothing.
I think I'll have to setup an Android dev environment to fix.

The strange thing is the reftest for this corrupted bitmap passes:

// have valid BPP values before adding the frame
if (mBIH.compression == BI_RLE8 && mBIH.bpp != 8) {
  PR_LOG(gBMPLog, PR_LOG_DEBUG, 
 ("BMP RLE8 compression only supports 8 bits per pixel\n"));
  PostDataError();
  return;
}


But the reftest for this corrupted bitmap fails (which follows directly in the code):

if (mBIH.compression == BI_RLE4 && mBIH.bpp != 4) {
  PR_LOG(gBMPLog, PR_LOG_DEBUG, 
 ("BMP RLE4 compression only supports 4 bits per pixel\n"));
  PostDataError();
  return;
}
(Assignee)

Comment 5

6 years ago
Comment on attachment 556616 [details] [diff] [review]
Patch that re-enables android reftests

Review of attachment 556616 [details] [diff] [review]:
-----------------------------------------------------------------

So I'm not sure which changeset fixed these tests but they are passing now as demonstrated on this recent push:
https://tbpl.mozilla.org/?tree=Try&rev=016a845a547d
Attachment #556616 - Flags: review?(joe)
Attachment #556616 - Flags: review?(joe) → review+
Depends on: 753639
(Assignee)

Comment 7

6 years ago
Now that we know it's actually an intermittent problem, I'll close this as a dupe of the new one and I'll backout the changeset from inbound.
(Assignee)

Comment 8

6 years ago
Backed out here:
http://hg.mozilla.org/integration/mozilla-inbound/rev/2dd6926fcab1

Work for this will continue in bug 753639
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 753639
You need to log in before you can comment on or make changes to this bug.