WebWorker has "Could not get Domain!" error when on localhost

RESOLVED DUPLICATE of bug 683280

Status

()

defect
RESOLVED DUPLICATE of bug 683280
8 years ago
5 months ago

People

(Reporter: jykng, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0a2) Gecko/20110826 Firefox/8.0a2
Build ID: 20110826042012

Steps to reproduce:

I have a script that uses creates a bunch of web workers, which simply calculate a random number.  I've tried doing this on a folder of "localhost".


Actual results:

The worker wouldn't even start, it got a "Could not get Domain!" error through the error console and firebug.

However that exact same script worked when put on a remote domain.


Expected results:

It should have been executing the web worker like it does with 6.0
Please provide a public URL or reduced test case that exhibits this issue.

Can you find a regression window? http://harthur.github.com/mozregression/
Posted file test case
The test is simple:

<script>var w = new Worker("anyname.js");</script>

Looks like it's http://hg.mozilla.org/mozilla-central/rev/f631e1b0e296
(or something that released on 2011-07-27-03-08-39-mozilla-central)
Fails on ff9 and Mac OS as well.
Component: General → DOM
OS: Windows 7 → All
Product: Firefox → Core
QA Contact: general → general
Hardware: x86_64 → All
Version: 8 Branch → Trunk
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 683280
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.