Thunderbird v6/7/8 hang on open/preview email w/ attachment, and on Tools:Add-ons:Install Add-on From File

RESOLVED DUPLICATE of bug 698993

Status

Thunderbird
General
--
critical
RESOLVED DUPLICATE of bug 698993
7 years ago
7 years ago

People

(Reporter: psirois, Unassigned)

Tracking

({hang, stackwanted})

8 Branch
x86
Windows XP
hang, stackwanted

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1) AppleWebKit/535.1 (KHTML, like Gecko) Chrome/13.0.782.215 Safari/535.1

Steps to reproduce:

Win XP SP3, TB 6.0

upgrade to TB  6.0 from previous version
enable mail preview
in left pane folder tree select any folder w/ mail w/ attachments
in main mail list window select any mail w/ attachment


Actual results:

Thunderbird crashes/hangs - no mail preview displayed, app doesn't respond to any further input, must kill TB process


Expected results:

display mail preview, no crash/hang
(Reporter)

Comment 1

7 years ago
antivirus integration w/ TB is disabled (ESET NOD32)
Severity: normal → critical
Priority: -- → P1
(Reporter)

Comment 2

7 years ago
on crash/hang following preview attempt, main TB window does not redraw - big white blank, Win hourglass cursor on mouse-over
(Reporter)

Comment 3

7 years ago
f*ck ... pardon the spam (bugzilla should support Comment edit).  Updated title, more info:

- crashes/hangs on open or preview for any email with any attachment - file size/type don't matter (txt, pdf, jpg, 1K, 1MB)
- during crash/hang TB CPU % is 0, memory footprint nominal(<=60MB)
Summary: Thunderbird 6.0 hang/crash on preview email w/ attachment → Thunderbird 6.0 hang/crash on open/preview email w/ attachment

Comment 4

7 years ago
psirois, please create a file with stacktrace information and attach file to this bug. see https://developer.mozilla.org/En/How_to_get_a_stacktrace_with_windbg and replace firefox whereever  you see it with thunderbird.
Keywords: hang, stackwanted
Priority: P1 → --
Summary: Thunderbird 6.0 hang/crash on open/preview email w/ attachment → Thunderbird 6.0 hang on open/preview email w/ attachment
Does starting in -safe-mode fixes the issues (see http://support.mozillamessaging.com/en-US/kb/Safe-Mode) ?
(Reporter)

Comment 6

7 years ago
didn't do -safe-mode but did disable all add-ons and restarted ... crash/hang still repro's.

windg and TB symbols build is pain in ass - as last resort could do that but surely there are other reports of this?

Comment 7

7 years ago
(In reply to psirois from comment #6)
> didn't do -safe-mode but did disable all add-ons and restarted ...
> crash/hang still repro's.
> 
> windg and TB symbols build is pain in ass - as last resort could do that but
> surely there are other reports of this?

psirois,

The problem in this case is there are many other reports. So unless you can match your precise issue to one of them [1], it's hard or perhaps impossible to determine which bug we can duplicate this to, if any.

[1] https://bugzilla.mozilla.org/buglist.cgi?type1-0-0=substring&keywords=hang%2C%20&keywords_type=allwords&list_id=1302936&short_desc=attach&field0-0-0=short_desc&type0-0-1=substring&field0-0-1=keywords&type1-0-1=allwordssubstr&resolution=---&classification=Client%20Software&classification=Components&query_format=advanced&short_desc_type=allwordssubstr&type0-0-0=anywordssubstr&field1-0-0=short_desc&product=MailNews%20Core&product=Thunderbird&field1-0-1=short_desc
(Reporter)

Comment 8

7 years ago
This problem is specific & unique wrt to the other reports - this hang occurs on attempt to preview a mail item with attachment.  No send, no attach operation, just attempting to view in the preview window.
SO as you are the only one seeing this a stack would be very useful/welcomed.
(Reporter)

Comment 10

7 years ago
(In reply to Ludovic Hirlimann [:Usul] from comment #9)
> SO as you are the only one seeing this a stack would be very useful/welcomed.

am I the only one seeing this?  see wayneM comment, above:

Wayne Mery (:wsmwk) 2011-09-15 13:33:49 PDT
(In reply to psirois from comment #6)
> didn't do -safe-mode but did disable all add-ons and restarted ...
> crash/hang still repro's.
> 
> windg and TB symbols build is pain in ass - as last resort could do that but
> surely there are other reports of this?

psirois,

The problem in this case is there are many other reports. So unless you can match your precise issue to one of them [1], it's hard or perhaps impossible to determine which bug we can duplicate this to, if any.
Priority: -- → P3
Summary: Thunderbird 6.0 hang on open/preview email w/ attachment → Thunderbird v6/7/8 hang on open/preview email w/ attachment, and on Tools:Add-ons:Install Add-on From File
Version: 6 → 8
(Reporter)

Comment 11

7 years ago
updated title, more repro:

- initial repro on TB v6
- upgraded via release channel to v7.0.1, repro'd the hang on preview email w/ attachment, and on selecting Tools:Add-ons:Install Add-on From File
- upgraded to v8.0 via release channel, still repro's

ESET Smart Security Extension still disabled (and still incompatible w/ TB v7/8)

Comment 12

7 years ago
(In reply to psirois from comment #10)
> (In reply to Ludovic Hirlimann [:Usul] from comment #9)
> > SO as you are the only one seeing this a stack would be very useful/welcomed.
> 
> am I the only one seeing this?  

still, your stacktrace would be helpful. the steps are well laid out
https://developer.mozilla.org/En/How_to_get_a_stacktrace_with_Windbg

however, it sounds like you will be OK as a duplicate
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Priority: P3 → --
Resolution: --- → DUPLICATE
Duplicate of bug: 698993
You need to log in before you can comment on or make changes to this bug.