Closed Bug 682920 Opened 8 years ago Closed 8 years ago

Remove build support for old Unix platforms

Categories

(Firefox Build System :: General, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
mozilla9

People

(Reporter: matjk7, Assigned: matjk7)

References

Details

(Whiteboard: fixed-in-bs)

Attachments

(2 files, 2 obsolete files)

No description provided.
Flags: in-testsuite-
Summary: Remove build support for Unixware → Remove build support for old Unix platforms
Attachment #556647 - Flags: review?(ted.mielczarek)
Attachment #556648 - Flags: review?(ted.mielczarek)
Missed some stuff in previous patch.
Attachment #556647 - Attachment is obsolete: true
Attachment #556647 - Flags: review?(ted.mielczarek)
Attachment #556731 - Flags: review?(ted.mielczarek)
Ditto.
Attachment #556648 - Attachment is obsolete: true
Attachment #556648 - Flags: review?(ted.mielczarek)
Attachment #556732 - Flags: review?(ted.mielczarek)
Comment on attachment 556731 [details] [diff] [review]
part 1: Remove support for old Unix platforms

Review of attachment 556731 [details] [diff] [review]:
-----------------------------------------------------------------

I don't even know what half of these *are*.
Attachment #556731 - Flags: review?(ted.mielczarek) → review+
Attachment #556732 - Flags: review?(ted.mielczarek) → review+
Attachment #556731 - Flags: checkin?(bmo)
Attachment #556732 - Flags: checkin?(bmo)
http://hg.mozilla.org/projects/build-system/rev/cfe788512a5d
http://hg.mozilla.org/projects/build-system/rev/78af9261582f

Both patches had the wrong bug number (Bug 689920) in the commit message.
It doesn't seem worth adding more churn backing them out and landing again to correct (since people can search for the rev ID), but please please please can you:
a) Check that check-sync-dirs passes (this one I triple checked before landing this time, but unluckily wasn't the problem this time around)
b) The commit message is correct 
...on future patches.

Thanks! :-)
Whiteboard: fixed-in-bs
Target Milestone: --- → mozilla9
I noticed the bug number was wrong at some point but forgot to fix it, sorry about that!

This also passed try-server but I didn't mention in the bug, though I guess it would be nicer if bugzilla had a "passed-try" flag similar to "in-testsuite".
Attachment #556731 - Flags: checkin?(bmo) → checkin+
Attachment #556732 - Flags: checkin?(bmo) → checkin+
https://hg.mozilla.org/mozilla-central/rev/cfe788512a5d
https://hg.mozilla.org/mozilla-central/rev/78af9261582f
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Blocks: 807488
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.