Last Comment Bug 682920 - Remove build support for old Unix platforms
: Remove build support for old Unix platforms
Status: RESOLVED FIXED
fixed-in-bs
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla9
Assigned To: Matheus Kerschbaum
:
Mentors:
Depends on: 682751
Blocks: 807488
  Show dependency treegraph
 
Reported: 2011-08-29 11:40 PDT by Matheus Kerschbaum
Modified: 2012-10-31 14:51 PDT (History)
3 users (show)
matjk7: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
part 1: Remove support for old Unix platforms (4.95 KB, patch)
2011-08-29 12:25 PDT, Matheus Kerschbaum
no flags Details | Diff | Review
part 2: Remove remaining support for Tru64/Alpha (16.62 KB, patch)
2011-08-29 12:26 PDT, Matheus Kerschbaum
no flags Details | Diff | Review
part 1: Remove support for old Unix platforms (9.91 KB, patch)
2011-08-29 18:18 PDT, Matheus Kerschbaum
ted: review+
emorley: checkin+
Details | Diff | Review
part 2: Remove remaining support for Tru64/Alpha (23.58 KB, patch)
2011-08-29 18:19 PDT, Matheus Kerschbaum
ted: review+
emorley: checkin+
Details | Diff | Review

Description Matheus Kerschbaum 2011-08-29 11:40:40 PDT

    
Comment 1 Matheus Kerschbaum 2011-08-29 12:25:55 PDT
Created attachment 556647 [details] [diff] [review]
part 1: Remove support for old Unix platforms
Comment 2 Matheus Kerschbaum 2011-08-29 12:26:58 PDT
Created attachment 556648 [details] [diff] [review]
part 2: Remove remaining support for Tru64/Alpha
Comment 3 Matheus Kerschbaum 2011-08-29 18:18:24 PDT
Created attachment 556731 [details] [diff] [review]
part 1: Remove support for old Unix platforms

Missed some stuff in previous patch.
Comment 4 Matheus Kerschbaum 2011-08-29 18:19:01 PDT
Created attachment 556732 [details] [diff] [review]
part 2: Remove remaining support for Tru64/Alpha

Ditto.
Comment 5 Ted Mielczarek [:ted.mielczarek] 2011-09-02 12:26:29 PDT
Comment on attachment 556731 [details] [diff] [review]
part 1: Remove support for old Unix platforms

Review of attachment 556731 [details] [diff] [review]:
-----------------------------------------------------------------

I don't even know what half of these *are*.
Comment 6 Ed Morley [:emorley] 2011-09-02 18:53:51 PDT
http://hg.mozilla.org/projects/build-system/rev/cfe788512a5d
http://hg.mozilla.org/projects/build-system/rev/78af9261582f

Both patches had the wrong bug number (Bug 689920) in the commit message.
It doesn't seem worth adding more churn backing them out and landing again to correct (since people can search for the rev ID), but please please please can you:
a) Check that check-sync-dirs passes (this one I triple checked before landing this time, but unluckily wasn't the problem this time around)
b) The commit message is correct 
...on future patches.

Thanks! :-)
Comment 7 Matheus Kerschbaum 2011-09-02 22:02:03 PDT
I noticed the bug number was wrong at some point but forgot to fix it, sorry about that!

This also passed try-server but I didn't mention in the bug, though I guess it would be nicer if bugzilla had a "passed-try" flag similar to "in-testsuite".

Note You need to log in before you can comment on or make changes to this bug.