Status

()

Core
XUL
18 years ago
9 years ago

People

(Reporter: blizzard, Unassigned)

Tracking

({meta})

Trunk
Future
x86
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Placeholder bug for patches + discussion.
(Reporter)

Updated

18 years ago
Status: NEW → ASSIGNED

Comment 1

18 years ago
This really isn't a mozilla bug (because, as far as I know, the text drawing
routines are in GDK and the XP toolkit just calls them). But it's nice to have
it anyways. Recently on the render@xfree86.org list, someone (I think Jim
Gettys) said that someone's already done the hacking for GTK 1.2-- someone
showed him antialiased Evolution. Anyone know about that? (I for one am not
patient enough to wait for GTK 2...)
Hit me with AA, baby!
(Reporter)

Comment 3

18 years ago
Actually, you do need some support from mozilla to work with libXft since it
does lots of checks for what fonts are available and has to use different
routines to determine sizes, etc.

Comment 4

18 years ago
Blizzard: thanks for explaining that. Moz in those screenshots does look a
little off, text placement-wise.

In case anyone hasn't found them, the unstable patches and screenshots are here:

http://primates.ximian.com/~vladimir

It's a set of patches for GAL, gnome-libs, gtk, and mozilla. Also, the
screenshots are with subpixel rendering (ClearType) so they might be a strain to
read on your CRT... but as far as I know there is nothing preventing you from
using regular anti-aliasing in the patch. You can even turn anti-aliasing off
for a certain app by setting the environment variable GDK_USE_XFT.
We will also want to use X-render for translucent compositing.

Comment 6

18 years ago
is it possible to cc vladimir and jacob @ximian.com -- i hear they were doing
some initial changes to moz along with their work on GDK w/ render.
Please confirm my understanding of the situation - this will be necessary to
support video card 2D acceleration - or do we have that already?
(Reporter)

Comment 8

17 years ago
If your card has XRender support then it will show up as an extension.  If it
doesn't then it won't.
Yes, I understand that XRender only works for certain cards.

I'm just trying to confirm that this is a necessary condition for using 2D
acceleration of video cards in Mozilla for drawing shapes & stuff.

Comment 10

17 years ago
*** Bug 75787 has been marked as a duplicate of this bug. ***

Comment 11

17 years ago
my search for anti-alias didn't turn up this bug, sorry for the dup.

Comment 12

17 years ago
I went to the Ximian link below but the page was basically blank, but I have a
url from mozdev that may be usefull.
http://news.gnome.org/gnome-news/981746971/index_html

I basically supplies the patch they used and not much else.
(Reporter)

Comment 13

17 years ago

*** This bug has been marked as a duplicate of 82076 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 14

17 years ago
I think that bug 82076 only addresses a subset of Render's capabilities.

Comment 15

17 years ago
Reopening as a tracking bug for FULL render support, as I mentioned in bug
82076. Adding 82076 as a dependency of this bug. I suggest reassigning it to
nobody@mozilla.org and marking it Future since Render doesn't even support the
appropriate functionality right now (however, I'm not going to mess with the TM
and assignedTo fields on a bug that isn't mine).

From my posting in bug 82076:

Render, in general, can do a lot more than just antialiased text. I'm not sure
how far along support is for these features right now, but when it's completed
it will be able to do at least all of the following:
- Basic alpha blending (CSS opacity and -moz-opacity properties)
- Per-pixel alpha blending (PNG, MNG)
- Antialiased line, polygon, curve etc drawing (SVG, MathML?)
- Antialiased image resizing (img width= height= and CSS equivalent)

I'm pretty sure that the first of these is supported by Render right now
(although it might not be in an XFree release yet) and I wouldn't be surprised
if the second is too. I'm pretty sure that the third and fourth aren't
implemented yet.

Sorry if I'm stepping on anyone's toes by reopening this bug, but I really want
to be able to track full render implementation and it seems to me to make more
sense to REOP this bug (which interested people are already following) than open
a new one.
Blocks: 82076
Status: RESOLVED → REOPENED
Keywords: meta
Resolution: DUPLICATE → ---
Summary: X-Render support for gtk → Full X-Render support
(Reporter)

Comment 16

17 years ago
You do realize that most of that stuff isn't even finished in X-Render, right?

Comment 17

17 years ago
Read my comment again :)

Hence the suggestion to reassign to nobody@mozilla.org and Future this bug until
Render is ready for us...
(Reporter)

Comment 18

17 years ago
Even better so it doesn't completely vanish.
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → LATER
LATER is deprecated per bug 35839.
Status: RESOLVED → REOPENED
Resolution: LATER → ---
Target Milestone: --- → Future
going with nobody for the moment
Assignee: blizzard → nobody
Status: REOPENED → NEW

Updated

16 years ago
QA Contact: jrgm → nobody
QA Contact: nobody → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.