Last Comment Bug 683416 - Remove build support for standalone necko and standalone xslt transformiix
: Remove build support for standalone necko and standalone xslt transformiix
Status: RESOLVED FIXED
: dev-doc-complete
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla9
Assigned To: Ed Morley [:emorley]
:
Mentors:
: 475833 (view as bug list)
Depends on:
Blocks: 687326
  Show dependency treegraph
 
Reported: 2011-08-30 19:12 PDT by Matheus Kerschbaum
Modified: 2011-12-21 07:57 PST (History)
8 users (show)
matjk7: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
A: Build system changes (8.32 KB, patch)
2011-08-31 14:31 PDT, Ed Morley [:emorley]
khuey: review+
Details | Diff | Review
B: File removals (156.69 KB, patch)
2011-08-31 14:35 PDT, Ed Morley [:emorley]
khuey: review+
Details | Diff | Review
C: Remove #ifdef TX_EXE (57.76 KB, patch)
2011-08-31 14:38 PDT, Ed Morley [:emorley]
khuey: review+
Details | Diff | Review

Description Matheus Kerschbaum 2011-08-30 19:12:12 PDT
Ed if you don't feel like working on this bug then please re-assign it to me.
Comment 1 Ed Morley [:emorley] 2011-08-31 14:31:37 PDT
Created attachment 557326 [details] [diff] [review]
A: Build system changes

Removes support for building standalone xslt & standalone necko.

Have separated out file removals for easier review.
Comment 2 Ed Morley [:emorley] 2011-08-31 14:35:57 PDT
Created attachment 557332 [details] [diff] [review]
B: File removals

Removes confvars.sh + build.mk from both content/xslt/ and netwerk/, since only used when building standalone. 

Post makefile changes in part 1, a bunch of files in content/xslt/src/ are now unused, so take those out too.
Comment 3 Kyle Huey [:khuey] (khuey@mozilla.com) 2011-08-31 14:37:18 PDT
Roping in the xslt owners to see if they have objections to dropping standalone transformiix.
Comment 4 Ed Morley [:emorley] 2011-08-31 14:38:36 PDT
Created attachment 557333 [details] [diff] [review]
C: Remove #ifdef TX_EXE

After part A, TX_EXE is never defined:
http://mxr.mozilla.org/mozilla-central/search?string=TX_EXE
Comment 5 Jonas Sicking (:sicking) PTO Until July 5th 2011-08-31 16:10:25 PDT
I'm all for this, but Peterv is the module owner.
Comment 6 Peter Van der Beken [:peterv] 2011-09-01 01:25:21 PDT
Let's do it.
Comment 7 Kyle Huey [:khuey] (khuey@mozilla.com) 2011-09-01 09:17:14 PDT
B and C are mechanical, I trust your ability to delete files correctly, so I didn't actually look at these.
Comment 9 Jonas Sicking (:sicking) PTO Until July 5th 2011-09-01 10:14:11 PDT
It'd be awesome to also kill txAtoms.h and do 
s/txXPathAtoms|txXMLAtoms|txXSLTAtoms|txHTMLAtoms/nsGkAtoms/g
Comment 10 Ed Morley [:emorley] 2011-09-01 10:20:31 PDT
On my list for a followup :-)

(Wanted to try and keep the more mechanical changes separate so khuey didn't have to actually read a 220kb patch :-))
Comment 11 :Ehsan Akhgari (busy, don't ask for review please) 2011-09-02 08:35:58 PDT
http://hg.mozilla.org/mozilla-central/rev/962b157801a6
Comment 12 :Ehsan Akhgari (busy, don't ask for review please) 2011-09-02 08:36:31 PDT
That was C, and we also have:

B: http://hg.mozilla.org/mozilla-central/rev/0c97e9647100
A: http://hg.mozilla.org/mozilla-central/rev/df264cbf7b9c
Comment 13 :Ms2ger 2011-11-02 07:50:59 PDT
*** Bug 475833 has been marked as a duplicate of this bug. ***
Comment 14 Ed Morley [:emorley] 2011-12-20 19:02:47 PST
Seeing the similar --enable-application=standalone change listed on https://developer.mozilla.org/en/Firefox_9_for_developers makes me dev-doc-needed may be appropriate for this as well. (Sorry for adding it late).
Comment 15 Eric Shepherd [:sheppy] 2011-12-21 07:57:55 PST
Docs updated:

https://developer.mozilla.org/En/Building_Necko_standalone
https://developer.mozilla.org/en/Building_XXX_Standalone

Also mentioned on Firefox 9 for developers.

Thanks for calling this to our attention!

Note You need to log in before you can comment on or make changes to this bug.