Last Comment Bug 683482 - remove replaceWholeText()
: remove replaceWholeText()
Status: RESOLVED FIXED
: addon-compat, dev-doc-complete
Product: Core
Classification: Components
Component: DOM: Core & HTML (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla10
Assigned To: Matheus Kerschbaum
:
:
Mentors:
Depends on: 688190
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-31 06:11 PDT by Anne (:annevk)
Modified: 2011-11-22 05:26 PST (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (17.65 KB, patch)
2011-09-18 01:57 PDT, Matheus Kerschbaum
jonas: review+
Details | Diff | Splinter Review
Patch to allow using nsIDocument::WarnOnceAbout for more cases (1.59 KB, patch)
2011-09-20 01:10 PDT, :Ms2ger (⌚ UTC+1/+2)
no flags Details | Diff | Splinter Review
patch for checkin (17.73 KB, patch)
2011-09-28 14:06 PDT, Matheus Kerschbaum
no flags Details | Diff | Splinter Review
patch for checkin (20.09 KB, patch)
2011-09-28 14:28 PDT, Matheus Kerschbaum
matjk7: review+
Details | Diff | Splinter Review
patch for checkin (20.09 KB, patch)
2011-09-29 15:37 PDT, Matheus Kerschbaum
matjk7: review+
Details | Diff | Splinter Review

Description Anne (:annevk) 2011-08-31 06:11:40 PDT
Per http://www.w3.org/Bugs/Public/show_bug.cgi?id=13046 it would be great if this method got removed so it can be removed from DOM Core.

(Acid3 relies on this, but Acid3 needs to change anyway.)
Comment 1 Matheus Kerschbaum 2011-09-18 01:57:40 PDT
Created attachment 560768 [details] [diff] [review]
patch
Comment 2 Jonas Sicking (:sicking) No longer reading bugmail consistently 2011-09-19 12:39:12 PDT
Comment on attachment 560768 [details] [diff] [review]
patch

Review of attachment 560768 [details] [diff] [review]:
-----------------------------------------------------------------

yay
Comment 3 Mounir Lamouri (:mounir) 2011-09-19 14:49:58 PDT
How confident are we that this is not going to break any website? Should we wait for the next merge (in 8 days) to increase the test period?
Comment 4 Matheus Kerschbaum 2011-09-19 15:37:53 PDT
(In reply to Mounir Lamouri (:volkmar) (:mounir) from comment #3)
> How confident are we that this is not going to break any website? Should we
> wait for the next merge (in 8 days) to increase the test period?

You're right this doesn't need to land right now.
Comment 5 Jonas Sicking (:sicking) No longer reading bugmail consistently 2011-09-19 16:21:29 PDT
If you're doing that, please add a warning to current builds as to increase the chances that anyone using this fixes their site.
Comment 6 :Ms2ger (⌚ UTC+1/+2) 2011-09-20 01:10:24 PDT
Created attachment 561137 [details] [diff] [review]
Patch to allow using nsIDocument::WarnOnceAbout for more cases

This patch would be useful if you want to use nsIDocument::WarnOnceAbout. (We've got 32 warnings already.)
Comment 7 Dão Gottwald [:dao] 2011-09-28 05:01:03 PDT
This patch isn't going to apply, due to the warning added in bug 688190, which you also need to remove.
Comment 8 Matheus Kerschbaum 2011-09-28 14:06:42 PDT
Created attachment 563176 [details] [diff] [review]
patch for checkin

Updated to tip.
Comment 9 Dão Gottwald [:dao] 2011-09-28 14:19:18 PDT
You forgot to update dom.properties.
Comment 10 Dão Gottwald [:dao] 2011-09-28 14:20:02 PDT
Comment on attachment 563176 [details] [diff] [review]
patch for checkin

... and nsDeprecatedOperationList.h
Comment 11 Matheus Kerschbaum 2011-09-28 14:28:14 PDT
Created attachment 563183 [details] [diff] [review]
patch for checkin
Comment 12 Dão Gottwald [:dao] 2011-09-29 07:02:48 PDT
patching file content/base/src/nsGenericDOMDataNode.h
Hunk #1 FAILED at 324
Comment 13 Matheus Kerschbaum 2011-09-29 15:37:20 PDT
Created attachment 563575 [details] [diff] [review]
patch for checkin
Comment 14 :Ms2ger (⌚ UTC+1/+2) 2011-10-02 07:14:44 PDT
https://hg.mozilla.org/mozilla-central/rev/5f0f1b44e73d

Note You need to log in before you can comment on or make changes to this bug.