Software Update Failed for Firefox and Thunderbird. "The update could not be installed ..."

RESOLVED WORKSFORME

Status

()

Toolkit
Application Update
RESOLVED WORKSFORME
7 years ago
2 years ago

People

(Reporter: Vyas, Unassigned)

Tracking

7 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(6 attachments)

(Reporter)

Description

7 years ago
Created attachment 557150 [details]
update_failed.png

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0) Gecko/20100101 Firefox/7.0
Build ID: 20110816154714

Steps to reproduce:

Try to open Firefox 


Actual results:

Got message


"The update could not be installed. Please make sure there are no other copies of Firefox running on your computer, and then restart Firefox to try again"


Expected results:

Updated FF and started FF
(Reporter)

Comment 1

7 years ago
I have tried this: http://kb.mozillazine.org/Software_Update but it did not help. All folders are clear and I have tried admin account as well
Component: General → Application Update
Product: Firefox → Toolkit
QA Contact: general → application.update
If you haven't re-installed already please perform the following:

Attach (using the 'Add an attachment' link above) the following files which can be located with a default install as follows:

Type the following in the Start Menu search box and press return.
%LOCALAPPDATA%
Then navigate to \Mozilla\Firefox\Mozilla Firefox\

active-update.xml

navigate to the updates subdirectory
last-update.log and backup-update.log
(Reporter)

Comment 3

7 years ago
I see only Profiles directory under C:\Users\username\AppData\Local\Mozilla\Firefox

There is no other directory or files you specified.

As far as I remember the link http://kb.mozillazine.org/Software_Update tells us to clean up those files so they can be downloaded again
Are you still experiencing the bug as reported?
(Reporter)

Comment 5

7 years ago
Yes otherwise I would have closed it :-)
Please attach the install.log file which is located in the affected Firefox installation directory.
(Reporter)

Comment 7

7 years ago
Created attachment 557509 [details]
install log for  FF 7
Noticed that you specified a different path than asked for in comment #3
C:\Users\username\AppData\Local\Mozilla\Firefox

It should be
C:\Users\username\AppData\Local\Mozilla Firefox\

Please check for that path and if present the requested files if present.

Also, did you move your Program Files directory from your c drive to your d drive?
(Reporter)

Comment 9

7 years ago
Yes I install in d:\Program Files\Mozilla Firefox

I just have C:\Users\username\AppData\Local\Mozilla\Firefox
I do not have Mozilla Firefox folder in Local
But did you do anything to move the "Program Files" directory? You can check by typing %ProgramFiles(x86)% in the Win7 "Search programs and files" box in the start menu and pressing enter. The current Program Files directory for 32 bit programs should open in explorer.
(Reporter)

Comment 11

7 years ago
No I did not do any changes to Win 7. The C:\Program Files (x86)\Mozilla Firefox folder still exists. I am not even more surprised!! Why does FF install in C:\Program Files (x86)\Mozilla Firefox  when I specify d:\Program Files\Mozilla Firefox during installation
Please attach the install.log file from the C:\Program Files (x86)\Mozilla Firefox directory and I'll answer your question.
(Reporter)

Comment 13

7 years ago
There is none

It just has 3 folders
components
extensions
plugins

Does that mean its footprints from some old installation? I usually install everything in D:
So, it isn't installed in "C:\Program Files (x86)\Mozilla Firefox". At some point it was either installed in "C:\Program Files (x86)\Mozilla Firefox" and additional files were installed in one or more of the sub-directories by a 3rd party which will prevent removal of the directories when it is uninstalled or possibly a 3rd party preinstalled files into those directories.

When you change the install directory to a directory outside of the default directory under the appropriate program files directory (typically C:\Program Files (x86)\Mozilla Firefox on x64) then you have to set the permissions on the directory and chances are the permissions aren't set up properly.

Please attach the following files if present:
d:\Program Files\Mozilla Firefox\active-update.xml
d:\Program Files\Mozilla Firefox\updates\last-update.log
d:\Program Files\Mozilla Firefox\updates\backup-update.log
Summary: Software Update Failed → Software Update Failed in user created directory outside of Program Files
(Reporter)

Comment 15

7 years ago
Created attachment 557543 [details]
active-update.xml
Attachment #557543 - Attachment mime type: text/plain → text/xml
(Reporter)

Comment 16

7 years ago
The other 2 files do not exist d:\Program Files\Mozilla Firefox\updates\. 
There  is a 0 folder in d:\Program Files\Mozilla Firefox\updates\. I am guessing that is the downloaded update file

Can I delete C:\Program Files (x86)\Mozilla Firefox manually?

Is it being used?
(In reply to Vyas from comment #16)
> The other 2 files do not exist d:\Program Files\Mozilla Firefox\updates\. 
> There  is a 0 folder in d:\Program Files\Mozilla Firefox\updates\. I am
> guessing that is the downloaded update file
To fix updates on your system you will need to grant your account full control on the d:\Program Files\Mozilla Firefox\ directory and reset the permissions on all of its contents by doing the following:
Exit Firefox if it is running
Open the properties on the following directory
d:\Program Files\Mozilla Firefox\
Select the security tab
Click advanced
Click change permissions
Click add and add your account and check full control in the enable column
Check Replace all child object permissions with inheritable permissions for this object.

You might need to delete the active-update.xml and updates.xml files and the updates directory.

After you finish the above try updating again.


> Can I delete C:\Program Files (x86)\Mozilla Firefox manually?
Yes

> Is it being used?
No
(Reporter)

Comment 18

7 years ago
I gave all permissions to the d:\Program Files\Mozilla Firefox\ directory. Deleted active-update.xml and updates.xml files and the updates directory.

After starting Firefox -> Help-> About. It started downloading update but when I apply update I have the same issue.
Is there an update.mar file in the following directory?
d:\Program Files\Mozilla Firefox\updates\0\

If present please attach the following files:
d:\Program Files\Mozilla Firefox\updates\0\update.log
d:\Program Files\Mozilla Firefox\updates\last-update.log
(Reporter)

Comment 20

7 years ago
Created attachment 557557 [details]
update log
(Reporter)

Comment 21

7 years ago
 update.mar  is present, hence I uploaded update.log but d:\Program Files\Mozilla Firefox\updates\last-update.log is missing

I am guessing that FireFox was never updated after installing 7 beta
Couple of notes:

The update is failing with
rename_file: failed to rename file - src: firefox.exe, dst:firefox.exe.moz-backup, err: 13

The firefox.exe.moz-backup doesn't exist so it isn't due to there already being one.

Also, on launch the update code is unable to rename or move
d:\Program Files\Mozilla Firefox\updates\0\update.log
to
d:\Program Files\Mozilla Firefox\updates\last-update.log
(Reporter)

Comment 23

7 years ago
Yes I saw that.  It has all permissions now
When you say it has all permissions now do you mean that you have changed the permissions since the last change which was noted in comment #18? If so, has it made a difference?
(Reporter)

Comment 25

7 years ago
I have also used "Run as administrator" and it makes no difference
(Reporter)

Comment 27

7 years ago
(In reply to Robert Strong [:rstrong] (do not email) from comment #24)
> When you say it has all permissions now do you mean that you have changed
> the permissions since the last change which was noted in comment #18? 
No

> If so,has it made a difference?
NA
(Reporter)

Comment 28

7 years ago
It seems I am having the same issue with Thunderbird as well. I m using 6.0 and on the release channel update.
(Reporter)

Comment 29

7 years ago
Any updates?
Not at present except to say that chances are it is a permissions problem on the directory.
(Reporter)

Comment 31

7 years ago
Do you want to log into my computer and check or do you need any other screen shots?
Regretfully I won't have time to look at this in the near future. I suspect that if you install into the default location under program files it will work properly as long as you are a member of the admin group with UAC turned on.
(Reporter)

Comment 33

7 years ago
Can I increase the  importance of this issue? 

If we cannot install the product on other locations other than the default we should not be providing user option to alter path.
It does work when installed outside of program files as long as the permissions for the directories are set to allow it. There are a couple of major projects that are of a higher priority since this doesn't affect the majority of users. If you can figure out the correct permissions it would help though.
(Reporter)

Comment 35

7 years ago
I will take a look but I tried all other permission settings as described above

Comment 36

7 years ago
Vyas, what were you able to determine?

Comment 37

6 years ago
there is a simple solution to this.
go to C:\Program Files (x86)\Mozilla Firefox

rename firefox.exe to afirefox.exe
double click afirefox.exe, it will invoke firefox, create a new firefox.exe and everything seems to work from there !

delete afirefox.exe

Comment 38

6 years ago
I can confirm the above is a suitable workaround for me.

The patch updates have never worked for me *ever* for either Thunderbird or  Firefox. The pertinent record from the log is perhaps: "rename_file: failed to rename file - src: firefox.exe, dst:firefox.exe.moz-backup, err: 13", but I have full access perms.

I have the programs installed on a Samba server however, so perhaps that influences things. Still, renaming the exe solves them, so it'd be nice for you guys to alter your updater with this behaviour! :)

Comment 39

6 years ago
Same problem on ESR 10.0.0->10.0.1, with the ESR installed in C:\Program Files\Mozilla Firefox ESR.  WinXP Pro 2002 SP3, running as local administrator.  I tried the permissions change per comment #17 with no success.  I also tried renaming firefox.exe to afirefox.exe per comment #37, but I got "unable to open destination file: firefox.exe, err: 2" in the update log, and a dialog box that the partial update had failed and it was going to try a full update.  Could we please at least mark this confirmed?

Comment 40

6 years ago
Created attachment 597924 [details]
Update log, patch update 10.0.0esr->10.0.1esr
(In reply to christopher.white from comment #39)
> Same problem on ESR 10.0.0->10.0.1, with the ESR installed in C:\Program
> Files\Mozilla Firefox ESR.  WinXP Pro 2002 SP3, running as local
> administrator.  I tried the permissions change per comment #17 with no
> success.  I also tried renaming firefox.exe to afirefox.exe per comment #37,
> but I got "unable to open destination file: firefox.exe, err: 2" in the
> update log, and a dialog box that the partial update had failed and it was
> going to try a full update.  Could we please at least mark this confirmed?
Per the bug summary "outside of Program Files" this is a different bug. Christopher, please file a new bug.

Comment 43

6 years ago
@rstrong: Done - bug 733006
(Reporter)

Comment 44

6 years ago
I can confirm that this is not related to moving of Program Files directory. Also, I am surprised this is not yet confirmed. 

I have now installed Firefox in default c:\Program Files directory (new machine) and I still have same problem during updates!

Comment 45

3 years ago
(In reply to Vyas from comment #44)
> I have now installed Firefox in default c:\Program Files directory (new
> machine) and I still have same problem during updates!

Vyas, do you still see this?
Flags: needinfo?(ejvyas)
Summary: Software Update Failed in user created directory outside of Program Files → Software Update Failed for Firefox and Thunderbird. "The update could not be installed ..."
(Reporter)

Comment 46

3 years ago
Its been almost 4 yrs since I raise this. I do not have the access to any Windows 7 machine to test this. If no one else is facing this please close the issue
Flags: needinfo?(ejvyas)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME

Comment 47

2 years ago
This seems to be an issue that occurs when another program launches or has a process handle on firefox. Using Process Hacker I searched for firefox and found a process that kept firefox active and prevented me from changing the filename as a test. By closing the launcher/unhooking the handle I was able to update firefox again.
You need to log in before you can comment on or make changes to this bug.