W3C CUAP: allow the user to view all metadata

VERIFIED FIXED in mozilla1.1alpha

Status

Core Graveyard
Tracking
VERIFIED FIXED
18 years ago
2 years ago

People

(Reporter: gerv, Unassigned)

Tracking

({meta})

Trunk
mozilla1.1alpha
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

[ This bug is one of the recommendations in the W3C's "Common User Agent 
Problems" document, URL above. One bug has been filed on each recommendation, 
for deciding whether we do it and, if not, whether we should. ]

1.9 When a Web resource includes metadata that may be recognized by the
user agent, allow the user to view that metadata.

     Metadata – data about data – can provide very useful context to users
     about information on the Web. For instance, metadata about a book
     might include the book's author, title, publication date, publisher,
     etc. (refer to the Dublin Core [DC] for information about library-type
     metadata). Authors include metadata in HTML documents through a
     variety of elements and attributes (e.g., the TITLE and ADDRESS
     elements, the "alt", "title", and "summary" attributes, etc. Languages
     such as the Resource Description Framework [RDF] allow users to
     populate the Web with rich metadata. User agents should provide a user
     interface to allow users to view metadata. The user interface may vary
     according to the underlying markup language. For instance, many
     graphical browsers render the HTML "title" attribute (e.g., as a
     tool-tip) when the user selects or hovers over an element with that
     attribute specified.
Blocks: 68427
Does bug 2800 cover the entirety of this, or just a part?

Gerv

Comment 2

18 years ago
This is a dup of bug 1995 and bug 52730.


*** This bug has been marked as a duplicate of 1995 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Keywords: verifyme
Resolution: --- → DUPLICATE
The bug, which is about compliance with the guidelines, is blocked by bug 1995
and 52730. Marking as such, and reopening. We should only close this bug when we
comply :-)

Gerv
Status: RESOLVED → REOPENED
Depends on: 1995, 52730
Resolution: DUPLICATE → ---

Comment 4

18 years ago
No, this bug is not about compliance with the guidelines; bug 68427 is about 
compliance with the guidelines. Bug 1995 covers 99 percent of guideline 1.9; bug 
52730 covers the other 1 percent, stuff which isn't even mentioned explicitly in 
that guideline. That's why I resolved this bug as a duplicate of 1995.

So if you're going to be like that, you can get out of my component. :-P
-->Tracking
Component: User Interface: Design Feedback → Tracking
Keywords: verifyme
Hardware: PC → All

Comment 5

18 years ago
Isn't a lot of metadata intended for indexers and not for users?  Maybe I'm 
interpreting that word incorrectly.  Cc hixie.

Comment 6

18 years ago
change qa
Status: REOPENED → NEW
QA Contact: mpt → gervase.markham

Comment 7

17 years ago
Not sure who should own this bug, sending to QA contact for assistance.
Assignee: hangas → gervase.markham
Rereading this recommendation, it seems very vague. We already have a pretty 
good metadata story, what with the TITLE stuff and the LINK toolbar. And I think 
someone is probably on the case with the rest.

Pushing to 1.1; re-evaluate post 1.0 when we can see exactly what is left to do 
on the metadata thing.

Gerv
Target Milestone: --- → mozilla1.1

Updated

17 years ago
Depends on: 73992
This has been fixed with the "properties" window from bug 1995. Feel free to
mark as fixed
This bug stays open until we do something sensible with Dublin Core metadata :-)

Gerv

Updated

17 years ago
Depends on: 82059

Updated

17 years ago
No longer depends on: 52730

Comment 11

17 years ago
Adding meta keyword.Sorry for the spam!
Keywords: meta
Not mine.

Gerv
Assignee: gerv → nobody
We now display all metadata in the Page Info window; I think we can close this one.

Gerv
Status: NEW → RESOLVED
Last Resolved: 18 years ago16 years ago
Resolution: --- → FIXED

Comment 14

16 years ago
I agree with Gerv.
Status: RESOLVED → VERIFIED
(Assignee)

Updated

2 years ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.