Last Comment Bug 68413 - W3C CUAP: Allow the user to bookmark negotiated resources
: W3C CUAP: Allow the user to bookmark negotiated resources
Status: RESOLVED EXPIRED
:
Product: SeaMonkey
Classification: Client Software
Component: Bookmarks & History (show other bugs)
: Trunk
: x86 All
: P5 enhancement (vote)
: Future
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
http://www.w3.org/TR/2001/NOTE-cuap-2...
Depends on:
Blocks: 68427
  Show dependency treegraph
 
Reported: 2001-02-10 01:30 PST by Gervase Markham [:gerv]
Modified: 2010-04-28 13:06 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Gervase Markham [:gerv] 2001-02-10 01:30:49 PST
[ This bug is one of the recommendations in the W3C's "Common User Agent 
Problems" document, URL above. One bug has been filed on each recommendation, 
for deciding whether we do it and, if not, whether we should. ]

1.11 Allow the user to bookmark negotiated resources.

     The HTTP/1.1 protocol [RFC2616] allows the client to request a
     representation of a resource which is best suited to its needs
     (language, media type, etc); this mechanism is called "content
     negotiation".

     When a resource is negotiated, the user might want to bookmark a
     particular version. For example, a document might be available in
     several languages under the same URI, and the user might want to point
     somebody to the Canadian version of this document, which has a
     different URI.

     In such a case, it should be possible to bookmark either the original
     URI or the URI of the view that the user got. The original URI can be
     interpreted as being the generic object and the retrieved document as
     one view of this object.
Comment 1 Matthew Paul Thomas 2001-02-10 03:53:49 PST
I don't think this is feasible. If it is important to be able to refer to 
particular negotiated versions, the Web site in question should provide the 
ability to reference them by CGI URL (e.g. <http://mozilla.org/?lang=jp>).

Allowing bookmarking of negotiated resources makes as much sense as allowing 
bookmarking of:
*   pages that result from a particular selection of cookies on the user's
    system
*   pages that result from a particular selection of supported filetypes on the
    user's system 
*   pages shown in a particular user style sheet
*   pages with a particular DOM state.
Comment 2 Andreas M. "Clarence" Schneider 2001-02-10 20:00:24 PST
For server-driven negotiation we always bookmark negotiated resources (unless
the Accept-* headers are changed). I see no sense in storing the actually used
Accept-* headers. Anyway, different results of server-driven negotiation do not
have different URIs the user agent is aware of.

For agent-driven negotiation: Do we support that? Is there any standard for it
(HTTP/1.1 does not define one)? Does any server support it?

IMO, this bug should be resolved to INVALID or WONTFIX.
Comment 3 Olivier Mengué 2001-10-08 09:41:32 PDT
In fact, the client is not able to know that a negociation occured on the 
server, so we would have to either always or never prompt the user to save the 
Accept-* headers with the bookmark.
Usually, negociation occurs for user language, file format (image for example), 
and plugin availability. User language should always be the one inf Prefs. The 
others are dependent on the software installation which may change, and it is 
probably better to let the user benefits of his system improvements.

Maybe we can consider that bookmarking negotiated resources is saving 
preferences ?

I propoose to
- change severity to enhancement, even if it shouldn't be anything at all.
- platform to All. 
- riority P5.

I agree with Andreas to resolve this bug to WONTFIX.
Comment 4 Ben Goodger (use ben at mozilla dot org for email) 2001-10-19 17:29:04 PDT
Paul Chen is now taking Bookmarks bugs. For your convenience, you can filter 
email notifications caused by this by searching for 'ilikegoats'.

Comment 5 Paul Chen 2001-10-23 09:53:57 PDT
Mass move Ben's bugs dumped on me marked future with p5 to get off my untriaged
radar. You can filter out this email by looking for "ironstomachaussie"
Comment 6 Peter Trudelle 2002-01-05 15:33:37 PST
mass reassign of pchen bookmark bugs to ben
Comment 7 Chris Lyon 2002-11-16 17:35:34 PST
->enhancement
Comment 8 Robert Kaiser 2009-06-14 08:07:59 PDT
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Comment 9 Robert Kaiser 2009-06-14 08:12:16 PDT
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Comment 10 Robert Kaiser 2009-06-14 08:19:51 PDT
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Comment 11 Robert Kaiser 2009-06-14 09:31:46 PDT
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Comment 12 Robert Kaiser 2009-06-14 09:37:46 PDT
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Comment 13 Robert Kaiser 2009-06-14 17:28:22 PDT
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Comment 14 Robert Kaiser 2010-04-28 13:06:29 PDT
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but still has no comment since the inception of the SeaMonkey project 5 years ago.

Because of this, we're resolving the bug as EXPIRED.

If you still can reproduce the bug on SeaMonkey 2 or otherwise think it's still valid, please REOPEN it and if it is a platform or toolkit issue, move it to the according component.

Query tag for this change: EXPIRED-20100420

Note You need to log in before you can comment on or make changes to this bug.