Last Comment Bug 684561 - Improve styling of Web Console on Windows
: Improve styling of Web Console on Windows
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Developer Tools (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Firefox 9
Assigned To: (Away 6/25-7/4) Jared Wein [:jaws] (reviews and needinfo disabled until back)
:
Mentors:
Depends on: 599498 686778
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-03 22:10 PDT by (Away 6/25-7/4) Jared Wein [:jaws] (reviews and needinfo disabled until back)
Modified: 2011-09-14 14:37 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Screenshot of the bug (9.32 KB, image/png)
2011-09-03 22:10 PDT, (Away 6/25-7/4) Jared Wein [:jaws] (reviews and needinfo disabled until back)
no flags Details
Patch for bug 684561 (1.81 KB, patch)
2011-09-04 20:53 PDT, (Away 6/25-7/4) Jared Wein [:jaws] (reviews and needinfo disabled until back)
dao+bmo: review-
Details | Diff | Review
Screenshot of the patch (11.72 KB, image/png)
2011-09-04 20:55 PDT, (Away 6/25-7/4) Jared Wein [:jaws] (reviews and needinfo disabled until back)
faaborg: feedback+
Details
Patch for bug 684561 v2 (2.60 KB, patch)
2011-09-05 01:03 PDT, (Away 6/25-7/4) Jared Wein [:jaws] (reviews and needinfo disabled until back)
dao+bmo: review-
Details | Diff | Review
Patch for bug 684561 v3 (3.06 KB, patch)
2011-09-05 02:38 PDT, (Away 6/25-7/4) Jared Wein [:jaws] (reviews and needinfo disabled until back)
dao+bmo: review+
Details | Diff | Review

Description (Away 6/25-7/4) Jared Wein [:jaws] (reviews and needinfo disabled until back) 2011-09-03 22:10:53 PDT
Created attachment 558120 [details]
Screenshot of the bug

We should add some margins between the filter buttons, and place the close button on the right-side.

See attached screenshot for details.
Comment 1 (Away 6/25-7/4) Jared Wein [:jaws] (reviews and needinfo disabled until back) 2011-09-04 20:53:32 PDT
Created attachment 558213 [details] [diff] [review]
Patch for bug 684561

Moved the close button to the right side and added some margins between the buttons.
Comment 2 (Away 6/25-7/4) Jared Wein [:jaws] (reviews and needinfo disabled until back) 2011-09-04 20:55:24 PDT
Created attachment 558214 [details]
Screenshot of the patch
Comment 3 Dão Gottwald [:dao] 2011-09-05 00:20:53 PDT
Comment on attachment 558213 [details] [diff] [review]
Patch for bug 684561

HUDService.jsm should append the close button to the end in the DOM (except for OS X maybe).
Comment 4 (Away 6/25-7/4) Jared Wein [:jaws] (reviews and needinfo disabled until back) 2011-09-05 01:03:13 PDT
Created attachment 558241 [details] [diff] [review]
Patch for bug 684561 v2

Updated HUDService.jsm to place the close button at the end of the DOM if not on OS X.
Comment 5 Dão Gottwald [:dao] 2011-09-05 01:12:03 PDT
Comment on attachment 558241 [details] [diff] [review]
Patch for bug 684561 v2

>-    this.makeCloseButton(toolbar);
>+    let osString = Cc["@mozilla.org/xre/app-info;1"].
>+                   getService(Ci.nsIXULRuntime).OS;
>+    if (osString == "Darwin")
>+      this.makeCloseButton(toolbar);
> 
>     for (let i = 0; i < BUTTONS.length; i++) {
>       this.makeFilterButton(toolbar, BUTTONS[i]);
>     }
> 
>     toolbar.appendChild(this.filterSpacer);
> 
>     let positionUI = this.createPositionUI();
>     toolbar.appendChild(positionUI);
> 
>     toolbar.appendChild(this.filterBox);
>     this.makeClearConsoleButton(toolbar);
> 
>+    if (osString != "Darwin")
>+      this.makeCloseButton(toolbar);

This should use ifdefs. Look for EXTRA_PP_JS_MODULES for how to enable this.

>+.webconsole-filter-button > .toolbarbutton-menubutton-button,
>+.webconsole-filter-button > .toolbarbutton-menubutton-button:hover:active {
>+  -moz-padding-start: 6px !important;
>+  -moz-padding-end: 3px !important;
>+}

Why is !important needed here?
Does -moz-padding-end actually change something? I can't see it in the screenshots.
Comment 6 (Away 6/25-7/4) Jared Wein [:jaws] (reviews and needinfo disabled until back) 2011-09-05 02:38:16 PDT
Created attachment 558250 [details] [diff] [review]
Patch for bug 684561 v3

The !important rules were a carry-over from previous tweaks and weren't needed. Thank you for catching them.

I have attempted (and it appears I was successful), at using EXTRA_PP_JS_MODULES, but I am not sure if I used it the way that you meant.
Comment 7 (Away 6/25-7/4) Jared Wein [:jaws] (reviews and needinfo disabled until back) 2011-09-05 02:43:51 PDT
> Does -moz-padding-end actually change something? I can't see it in the
> screenshots.

I forgot to mention that -moz-padding-end is needed because there is a rule in toolbarbutton.css sets the padding to 2px on :hover:active, causing the toolbarbutton to shrink by 1 pixel.
Comment 8 Rob Campbell [:rc] (:robcee) 2011-09-06 14:47:42 PDT
Sweet! Thanks for doing this. :)
Comment 9 (Away 6/25-7/4) Jared Wein [:jaws] (reviews and needinfo disabled until back) 2011-09-06 16:46:06 PDT
http://hg.mozilla.org/integration/fx-team/rev/d1c042be8802
Comment 10 Tim Taubert [:ttaubert] 2011-09-08 02:36:38 PDT
http://hg.mozilla.org/mozilla-central/rev/d1c042be8802

Note You need to log in before you can comment on or make changes to this bug.