HTML editors don't accept links/text by dnd, gfx don't accept links

VERIFIED INVALID

Status

()

--
major
VERIFIED INVALID
18 years ago
17 years ago

People

(Reporter: bugzilla, Assigned: mozeditor)

Tracking

({regression})

Trunk
x86
Windows 2000
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
Build ID: 2001020904

Steps to Reproduce:

(1) Go to http://bugzilla.mozilla.org/
(2) Start dragging a link, try to drop it into the textfield.
(3) Start dragging text from the page, try to drop it into the textfield.
(4) Start dragging a link, try to drop it into the URL bar.

Result: on dragover of the textfield (steps 2,3) and the URL bar (step 4), you 
aren't allowed to drop (the 'no-drop' cursor appears).

Additional Information:

* These may be Windows-only problems (Ben said he didn't see them on Mac).

* With Ben's recent dnd changes (bug 64722) backed out, removing these lines:

      if (aDragSession.sourceDocument == window._content.document)
        aDragSession.canDrop = false;

  (which were intended to ensure that you can't drop content dragged from a
  page into the same page) from contentAreaDD.js fixes problems 2 and 3. With 
  Ben's changes in, removing these lines does *not* fix either problem.  These
  lines have always existed, and drops into html textfields used to work
  anyways.

* These problems still existed when Ben's recent dnd changes were backed out.
  Upon backing out Joe's fix for bug 66290, all of these problems went away.

* Backing out Kathy's recent changes to nsEditorEventListeners.cpp had no effect
  on any of the problems.

* See also: bug 64722, bug 66290, bug 68058, bug 67109.
(Reporter)

Updated

18 years ago
Severity: normal → major
Keywords: mozilla0.8, nsbeta1, regression
Whiteboard: critical for 0.8
(Reporter)

Comment 1

18 years ago
Looks like this might be Ben after all.  See 68058.
Keywords: mozilla0.8, nsbeta1
Whiteboard: critical for 0.8
(Reporter)

Comment 2

18 years ago
marking invalid.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID

Comment 3

18 years ago
also, look at bug 67853

Comment 4

18 years ago
verified in 2/12 build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.